aboutsummaryrefslogtreecommitdiffstats
path: root/x11/dmenu/Makefile
diff options
context:
space:
mode:
authorscheidell <scheidell@FreeBSD.org>2012-02-15 05:25:17 +0800
committerscheidell <scheidell@FreeBSD.org>2012-02-15 05:25:17 +0800
commitc49250701f6f1e2110ed045fea4b05cc0965a520 (patch)
treeeb1fb8238ebbc72a6d7f3471d218d738d8b6125a /x11/dmenu/Makefile
parent0006556d6f06a47e75d6b1c77e1d1eb758085e27 (diff)
downloadfreebsd-ports-gnome-c49250701f6f1e2110ed045fea4b05cc0965a520.tar.gz
freebsd-ports-gnome-c49250701f6f1e2110ed045fea4b05cc0965a520.tar.zst
freebsd-ports-gnome-c49250701f6f1e2110ed045fea4b05cc0965a520.zip
- Upgrade to 4.5 [1]
- Add optional XFS support [1] (default off) [2] - Revised patch by maintainer [2] PR: ports/164012 Submitted by: Aragon Gouveia <aragon@phat.za.net> [1] Approved by: Jeroen Schot <schot@A-Eskwadraat.nl> (maintainer), gabor (mentor, implicit)
Diffstat (limited to 'x11/dmenu/Makefile')
-rw-r--r--x11/dmenu/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/x11/dmenu/Makefile b/x11/dmenu/Makefile
index a475dce30f5d..30c021294a33 100644
--- a/x11/dmenu/Makefile
+++ b/x11/dmenu/Makefile
@@ -6,23 +6,28 @@
#
PORTNAME= dmenu
-PORTVERSION= 4.4.1
+PORTVERSION= 4.5
CATEGORIES= x11
MASTER_SITES= http://dl.suckless.org/tools/ \
http://schot.a-eskwadraat.nl/files/
+PATCH_SITES= http://tools.suckless.org/dmenu/patches/ \
+ http://schot.a-eskwadraat.nl/files/
+PATCH_DIST_STRIP=-p1
+
MAINTAINER= schot@a-eskwadraat.nl
COMMENT= X11 menu application designed for the dwm window manager
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-OPTIONS= XINERAMA "Enable Xinerama support" On
+OPTIONS= XINERAMA "Enable Xinerama support" On \
+ XFT "Enable Xft support" Off
USE_XORG= x11
-MAN1= dmenu.1 lsx.1
-PLIST_FILES= bin/dmenu bin/dmenu_run bin/lsx
+MAN1= dmenu.1 stest.1
+PLIST_FILES= bin/dmenu bin/dmenu_run bin/stest
.include <bsd.port.options.mk>
@@ -30,6 +35,11 @@ PLIST_FILES= bin/dmenu bin/dmenu_run bin/lsx
USE_XORG+= xinerama
.endif
+.if defined(WITH_XFT)
+USE_XORG+= xft
+PATCHFILES+= ${PORTNAME}-${PORTVERSION}-xft.diff
+.endif
+
post-patch:
@${GREP} -Rl '%%[[:alpha:]]\+%%' ${WRKSRC}|${XARGS} ${REINPLACE_CMD} \
-e "s,%%PREFIX%%,${PREFIX},g" \