aboutsummaryrefslogtreecommitdiffstats
path: root/x11/e17-module-mem
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-06-25 01:46:15 +0800
committeritetcu <itetcu@FreeBSD.org>2006-06-25 01:46:15 +0800
commitea169809d8187187eb82b6cff6b54ede4a2184b9 (patch)
tree94ea42e09f4c42140a6afe23e8d2569fe975dbea /x11/e17-module-mem
parentc251557ccfa63fa30670b8e27bc1370792d61390 (diff)
downloadfreebsd-ports-gnome-ea169809d8187187eb82b6cff6b54ede4a2184b9.tar.gz
freebsd-ports-gnome-ea169809d8187187eb82b6cff6b54ede4a2184b9.tar.zst
freebsd-ports-gnome-ea169809d8187187eb82b6cff6b54ede4a2184b9.zip
An E17 module which monitors the RAM usage. It features the following:
- display text and/or graph - display text in percentage or absolute Author: Matthew Mullins WWW: http://www.enlightenment.org PR: ports/99365 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
Diffstat (limited to 'x11/e17-module-mem')
-rw-r--r--x11/e17-module-mem/Makefile36
-rw-r--r--x11/e17-module-mem/distinfo3
-rw-r--r--x11/e17-module-mem/files/patch-configure11
-rw-r--r--x11/e17-module-mem/pkg-descr6
-rw-r--r--x11/e17-module-mem/pkg-plist37
5 files changed, 93 insertions, 0 deletions
diff --git a/x11/e17-module-mem/Makefile b/x11/e17-module-mem/Makefile
new file mode 100644
index 000000000000..5a5fe517cecf
--- /dev/null
+++ b/x11/e17-module-mem/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e17-module-mem
+# Date created: 23 June 2006
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mem
+PORTVERSION= 23062006
+CATEGORIES= x11
+MASTER_SITES= http://mbsd.msk.ru/dist/
+PKGNAMEPREFIX= e17-module-
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An e17 memory monitoring module
+
+BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/e17-module-mem/distinfo b/x11/e17-module-mem/distinfo
new file mode 100644
index 000000000000..9d89499b0331
--- /dev/null
+++ b/x11/e17-module-mem/distinfo
@@ -0,0 +1,3 @@
+MD5 (mem-23062006.tar.bz2) = dff9e3cad99d050232dc4d0df0a9c201
+SHA256 (mem-23062006.tar.bz2) = c0466c3d9449fd85c935c99ab38d470bfd0ff62d8e30cb37fd23765bad6978dd
+SIZE (mem-23062006.tar.bz2) = 426819
diff --git a/x11/e17-module-mem/files/patch-configure b/x11/e17-module-mem/files/patch-configure
new file mode 100644
index 000000000000..6c90622c5b13
--- /dev/null
+++ b/x11/e17-module-mem/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Fri Jun 23 16:49:21 2006
++++ configure Fri Jun 23 16:49:32 2006
+@@ -23390,7 +23390,7 @@
+
+
+
+-MODULE_ARCH="$host_os-$host_cpu"
++MODULE_ARCH=""
+
+
+ cat >>confdefs.h <<_ACEOF
diff --git a/x11/e17-module-mem/pkg-descr b/x11/e17-module-mem/pkg-descr
new file mode 100644
index 000000000000..a68c0ab3c5b7
--- /dev/null
+++ b/x11/e17-module-mem/pkg-descr
@@ -0,0 +1,6 @@
+An E17 module which monitors the RAM usage. It features the following:
+- display text and/or graph
+- display text in percentage or absolute
+
+Author: Matthew Mullins
+WWW: http://www.enlightenment.org
diff --git a/x11/e17-module-mem/pkg-plist b/x11/e17-module-mem/pkg-plist
new file mode 100644
index 000000000000..8462c820b7f1
--- /dev/null
+++ b/x11/e17-module-mem/pkg-plist
@@ -0,0 +1,37 @@
+lib/enlightenment/modules/mem/DejaVuSansMono.ttf
+lib/enlightenment/modules/mem/mem.edc
+lib/enlightenment/modules/mem/mem.edj
+lib/enlightenment/modules/mem/module.a
+lib/enlightenment/modules/mem/module.eap
+lib/enlightenment/modules/mem/module.la
+lib/enlightenment/modules/mem/module.so
+lib/enlightenment/modules/mem/module_icon.png
+lib/enlightenment/modules/mem/real_00.png
+lib/enlightenment/modules/mem/real_01.png
+lib/enlightenment/modules/mem/real_02.png
+lib/enlightenment/modules/mem/real_03.png
+lib/enlightenment/modules/mem/real_04.png
+lib/enlightenment/modules/mem/real_05.png
+lib/enlightenment/modules/mem/real_06.png
+lib/enlightenment/modules/mem/real_07.png
+lib/enlightenment/modules/mem/real_08.png
+lib/enlightenment/modules/mem/real_09.png
+lib/enlightenment/modules/mem/real_10.png
+lib/enlightenment/modules/mem/swap_00.png
+lib/enlightenment/modules/mem/swap_01.png
+lib/enlightenment/modules/mem/swap_02.png
+lib/enlightenment/modules/mem/swap_03.png
+lib/enlightenment/modules/mem/swap_04.png
+lib/enlightenment/modules/mem/swap_05.png
+lib/enlightenment/modules/mem/swap_06.png
+lib/enlightenment/modules/mem/swap_07.png
+lib/enlightenment/modules/mem/swap_08.png
+lib/enlightenment/modules/mem/swap_09.png
+lib/enlightenment/modules/mem/swap_10.png
+%%NLS%%share/locale/eo/LC_MESSAGES/mem.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/mem.mo
+%%NLS%%share/locale/it/LC_MESSAGES/mem.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/mem.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/mem.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/mem.mo
+@dirrm lib/enlightenment/modules/mem