aboutsummaryrefslogtreecommitdiffstats
path: root/x11/e17-module-weather
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
committerstas <stas@FreeBSD.org>2006-10-08 21:48:37 +0800
commit173755349dc2dd22744f67ee65b533ef3b1c3649 (patch)
treefcddf9b33a006f3b495b40ac5641012787c2a99e /x11/e17-module-weather
parented21c3e01f7d2d837804666f445b9249d985c327 (diff)
downloadfreebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.gz
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.tar.zst
freebsd-ports-gnome-173755349dc2dd22744f67ee65b533ef3b1c3649.zip
- Move to LOCALBASE
- Use new EFL framework - Update all e17 ports to the lates stable cvs snapshot - Add additional knobs/options to ports makefiles to control the feature set - Add a bunch of new e17 applications/libraries - Minor improvements/modification. Approved by: vanilla (old maintainer), sem (mentor)
Diffstat (limited to 'x11/e17-module-weather')
-rw-r--r--x11/e17-module-weather/Makefile26
-rw-r--r--x11/e17-module-weather/distinfo6
-rw-r--r--x11/e17-module-weather/files/patch-e_mod_main.c12
-rw-r--r--x11/e17-module-weather/pkg-plist17
4 files changed, 25 insertions, 36 deletions
diff --git a/x11/e17-module-weather/Makefile b/x11/e17-module-weather/Makefile
index 8d4ccdd37b55..458c9d203ff7 100644
--- a/x11/e17-module-weather/Makefile
+++ b/x11/e17-module-weather/Makefile
@@ -6,27 +6,25 @@
#
PORTNAME= weather
-PORTVERSION= 23062006
-PORTREVISION= 2
+PORTVERSION= 20060926
+PORTREVISION= 0
+PORTEPOCH= 1
CATEGORIES= x11
-MASTER_SITES= http://mbsd.msk.ru/dist/
+MASTER_SITES= http://sunner.elcomnet.ru/~stas/
PKGNAMEPREFIX= e17-module-
DISTNAME= ${PORTNAME}-${PORTVERSION}
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= An e17 weather module
-BUILD_DEPENDS= enlightenment:${PORTSDIR}/x11-wm/enlightenment-devel
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+RUN_DEPENDS= enlightenment-config:${PORTSDIR}/x11-wm/enlightenment-devel
+GNU_CONFIGURE= yes
USE_BZIP2= yes
-USE_X_PREFIX= yes
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-
-PLIST_SUB+= MODULE_ARCH=freebsd${OSREL}-${ARCH}
+USE_GNOME= gnometarget pkgconfig
+USE_EFL= edje
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
@@ -36,4 +34,6 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
+.include <bsd.port.post.mk>
diff --git a/x11/e17-module-weather/distinfo b/x11/e17-module-weather/distinfo
index 286d80bf9239..51bc6124cecc 100644
--- a/x11/e17-module-weather/distinfo
+++ b/x11/e17-module-weather/distinfo
@@ -1,3 +1,3 @@
-MD5 (weather-23062006.tar.bz2) = ea95150b91bd794e1c4d2381e4729a80
-SHA256 (weather-23062006.tar.bz2) = 4847c88494e6f33424911464f91cfe696ae82e70ed512fd900e70a1123ce3ea8
-SIZE (weather-23062006.tar.bz2) = 941161
+MD5 (weather-20060926.tar.bz2) = 6bda3b61f7f026040865a262305fc9a4
+SHA256 (weather-20060926.tar.bz2) = 02371844b0d466d7a90ad47bef5e40470dec77aff07c8635cea4cf985ba384d3
+SIZE (weather-20060926.tar.bz2) = 948459
diff --git a/x11/e17-module-weather/files/patch-e_mod_main.c b/x11/e17-module-weather/files/patch-e_mod_main.c
deleted file mode 100644
index 64cfef8a20e0..000000000000
--- a/x11/e17-module-weather/files/patch-e_mod_main.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- e_mod_main.c.orig Thu Jul 6 23:05:04 2006
-+++ e_mod_main.c Thu Jul 6 23:05:19 2006
-@@ -354,7 +354,8 @@
- EAPI int
- e_modapi_about(E_Module *m)
- {
-- e_module_dialog_show(D_("Enlightenment Weather Module"), D_("A weather forecast module for Enlightenment"));
-+ e_module_dialog_show(m, D_("Enlightenment Weather Module"),
-+ D_("A weather forecast module for Enlightenment"));
- return 1;
- }
-
diff --git a/x11/e17-module-weather/pkg-plist b/x11/e17-module-weather/pkg-plist
index 66c078bb5d6f..bd4bcd2c0fbd 100644
--- a/x11/e17-module-weather/pkg-plist
+++ b/x11/e17-module-weather/pkg-plist
@@ -1,4 +1,6 @@
-lib/enlightenment/modules/weather/VeraBd.ttf
+lib/enlightenment/modules/weather/%%E17_ARCH%%/module.a
+lib/enlightenment/modules/weather/%%E17_ARCH%%/module.la
+lib/enlightenment/modules/weather/%%E17_ARCH%%/module.so
lib/enlightenment/modules/weather/images/blizzard.png
lib/enlightenment/modules/weather/images/blowingsnow.png
lib/enlightenment/modules/weather/images/chancetstorm.png
@@ -61,17 +63,16 @@ lib/enlightenment/modules/weather/images/unknown.png
lib/enlightenment/modules/weather/images/wind.png
lib/enlightenment/modules/weather/images/wswarning.png
lib/enlightenment/modules/weather/images/wswatch.png
-lib/enlightenment/modules/weather/%%MODULE_ARCH%%/module.a
-lib/enlightenment/modules/weather/module.eap
-lib/enlightenment/modules/weather/%%MODULE_ARCH%%/module.la
-lib/enlightenment/modules/weather/%%MODULE_ARCH%%/module.so
+lib/enlightenment/modules/weather/module.desktop
+lib/enlightenment/modules/weather/module.edj
lib/enlightenment/modules/weather/module_icon.png
-lib/enlightenment/modules/weather/vera.ttf
-lib/enlightenment/modules/weather/weather.edc
lib/enlightenment/modules/weather/weather.edj
%%NLS%%share/locale/eo/LC_MESSAGES/weather.mo
%%NLS%%share/locale/it/LC_MESSAGES/weather.mo
%%NLS%%share/locale/ja/LC_MESSAGES/weather.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/weather.mo
@dirrm lib/enlightenment/modules/weather/images
-@dirrm lib/enlightenment/modules/weather/%%MODULE_ARCH%%
+@dirrm lib/enlightenment/modules/weather/%%E17_ARCH%%
@dirrm lib/enlightenment/modules/weather
+@dirrmtry lib/enlightenment/modules
+@dirrmtry lib/enlightenment