aboutsummaryrefslogtreecommitdiffstats
path: root/x11/enity
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2007-03-15 15:34:30 +0800
committerstas <stas@FreeBSD.org>2007-03-15 15:34:30 +0800
commitd04e79e4ba17a2fccc0ce683c5084e345dfe3d35 (patch)
tree521f75156c192de04feadef0e272c8ea14905271 /x11/enity
parent02c41a78b0603e99edda63055fa6af0888c006b4 (diff)
downloadfreebsd-ports-gnome-d04e79e4ba17a2fccc0ce683c5084e345dfe3d35.tar.gz
freebsd-ports-gnome-d04e79e4ba17a2fccc0ce683c5084e345dfe3d35.tar.zst
freebsd-ports-gnome-d04e79e4ba17a2fccc0ce683c5084e345dfe3d35.zip
- Fix on !i386 by disabling invalid code. There's no known solution for this
problem currently. Reported by: kris
Diffstat (limited to 'x11/enity')
-rw-r--r--x11/enity/Makefile6
-rw-r--r--x11/enity/files/extra-patch-src_bin_enity.c21
2 files changed, 27 insertions, 0 deletions
diff --git a/x11/enity/Makefile b/x11/enity/Makefile
index 0a1779b80f15..0398b0aa7017 100644
--- a/x11/enity/Makefile
+++ b/x11/enity/Makefile
@@ -8,6 +8,7 @@
PORTNAME= enity
PORTVERSION= 20070223
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= ftp://ftp.springdaemons.com/pub/snapshots/e17/
@@ -23,5 +24,10 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/enity
.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-src_bin_enity.c
+.endif
+
.include "../../x11-wm/enlightenment-devel/bsd.efl.mk"
.include <bsd.port.post.mk>
diff --git a/x11/enity/files/extra-patch-src_bin_enity.c b/x11/enity/files/extra-patch-src_bin_enity.c
new file mode 100644
index 000000000000..ed23babe4d70
--- /dev/null
+++ b/x11/enity/files/extra-patch-src_bin_enity.c
@@ -0,0 +1,21 @@
+--- src/bin/enity.c.orig Thu Mar 15 09:55:46 2007
++++ src/bin/enity.c Thu Mar 15 09:57:47 2007
+@@ -378,7 +378,9 @@
+
+ valist[j] = NULL;
+
++/*
+ row = etk_tree_row_append(ETK_TREE(tree), NULL, (va_list)valist);
++*/
+ etk_tree_row_data_set(row, cols);
+ }
+ }
+@@ -585,7 +587,7 @@
+ /* --list options */
+ { "checklist", ' ', NULL, _en_list_check_cb, NULL, EN_ARGUMENT_FLAG_OPTIONAL, "Use check boxes for first column" },
+ { "column", ' ', NULL, _en_list_column_cb, NULL, EN_ARGUMENT_FLAG_OPTIONAL|EN_ARGUMENT_FLAG_VALUE_REQUIRED|EN_ARGUMENT_FLAG_MULTIVALUE, "Set the column header" },
+- { "list", ' ', NULL, _en_list_cb, NULL, EN_ARGUMENT_FLAG_OPTIONAL, "Display list dialog" },
++/* { "list", ' ', NULL, _en_list_cb, NULL, EN_ARGUMENT_FLAG_OPTIONAL, "Display list dialog" }, */
+
+ /* --progress options */
+ { "progress", ' ', NULL, _en_progress_cb, NULL, EN_ARGUMENT_FLAG_OPTIONAL, "Display progress indication dialog" },