aboutsummaryrefslogtreecommitdiffstats
path: root/x11/erun
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2008-03-12 05:41:35 +0800
committergahr <gahr@FreeBSD.org>2008-03-12 05:41:35 +0800
commitff3d315e48f54d366a6ad48b4095803f49c68143 (patch)
tree9478dbd36ed4ddedae872d7163e955f893f5f3ff /x11/erun
parent7d495d1d0991a14049597e56b623e66740b36619 (diff)
downloadfreebsd-ports-gnome-ff3d315e48f54d366a6ad48b4095803f49c68143.tar.gz
freebsd-ports-gnome-ff3d315e48f54d366a6ad48b4095803f49c68143.tar.zst
freebsd-ports-gnome-ff3d315e48f54d366a6ad48b4095803f49c68143.zip
- Fix build with new libepplet2
- Remove useless USE_PREFIX variable - Adopt maintainship Reported by: erwin Approved by: miwi (mentor)
Diffstat (limited to 'x11/erun')
-rw-r--r--x11/erun/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/x11/erun/Makefile b/x11/erun/Makefile
index 149b11252fb0..6bf03128dd58 100644
--- a/x11/erun/Makefile
+++ b/x11/erun/Makefile
@@ -7,24 +7,24 @@
PORTNAME= E-Run
PORTVERSION= 1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= kbyanc
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= A simple epplet for launching arbitrary programs
-LIB_DEPENDS= epplet.1:${PORTSDIR}/x11-wm/epplets
+LIB_DEPENDS= epplet.2:${PORTSDIR}/x11-wm/epplets \
+ Imlib2.4:${PORTSDIR}/graphics/imlib2
PLIST_FILES= bin/E-Run.epplet
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_X_PREFIX= yes
-
+USE_GL= gl
CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lepplet -lGL ${PTHREAD_LIBS}
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib -lepplet -lImlib2 -lGL ${PTHREAD_LIBS}
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} ${CPPFLAGS} -o ${PORTNAME}.epplet \