aboutsummaryrefslogtreecommitdiffstats
path: root/x11/etoile-iterm
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-12-19 14:49:03 +0800
committerdinoex <dinoex@FreeBSD.org>2006-12-19 14:49:03 +0800
commit9e000ed4e29f48a2207b1cef77d8957d58f4c80f (patch)
treeba044dbd47eb1b3204ede3af02d45335821315f1 /x11/etoile-iterm
parentfaff75ba6d29b6793c8543e38827a8a39257bef4 (diff)
downloadfreebsd-ports-gnome-9e000ed4e29f48a2207b1cef77d8957d58f4c80f.tar.gz
freebsd-ports-gnome-9e000ed4e29f48a2207b1cef77d8957d58f4c80f.tar.zst
freebsd-ports-gnome-9e000ed4e29f48a2207b1cef77d8957d58f4c80f.zip
- add include to build on sparc64, amd64
Diffstat (limited to 'x11/etoile-iterm')
-rw-r--r--x11/etoile-iterm/Makefile12
-rw-r--r--x11/etoile-iterm/files/patch-PTYSession.h10
2 files changed, 15 insertions, 7 deletions
diff --git a/x11/etoile-iterm/Makefile b/x11/etoile-iterm/Makefile
index 9d930db12334..eb33e68af8d5 100644
--- a/x11/etoile-iterm/Makefile
+++ b/x11/etoile-iterm/Makefile
@@ -7,27 +7,25 @@
PORTNAME= iterm
PORTVERSION= 0.1.${SNAPSHOT}
+PORTREVISION= 1
CATEGORIES= x11
-MASTER_SITES= http://io.debian.net/~tar/ports/distfiles/
+MASTER_SITES= ${MASTER_SITE_GNUSTEP_CH}
PKGNAMEPREFIX= etoile-
DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Etoile Project Terminal application
-SNAPSHOT= 20060917
-WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
USE_GNUSTEP_LOCAL_LIBS+= Addresses:${ADDRESSES_PORT}
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
USE_GNUSTEP_MAKE_DIRS+= Services/User/Terminal
-MAKEFILE=
-ALL_TARGET=
ADDRESSES_PORT?= mail/addresses
diff --git a/x11/etoile-iterm/files/patch-PTYSession.h b/x11/etoile-iterm/files/patch-PTYSession.h
new file mode 100644
index 000000000000..43d9f21b8c6d
--- /dev/null
+++ b/x11/etoile-iterm/files/patch-PTYSession.h
@@ -0,0 +1,10 @@
+--- Services/User/Terminal/Headers/iTerm/PTYSession.h.orig Sun Sep 17 21:03:24 2006
++++ Services/User/Terminal/Headers/iTerm/PTYSession.h Tue Dec 19 07:29:49 2006
+@@ -28,6 +28,7 @@
+ #import <AppKit/AppKit.h>
+
+ #include <sys/time.h>
++#include <pthread.h>
+
+ @class PTYTask;
+ @class PTYTextView;