aboutsummaryrefslogtreecommitdiffstats
path: root/x11/etoile/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-12-22 19:04:13 +0800
committerdinoex <dinoex@FreeBSD.org>2006-12-22 19:04:13 +0800
commite5eba817e54100ec5e9b03f7eb543c79c38e374d (patch)
treeff95fdabb3b3ecd5786bcefdc9223c1bfadbdb12 /x11/etoile/Makefile
parent1ee4d9a5f4dbea1792537037ea7a031ecdc0e71e (diff)
downloadfreebsd-ports-gnome-e5eba817e54100ec5e9b03f7eb543c79c38e374d.tar.gz
freebsd-ports-gnome-e5eba817e54100ec5e9b03f7eb543c79c38e374d.tar.zst
freebsd-ports-gnome-e5eba817e54100ec5e9b03f7eb543c79c38e374d.zip
Etoile intends to be an innovative GNUstep based user environnement built
from the ground up on highly modular and light components with project and document orientation in mind, in order to allow users to create their own workflow by reshaping or recombining provided Services (aka Applications), Components etc. Flexibility and modularity on both User Interface and code level should allow us to scale from PDA to computer environment. WWW: http://www.etoile-project.org/
Diffstat (limited to 'x11/etoile/Makefile')
-rw-r--r--x11/etoile/Makefile75
1 files changed, 75 insertions, 0 deletions
diff --git a/x11/etoile/Makefile b/x11/etoile/Makefile
new file mode 100644
index 000000000000..47c73662d3bf
--- /dev/null
+++ b/x11/etoile/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: etoile
+# Date created: 21 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= etoile
+PORTVERSION= 0.1.0
+CATEGORIES= x11
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Metaport for Etoile desktop
+
+NO_BUILD= yes
+NO_INSTALL= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_GUI= yes
+USE_GNUSTEP_BACK= yes
+.if !defined(WITH_GNUSTEP_SINGLE_BACKEND)
+USE_GNUSTEP_XLIB= yes
+USE_GNUSTEP_LIBART= yes
+USE_GNUSTEP_CAIRO= yes
+.endif
+
+USE_GNUSTEP_SYSTEM_LIBS+= \
+ TrackerKit:deskutils/etoile-trackerkit \
+ PreferencesKit:deskutils/etoile-preferenceskit \
+ BookmarkKit:www/etoile-bookmarkkit \
+ ServicesBarKit:deskutils/etoile-servicesbarkit \
+ IconKit:x11-themes/etoile-iconkit \
+
+USE_GNUSTEP_LOCAL_LIBS+= \
+ Addresses:mail/addresses \
+ SQLClient:databases/sqlclient \
+ UnitKit:devel/etoile-unitkit \
+ XWindowServerKit:x11/etoile-xwindowserverkit \
+ RSSKit:www/etoile-rsskit \
+ EtoileExtensions:deskutils/etoile-etoileextensionskit \
+ PopplerKit:graphics/popplerkit \
+
+# OgreKit:textproc/etoile-ogrekit \
+# LuceneKit:textproc/etoile-lucenekit \
+
+USE_GNUSTEP_SYSTEM_BUNDLES+= \
+ EtoileMenus:x11-themes/etoile-etoilemenus \
+
+USE_GNUSTEP_SYSTEM_THEMES+= \
+ Camaelon:x11-themes/etoile-camaelon \
+
+USE_GNUSTEP_LOCAL_THEMES+= \
+ WildMenus:x11-themes/etoile-wildmenus
+
+USE_GNUSTEP_SYSTEM_APPS+= \
+ AZDock:x11-wm/etoile-azdock \
+
+USE_GNUSTEP_LOCAL_APPS+= \
+ DictionaryReader:deskutils/etoile \
+ Grr:www/etoile-grr \
+ iTerm:x11/etoile-iterm \
+ Installer:sysutils/etoile-installer \
+ Hardware:deskutils/etoile-hardware \
+ LookAndBehavior:deskutils/etoile-lookandbehavior \
+ Azalea:x11-wm/etoile-azalea \
+ EtoileMenuServer:deskutils/etoile-menuserver \
+ Vindaloo:graphics/vindaloo \
+
+# Typewriter:editors/etoile-typewriter \
+
+.include <bsd.port.mk>