aboutsummaryrefslogtreecommitdiffstats
path: root/x11/fbpanel/files
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2004-12-15 14:34:35 +0800
committerclive <clive@FreeBSD.org>2004-12-15 14:34:35 +0800
commit306b2beedb190abe3f6ee91a9c11fa1a936b5306 (patch)
tree2d1dfea1444ec8254a08a39557db139d9fee967e /x11/fbpanel/files
parent819c67d7d1f2939e484d78a89afe9f3b2e7f832f (diff)
downloadfreebsd-ports-gnome-306b2beedb190abe3f6ee91a9c11fa1a936b5306.tar.gz
freebsd-ports-gnome-306b2beedb190abe3f6ee91a9c11fa1a936b5306.tar.zst
freebsd-ports-gnome-306b2beedb190abe3f6ee91a9c11fa1a936b5306.zip
Update to 3.18
PR: ports/75072 Submitted by: MAINTAINER
Diffstat (limited to 'x11/fbpanel/files')
-rw-r--r--x11/fbpanel/files/patch-Makefile.common16
-rw-r--r--x11/fbpanel/files/patch-plugins::Makefile11
2 files changed, 20 insertions, 7 deletions
diff --git a/x11/fbpanel/files/patch-Makefile.common b/x11/fbpanel/files/patch-Makefile.common
index 94b33a3a4102..3625cbc91377 100644
--- a/x11/fbpanel/files/patch-Makefile.common
+++ b/x11/fbpanel/files/patch-Makefile.common
@@ -1,14 +1,16 @@
---- Makefile.common.orig Sat Jun 26 14:00:42 2004
-+++ Makefile.common Sat Jun 26 14:03:02 2004
-@@ -15,10 +15,9 @@
+--- Makefile.common.orig Tue Dec 14 18:52:32 2004
++++ Makefile.common Tue Dec 14 18:53:15 2004
+@@ -15,12 +15,10 @@
endif
endif
-CC = gcc
+CC ?= gcc
LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
- INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
--CFLAGS = -O2 # overwriten by command line or env. variable
- CFLAGS += -Wall # always nice to have
+ INCS2 = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
+ INCS := $(INCS2:-I%=-isystem%)
+-# first = may be overwriten by command line or env. variable
+-CFLAGS = -O2
+ # this one always applays
+ CFLAGS += -Wall
ifneq (,$(DEVEL))
- CFLAGS := -g -Wall
diff --git a/x11/fbpanel/files/patch-plugins::Makefile b/x11/fbpanel/files/patch-plugins::Makefile
new file mode 100644
index 000000000000..f475b4dca68c
--- /dev/null
+++ b/x11/fbpanel/files/patch-plugins::Makefile
@@ -0,0 +1,11 @@
+--- plugins/Makefile.orig Tue Dec 14 19:59:15 2004
++++ plugins/Makefile Tue Dec 14 19:59:23 2004
+@@ -7,7 +7,7 @@
+ INCS += -I../
+ SRC = image.c menu.c separator.c taskbar.c wincmd.c \
+ dclock.c launchbar.c pager.c space.c test.c \
+- icons.c cpu.c deskno.c
++ icons.c deskno.c
+
+ SOBJ = $(SRC:%.c=%.so)
+ OBJ = $(SRC:%.c=%.o)