aboutsummaryrefslogtreecommitdiffstats
path: root/x11/finder/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-09-05 21:11:31 +0800
committersobomax <sobomax@FreeBSD.org>2000-09-05 21:11:31 +0800
commitc9253d69454ea5fe485583fe7d46b0be2329a57f (patch)
treeeca6b28952dc1bc122fada98a577c1886d40d987 /x11/finder/files
parent7cedbcba2dfda03d1be5574320a1ece6cf9cf187 (diff)
downloadfreebsd-ports-gnome-c9253d69454ea5fe485583fe7d46b0be2329a57f.tar.gz
freebsd-ports-gnome-c9253d69454ea5fe485583fe7d46b0be2329a57f.tar.zst
freebsd-ports-gnome-c9253d69454ea5fe485583fe7d46b0be2329a57f.zip
Add finder. Finder is a small program that creates a finder bar on your Gnome
desktop. It can be used to switch tasks and launch applications.
Diffstat (limited to 'x11/finder/files')
-rw-r--r--x11/finder/files/patch-aa51
-rw-r--r--x11/finder/files/patch-ab13
-rw-r--r--x11/finder/files/patch-ac13
-rw-r--r--x11/finder/files/patch-ad13
-rw-r--r--x11/finder/files/patch-ae12
5 files changed, 102 insertions, 0 deletions
diff --git a/x11/finder/files/patch-aa b/x11/finder/files/patch-aa
new file mode 100644
index 000000000000..583c3ea3d758
--- /dev/null
+++ b/x11/finder/files/patch-aa
@@ -0,0 +1,51 @@
+--- Makefile.orig Tue Sep 5 00:49:19 2000
++++ Makefile Tue Sep 5 14:55:11 2000
+@@ -1,11 +1,11 @@
+-INCLUDE=`gnome-config --cflags gnome gnomeui gnorba applets gdk_pixbuf` -I.
+-LIBS=`gnome-config --libs gnome gnomeui gnorba applets gdk_pixbuf` -L.
+-BIN=`gnome-config --bindir`
+-PIXMAP=`gnome-config --prefix`/share/pixmaps
+-DESKTOP=`gnome-config --prefix`/share/applets/Utility
+-GNORBA=`gnome-config --prefix`/etc/CORBA/servers
++INCLUDE=`$(X11BASE)/bin/gnome-config --cflags gnome gnomeui gnorba applets gdk_pixbuf` -I.
++LIBS=`$(X11BASE)/bin/gnome-config --libs gnome gnomeui gnorba applets gdk_pixbuf` -L.
++BIN=`$(X11BASE)/bin/gnome-config --bindir`
++PIXMAP=`$(X11BASE)/bin/gnome-config --datadir`/pixmaps
++DESKTOP=`$(X11BASE)/bin/gnome-config --datadir`/applets/Utility
++GNORBA=`$(X11BASE)/bin/gnome-config --prefix`/etc/CORBA/servers
+
+-CC=gcc
++CC?=gcc
+
+ CFLAGS+=$(INCLUDE)
+
+@@ -23,20 +23,20 @@
+ compile: $(OBJS)
+
+ finder:
+- make -C gwmh
+- make -C TaskMenu
+- make $(OBJS)
+- gcc $(CFLAGS) $(LIBS) -o finder $(OBJS)
++ ${MAKE} -C gwmh
++ ${MAKE} -C TaskMenu
++ ${MAKE} $(OBJS)
++ ${CC} $(CFLAGS) $(LIBS) -o finder $(OBJS)
+
+ clean:
+ rm -f $(OBJS) $(TARGETS)
+
+ install: $(INST)
+- cp finder $(BIN)/finder
+- cp apple.png $(PIXMAP)/apple.png
+- cp finder.png $(PIXMAP)/finder.png
+- cp finder.desktop $(DESKTOP)/finder.desktop
+- cp finder.gnorba $(GNORBA)/finder.gnorba
++ $(BSD_INSTALL_PROGRAM) finder $(BIN)/finder
++ $(BSD_INSTALL_DATA) apple.png $(PIXMAP)/apple.png
++ $(BSD_INSTALL_DATA) finder.png $(PIXMAP)/finder.png
++ $(BSD_INSTALL_DATA) finder.desktop $(DESKTOP)/finder.desktop
++ $(BSD_INSTALL_DATA) finder.gnorba $(GNORBA)/finder.gnorba
+
+ uninstall:
+ rm -f $(BIN)/finder
diff --git a/x11/finder/files/patch-ab b/x11/finder/files/patch-ab
new file mode 100644
index 000000000000..e51b0c5ed9de
--- /dev/null
+++ b/x11/finder/files/patch-ab
@@ -0,0 +1,13 @@
+--- gwmh/Makefile.orig Sun Sep 3 05:34:12 2000
++++ gwmh/Makefile Mon Sep 4 16:18:43 2000
+@@ -1,8 +1,8 @@
+-INCLUDEFLAGS=`gnome-config --cflags gnome` `gtk-config --cflags` -I.
++INCLUDEFLAGS=`$(X11BASE)/bin/gnome-config --cflags gnome` `$(X11BASE)/bin/gtk12-config --cflags` -I.
+
+ OBJS=gwmh.o gstc.o
+
+-CC=gcc
++CC?=gcc
+ CFLAGS+=$(INCLUDEFLAGS)
+
+ default: $(OBJS)
diff --git a/x11/finder/files/patch-ac b/x11/finder/files/patch-ac
new file mode 100644
index 000000000000..85bafefcad69
--- /dev/null
+++ b/x11/finder/files/patch-ac
@@ -0,0 +1,13 @@
+--- TaskMenu/Makefile.orig Mon Sep 4 00:17:56 2000
++++ TaskMenu/Makefile Mon Sep 4 16:18:17 2000
+@@ -1,8 +1,8 @@
+-INCLUDEFLAGS=`gnome-config --cflags gnome` `gtk-config --cflags` -I.
++INCLUDEFLAGS=`$(X11BASE)/bin/gnome-config --cflags gnome` `$(X11BASE)/bin/gtk12-config --cflags` -I.
+
+ OBJS=task-menu.o task-option.o task-manage.o task-icon.o
+
+-CC=gcc
++CC?=gcc
+ CFLAGS+=$(INCLUDEFLAGS)
+
+ default: $(OBJS)
diff --git a/x11/finder/files/patch-ad b/x11/finder/files/patch-ad
new file mode 100644
index 000000000000..3dbd9140d753
--- /dev/null
+++ b/x11/finder/files/patch-ad
@@ -0,0 +1,13 @@
+--- AboutDialog/Makefile 2000/09/04 13:19:20 1.1
++++ AboutDialog/Makefile 2000/09/04 13:19:53
+@@ -1,8 +1,8 @@
+-INCLUDEFLAGS=`gnome-config --cflags gnome` `gtk-config --cflags` -I.
++INCLUDEFLAGS=`$(X11BASE)/bin/gnome-config --cflags gnome` `$(X11BASE)/bin/gtk12-config --cflags` -I.
+
+ OBJS=about-dialog.o
+
+-CC=gcc
++CC?=gcc
+ CFLAGS+=$(INCLUDEFLAGS)
+
+ default: $(OBJS)
diff --git a/x11/finder/files/patch-ae b/x11/finder/files/patch-ae
new file mode 100644
index 000000000000..856acdb1f02e
--- /dev/null
+++ b/x11/finder/files/patch-ae
@@ -0,0 +1,12 @@
+--- finder.desktop.orig Tue Sep 5 16:00:38 2000
++++ finder.desktop Tue Sep 5 16:00:53 2000
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Name=Finder
+-Icon=finder.png
+ Comment=Finder Task Switcher
+-Exec=finder
++Exec=finder --activate-goad-server=finder
++Icon=finder.png
+ Terminal=0
+ Type=Application