aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gdm/Makefile
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2006-10-31 17:58:24 +0800
committerjylefort <jylefort@FreeBSD.org>2006-10-31 17:58:24 +0800
commitbadf13f0f23b8c6d9338016e067b5c530900f771 (patch)
tree3804065abba14e3b8cd41230b87a6b4832a5a751 /x11/gdm/Makefile
parentf0a456bf070fc208edb7155204da7a1b9f51119f (diff)
downloadfreebsd-ports-gnome-badf13f0f23b8c6d9338016e067b5c530900f771.tar.gz
freebsd-ports-gnome-badf13f0f23b8c6d9338016e067b5c530900f771.tar.zst
freebsd-ports-gnome-badf13f0f23b8c6d9338016e067b5c530900f771.zip
- Allow to lift the annoying ~/.xsession-errors size limit
- Start gdm if gnome_enable is set to yes in /etc/rc.conf
Diffstat (limited to 'x11/gdm/Makefile')
-rw-r--r--x11/gdm/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index fa33422a2d8e..1d1a87b8ac92 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -8,6 +8,7 @@
PORTNAME= gdm
PORTVERSION= 2.16.2
+PORTREVISION= 1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -26,6 +27,7 @@ USE_XLIB= yes
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_RC_SUBR= gdm
+USE_GNOME_SUBR= yes
USE_GMAKE= yes
USE_GNOME= gnomehack intlhack gnomehier libgnomeui librsvg2 gnomedocutils \
gnomeprefix
@@ -42,7 +44,8 @@ GNOME_LOCALSTATEDIR= /var
MAN1= gdm.1
-OPTIONS= IPV6 "Enable IPv6 support" on
+OPTIONS= IPV6 "Enable IPv6 support" on \
+ LOG_LIMIT "Limit ~/.xsession-errors size" on
.include <bsd.port.pre.mk>
@@ -64,6 +67,10 @@ CONFIGURE_ARGS+= --enable-ipv6
CONFIGURE_ARGS+= --disable-ipv6
.endif
+.if defined(WITHOUT_LOG_LIMIT)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-daemon_slave.c
+.endif
+
post-patch:
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )