aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gdm
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-02-01 05:50:25 +0800
committermarcus <marcus@FreeBSD.org>2009-02-01 05:50:25 +0800
commitc7c02e75d686b5f203a77c5cc8b2b2b8ecf655a7 (patch)
tree6a5c952e6b039784f0d6b1760d2e6a911d7fba90 /x11/gdm
parent189e38a0ddf66922b30e09473680e2efa5bc2ae8 (diff)
downloadfreebsd-ports-gnome-c7c02e75d686b5f203a77c5cc8b2b2b8ecf655a7.tar.gz
freebsd-ports-gnome-c7c02e75d686b5f203a77c5cc8b2b2b8ecf655a7.tar.zst
freebsd-ports-gnome-c7c02e75d686b5f203a77c5cc8b2b2b8ecf655a7.zip
Take a stab at working around the hald/gdm race. After we loop waiting
for the getty, loop waiting for hald to be ready.
Diffstat (limited to 'x11/gdm')
-rw-r--r--x11/gdm/Makefile2
-rw-r--r--x11/gdm/files/gdm.in8
2 files changed, 9 insertions, 1 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index a6f0ba670bd6..8e00f2c136f0 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gdm
PORTVERSION= 2.24.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11/gdm/files/gdm.in b/x11/gdm/files/gdm.in
index c6bf0fdc55ad..23ab71b4beaa 100644
--- a/x11/gdm/files/gdm.in
+++ b/x11/gdm/files/gdm.in
@@ -46,6 +46,14 @@ gdm_start()
sleep 1
iter=$(expr ${iter} + 1)
done
+ iter=0
+ while ! %%LOCALBASE%%/bin/lshal >/dev/null 2>&1 ; do
+ if [ ${iter} -eq 60 ]; then
+ break
+ fi
+ sleep 1
+ iter=$(expr ${iter} + 1)
+ done
${command} ${gdm_flags} ) &
}