aboutsummaryrefslogtreecommitdiffstats
path: root/x11/ggiterm/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-09 08:05:55 +0800
committerpav <pav@FreeBSD.org>2003-12-09 08:05:55 +0800
commit43058d9985ac3bd1afbab06eb3551a7ef8f6165d (patch)
tree82d5c0c177182851e03a386b3cf3cb0856091ee3 /x11/ggiterm/Makefile
parent67cc439e7a4f899051257c6a2e42a67de82f9456 (diff)
downloadfreebsd-ports-gnome-43058d9985ac3bd1afbab06eb3551a7ef8f6165d.tar.gz
freebsd-ports-gnome-43058d9985ac3bd1afbab06eb3551a7ef8f6165d.tar.zst
freebsd-ports-gnome-43058d9985ac3bd1afbab06eb3551a7ef8f6165d.zip
Add ggiterm, a GGI-based ANSI terminal emulator, but it runs on any GGI target
- X, SVGAlib, etc. It uses Freetype (by default) for fonts. PR: ports/58342 Submitted by: andi payn <andi_payn@speedymail.org>
Diffstat (limited to 'x11/ggiterm/Makefile')
-rw-r--r--x11/ggiterm/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11/ggiterm/Makefile b/x11/ggiterm/Makefile
new file mode 100644
index 000000000000..244a2af8d567
--- /dev/null
+++ b/x11/ggiterm/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: ggiterm
+# Date created: 20 October 2003
+# Whom: andi_payn@speedymail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggiterm
+PORTVERSION= 0.5.1
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ggiterm
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A terminal emulator for GGI
+
+LIB_DEPENDS= ggi.2:${PORTSDIR}/graphics/libggi
+.if !defined(WITHOUT_FREETYPE)
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+.endif
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-ggi=${LOCALBASE}
+.if !defined(WITHOUT_FREETYPE)
+CONFIGURE_ARGS+=--with-ft-prefix=${LOCALBASE}
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+pre-everything::
+.if !defined(WITHOUT_FREETYPE)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "ggiterm can be built without Freetype support. However, as the author says,"
+ @${ECHO_MSG} "'if you don't have freetype you lose much of the ggiterm reason for being,'"
+ @${ECHO_MSG} "so you probably don't want this. If you do, cancel now and build with:"
+ @${ECHO_MSG} " WITHOUT_FREETYPE=yes"
+ @${ECHO_MSG} ""
+.else
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You have chosen to build ggiterm without Freetype. If this wasn't your"
+ @${ECHO_MSG} "intention, cancel now and unset the 'WITHOUT_FREETYPE' variable."
+ @${ECHO_MSG} ""
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>