aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-applets
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
committerkwm <kwm@FreeBSD.org>2011-08-24 02:39:19 +0800
commit39ef19450c2cf8b75e3b20495c6e2331f67e3138 (patch)
tree68e92ca91db8af8e96889640de621794add90af4 /x11/gnome-applets
parent6a56442427dd00f76ca13093ea38b248d54a7964 (diff)
downloadfreebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.gz
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.tar.zst
freebsd-ports-gnome-39ef19450c2cf8b75e3b20495c6e2331f67e3138.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Diffstat (limited to 'x11/gnome-applets')
-rw-r--r--x11/gnome-applets/Makefile7
-rw-r--r--x11/gnome-applets/files/patch-battstat_battstat_applet.c15
-rw-r--r--x11/gnome-applets/files/patch-gweather_gweather-applet.c12
3 files changed, 27 insertions, 7 deletions
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index 03727ebbdf25..0b692899a299 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-applets/Makefile,v 1.216 2010/09/27 10:14:28 kwm Exp $
+# $MCom: ports/x11/gnome-applets/Makefile,v 1.219 2011/04/10 19:41:38 mezz Exp $
#
PORTNAME= gnome-applets
PORTVERSION= 2.32.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -29,7 +29,6 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/system-tools-backends-2.0.pc:${PORTS
USE_GETTEXT= yes
USE_BZIP2= yes
USE_GMAKE= yes
-GNOME_DESKTOP_VERSION=2
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
@@ -58,7 +57,7 @@ WITH_GNOME= yes
.if exists(${LOCALBASE}/libdata/pkgconfig/libnotify.pc) || \
!defined(WITHOUT_LIBNOTIFY)
-LIB_DEPENDS+= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
diff --git a/x11/gnome-applets/files/patch-battstat_battstat_applet.c b/x11/gnome-applets/files/patch-battstat_battstat_applet.c
index a95b7b569a09..05f2171440bb 100644
--- a/x11/gnome-applets/files/patch-battstat_battstat_applet.c
+++ b/x11/gnome-applets/files/patch-battstat_battstat_applet.c
@@ -1,6 +1,15 @@
---- battstat/battstat_applet.c.orig Fri Aug 19 22:13:49 2005
-+++ battstat/battstat_applet.c Tue Aug 23 20:37:13 2005
-@@ -430,14 +430,14 @@ battery_full_notify (GtkWidget *applet)
+--- battstat/battstat_applet.c.orig 2010-11-22 15:38:27.000000000 +0100
++++ battstat/battstat_applet.c 2011-03-07 19:09:55.000000000 +0100
+@@ -435,7 +435,7 @@ battery_full_notify (GtkWidget *applet)
+ GTK_ICON_LOOKUP_USE_BUILTIN,
+ NULL);
+
+- NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL, applet);
++ NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL);
+
+ /* XXX: it would be nice to pass this as a named icon */
+ notify_notification_set_icon_from_pixbuf (n, icon);
+@@ -462,14 +462,14 @@ battery_full_notify (GtkWidget *applet)
static void
battery_full_dialog (GtkWidget *applet)
{
diff --git a/x11/gnome-applets/files/patch-gweather_gweather-applet.c b/x11/gnome-applets/files/patch-gweather_gweather-applet.c
new file mode 100644
index 000000000000..9472c7b9e5fd
--- /dev/null
+++ b/x11/gnome-applets/files/patch-gweather_gweather-applet.c
@@ -0,0 +1,12 @@
+--- gweather/gweather-applet.c.orig 2011-03-07 17:35:07.000000000 +0100
++++ gweather/gweather-applet.c 2011-03-07 17:35:33.000000000 +0100
+@@ -471,8 +471,7 @@ update_finish (WeatherInfo *info, gpoint
+ if (icon == NULL)
+ icon = "stock-unknown";
+
+- n = notify_notification_new (message, detail, icon,
+- gw_applet->container);
++ n = notify_notification_new (message, detail, icon);
+
+ notify_notification_show (n, &error);
+ if (error)