aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-menus
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
committermarcus <marcus@FreeBSD.org>2006-04-30 08:47:21 +0800
commit7315b1c16ae631c60d787b73475db448b86b7e0b (patch)
tree0a7edc722d829b9a98914843c0c09d978324e75f /x11/gnome-menus
parente43bffa408ddb90519bcbf271791632a33f25217 (diff)
downloadfreebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.gz
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.tar.zst
freebsd-ports-gnome-7315b1c16ae631c60d787b73475db448b86b7e0b.zip
Presenting GNOME 2.14.1 for FreeBSD! Checkout
http://www.gnome.org/start/2.14/ for the official release notes, and a list of all the gooides in this new release. In particular, GNOME 2.14 focused on performance, and they did not miss the mark. There's some new eye candy, but most of the big things are waiting until GNOME 2.16. On the FreeBSD side, we tried to clean up all the crashers we could. In particular, we really improved GNOME's 64-bit support. The good news is that this release does not bring any big shared library version bumps, so you can almost do a simple portupgrade to get to 2.14. There are a few minor gotchas that will be documented in UPDATING shortly. The FreeBSD GNOME Team would like th thank the following users for their patches, feedback, and sometimes incessant complaing about crashes (you know who you are). Yasuda Keisuke <kysd@po.harenet.ne.jp> Pascal Hofstee <caelian@gmail.com> rmgls@wanadoo.fr tmclaugh Yuri Pankov <yuri.pankov@gmail.com> sajd on #freebsd-gnome ade ankon on #FreeBSD-Gnome mux Pascal Hofstee <caelian@gmail.com> QuiRK on #freebsd-gnome Vladimir Timofeev <vovkasm@gmail.com>
Diffstat (limited to 'x11/gnome-menus')
-rw-r--r--x11/gnome-menus/Makefile19
-rw-r--r--x11/gnome-menus/distinfo6
-rw-r--r--x11/gnome-menus/files/patch-Makefile.in4
-rw-r--r--x11/gnome-menus/pkg-plist25
4 files changed, 42 insertions, 12 deletions
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index 2b04a083b71a..0b3b692e9fce 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -3,31 +3,36 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-menus/Makefile,v 1.21 2005/09/08 18:04:51 marcus Exp $
+# $MCom: ports/x11/gnome-menus/Makefile,v 1.29 2006/04/13 13:04:49 ahze Exp $
#
PORTNAME= gnome-menus
-PORTVERSION= 2.12.0
-PORTREVISION= 2
+PORTVERSION= 2.14.0
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Implementation of the FreeDesktop Desktop Menu Spec
+USE_GETTEXT= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomevfs2 ltverhack
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
USE_PYTHON= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libfam.so) || !defined(WITHOUT_FAM)
+USE_FAM= yes
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/gnome|${X11BASE}/share/gnome|g' \
${WRKSRC}/layout/applications.menu \
@@ -41,4 +46,4 @@ post-install:
@${MKDIR} ${PREFIX}/share/gnome/desktop-directories
@${INSTALL_DATA} ${WRKSRC}/KDE.directory ${PREFIX}/share/gnome/desktop-directories
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/gnome-menus/distinfo b/x11/gnome-menus/distinfo
index 7a00a1d9cb81..49becc359005 100644
--- a/x11/gnome-menus/distinfo
+++ b/x11/gnome-menus/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-menus-2.12.0.tar.bz2) = 615392c4f729f70c03aa3aa7dbe40a95
-SHA256 (gnome2/gnome-menus-2.12.0.tar.bz2) = f77192ca0b909000f675ad3cd520c313431ee117d554102c7ea486f76f396f6b
-SIZE (gnome2/gnome-menus-2.12.0.tar.bz2) = 393280
+MD5 (gnome2/gnome-menus-2.14.0.tar.bz2) = 7aa0c08fc8b9caabb4be46e1cfb595fc
+SHA256 (gnome2/gnome-menus-2.14.0.tar.bz2) = 07985a597e825cab86e3b0a46d6bdc89f2545dd57ee4cf5ea781ab4f37cd60a3
+SIZE (gnome2/gnome-menus-2.14.0.tar.bz2) = 408473
diff --git a/x11/gnome-menus/files/patch-Makefile.in b/x11/gnome-menus/files/patch-Makefile.in
index 510f1140fb48..995bf4c2e5e8 100644
--- a/x11/gnome-menus/files/patch-Makefile.in
+++ b/x11/gnome-menus/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Thu Sep 8 13:59:53 2005
-+++ Makefile.in Thu Sep 8 14:00:08 2005
+--- Makefile.in.orig Thu Apr 13 08:59:30 2006
++++ Makefile.in Thu Apr 13 08:59:38 2006
@@ -205,7 +205,7 @@
target_alias = @target_alias@
NULL =
diff --git a/x11/gnome-menus/pkg-plist b/x11/gnome-menus/pkg-plist
index 81576978b409..b5a4b5e1700a 100644
--- a/x11/gnome-menus/pkg-plist
+++ b/x11/gnome-menus/pkg-plist
@@ -31,11 +31,14 @@ share/gnome/desktop-directories/System-Settings.directory
share/gnome/desktop-directories/System-Tools.directory
share/locale/ar/LC_MESSAGES/gnome-menus.mo
share/locale/bg/LC_MESSAGES/gnome-menus.mo
+share/locale/bn/LC_MESSAGES/gnome-menus.mo
+share/locale/br/LC_MESSAGES/gnome-menus.mo
share/locale/ca/LC_MESSAGES/gnome-menus.mo
share/locale/cs/LC_MESSAGES/gnome-menus.mo
share/locale/cy/LC_MESSAGES/gnome-menus.mo
share/locale/da/LC_MESSAGES/gnome-menus.mo
share/locale/de/LC_MESSAGES/gnome-menus.mo
+share/locale/dz/LC_MESSAGES/gnome-menus.mo
share/locale/el/LC_MESSAGES/gnome-menus.mo
share/locale/en_CA/LC_MESSAGES/gnome-menus.mo
share/locale/en_GB/LC_MESSAGES/gnome-menus.mo
@@ -54,8 +57,13 @@ share/locale/hy/LC_MESSAGES/gnome-menus.mo
share/locale/id/LC_MESSAGES/gnome-menus.mo
share/locale/it/LC_MESSAGES/gnome-menus.mo
share/locale/ja/LC_MESSAGES/gnome-menus.mo
+share/locale/ka/LC_MESSAGES/gnome-menus.mo
share/locale/ko/LC_MESSAGES/gnome-menus.mo
+share/locale/ku/LC_MESSAGES/gnome-menus.mo
+share/locale/ky/LC_MESSAGES/gnome-menus.mo
share/locale/lt/LC_MESSAGES/gnome-menus.mo
+share/locale/lv/LC_MESSAGES/gnome-menus.mo
+share/locale/mg/LC_MESSAGES/gnome-menus.mo
share/locale/mk/LC_MESSAGES/gnome-menus.mo
share/locale/mr/LC_MESSAGES/gnome-menus.mo
share/locale/ms/LC_MESSAGES/gnome-menus.mo
@@ -76,21 +84,38 @@ share/locale/sq/LC_MESSAGES/gnome-menus.mo
share/locale/sr/LC_MESSAGES/gnome-menus.mo
share/locale/sr@Latn/LC_MESSAGES/gnome-menus.mo
share/locale/sv/LC_MESSAGES/gnome-menus.mo
+share/locale/te/LC_MESSAGES/gnome-menus.mo
share/locale/th/LC_MESSAGES/gnome-menus.mo
share/locale/tr/LC_MESSAGES/gnome-menus.mo
+share/locale/ug/LC_MESSAGES/gnome-menus.mo
share/locale/uk/LC_MESSAGES/gnome-menus.mo
share/locale/vi/LC_MESSAGES/gnome-menus.mo
share/locale/xh/LC_MESSAGES/gnome-menus.mo
share/locale/zh_CN/LC_MESSAGES/gnome-menus.mo
+share/locale/zh_HK/LC_MESSAGES/gnome-menus.mo
share/locale/zh_TW/LC_MESSAGES/gnome-menus.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/mg/LC_MESSAGES
+@dirrmtry share/locale/mg
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
@dirrm share/gnome/desktop-directories
@dirrm include/gnome-menus
@dirrm etc/xdg/menus