aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-04-06 01:32:30 +0800
committermezz <mezz@FreeBSD.org>2008-04-06 01:32:30 +0800
commit41255bd51508c4744f42b5ec57604060b222a093 (patch)
treea70d76ff9815131728bb605969999ec541646739 /x11/gnome-panel
parentcc9d30f1f6c72468f1d86ebdb369026f0b011d1d (diff)
downloadfreebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.tar.gz
freebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.tar.zst
freebsd-ports-gnome-41255bd51508c4744f42b5ec57604060b222a093.zip
Fix the crash by clock-applet when add to the panel. Bump the PORTREVISION.
PR: ports/122455 Submitted by: fukui <fukui.FreeBSD@fanet.net> Obtained from: Its SVN
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile2
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_set-timezone.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index a459bdeeb665..817e3850b5cc 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnome-panel
PORTVERSION= 2.22.0
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-panel/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/x11/gnome-panel/files/patch-applets_clock_set-timezone.c b/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
new file mode 100644
index 000000000000..3a9fb4ae9fa8
--- /dev/null
+++ b/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
@@ -0,0 +1,22 @@
+--- trunk/applets/clock/set-timezone.c 2008/02/28 20:48:16 10908
++++ applets/clock/set-timezone.c 2008/04/02 15:08:34 10972
+@@ -139,6 +139,9 @@
+ DBusError dbus_error;
+ gint res = 0;
+
++ pk_caller = NULL;
++ pk_action = NULL;
++
+ system_bus = dbus_g_connection_get_connection (get_system_bus ());
+ if (system_bus == NULL)
+ goto out;
+@@ -147,9 +150,6 @@
+ if (pk_context == NULL)
+ goto out;
+
+- pk_caller = NULL;
+- pk_action = NULL;
+-
+ pk_action = polkit_action_new ();
+ polkit_action_set_action_id (pk_action, pk_action_id);
+