aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2011-06-05 06:45:27 +0800
committermezz <mezz@FreeBSD.org>2011-06-05 06:45:27 +0800
commit4c188dd36aa4628b3df1a1726385189d3fab6908 (patch)
tree9116b0072d649f367f49ae9212fcdc61653758c1 /x11/gnome-panel
parent4657582a25c8c6d8962ec00771b610afc5090afb (diff)
downloadfreebsd-ports-gnome-4c188dd36aa4628b3df1a1726385189d3fab6908.tar.gz
freebsd-ports-gnome-4c188dd36aa4628b3df1a1726385189d3fab6908.tar.zst
freebsd-ports-gnome-4c188dd36aa4628b3df1a1726385189d3fab6908.zip
- Remove --enable-polkit configure option, that doesn't exists anymore
- Move CPPFLAGS out of CONFIGURE_ENV - Do a better way of patch for Python. PR: ports/157126 Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile11
-rw-r--r--x11/gnome-panel/files/patch-configure11
2 files changed, 6 insertions, 16 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index 1082e367f0e2..4887b4cf240d 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -26,19 +26,18 @@ LIB_DEPENDS= gweather.1:${PORTSDIR}/net/libgweather \
USE_GETTEXT= yes
USE_XORG= ice sm x11 xau xrandr
+USE_PYTHON= yes
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop libwnck gnomemenus \
gnomedocutils ltverhack referencehack librsvg2
WANT_GNOME= yes
-GNOME_DESKTOP_VERSION=2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --disable-network-manager \
- --enable-polkit
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-network-manager
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS="-I${LOCALBASE}/include"
MAN1= gnome-panel.1
GCONF_SCHEMAS= clock.schemas fish.schemas \
@@ -80,6 +79,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|xsltproc -o| xsltproc --nonet -o|g' \
${WRKSRC}/help/clock/Makefile.in \
${WRKSRC}/help/fish/Makefile.in
+ @${REINPLACE_CMD} -e 's|python.* python2\.0|${PYTHON_VERSION}|g' \
+ ${WRKSRC}/configure
post-install:
@${MKDIR} ${PREFIX}/lib/gnome-panel/modules
diff --git a/x11/gnome-panel/files/patch-configure b/x11/gnome-panel/files/patch-configure
deleted file mode 100644
index 785c7f0f6176..000000000000
--- a/x11/gnome-panel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig 2010-01-07 14:47:10.000000000 +0100
-+++ configure 2010-01-07 14:47:58.000000000 +0100
-@@ -13318,7 +13318,7 @@
-
- # Find any Python interpreter.
- if test -z "$PYTHON"; then
-- for ac_prog in python python2 python3 python3.0 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0
-+ for ac_prog in python python2 python3 python3.0 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2