aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-panel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-04-08 12:19:46 +0800
committermarcus <marcus@FreeBSD.org>2008-04-08 12:19:46 +0800
commit8eefe69ae479ef402680a669e25bd36de8a91d07 (patch)
treeb651f3bccb7d479cd6e622255b7b74475f3e6212 /x11/gnome-panel
parent2c96623ace7e7b99e5a3a30fc37e6a88ec7cd308 (diff)
downloadfreebsd-ports-gnome-8eefe69ae479ef402680a669e25bd36de8a91d07.tar.gz
freebsd-ports-gnome-8eefe69ae479ef402680a669e25bd36de8a91d07.tar.zst
freebsd-ports-gnome-8eefe69ae479ef402680a669e25bd36de8a91d07.zip
Update to 2.22.1.
Diffstat (limited to 'x11/gnome-panel')
-rw-r--r--x11/gnome-panel/Makefile8
-rw-r--r--x11/gnome-panel/distinfo6
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_clock-location.c31
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_gweather-xml.c11
-rw-r--r--x11/gnome-panel/files/patch-applets_clock_set-timezone.c22
-rw-r--r--x11/gnome-panel/pkg-plist4
6 files changed, 22 insertions, 60 deletions
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index 817e3850b5cc..8d930c00e29c 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -7,8 +7,8 @@
#
PORTNAME= gnome-panel
-PORTVERSION= 2.22.0
-PORTREVISION?= 3
+PORTVERSION= 2.22.1
+PORTREVISION?= 0
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gnome-panel/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -21,7 +21,7 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= gweather.0:${PORTSDIR}/net/libgweather \
+LIB_DEPENDS= gweather.1:${PORTSDIR}/net/libgweather \
polkit-gnome.0:${PORTSDIR}/sysutils/policykit-gnome
USE_GETTEXT= yes
@@ -69,8 +69,6 @@ post-patch:
@${FIND} ${WRKSRC} -type f | \
${XARGS} -n 10 ${REINPLACE_CMD} -e \
's|"applications.menu"|"gnome-applications.menu"|'
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/applets/clock/gweather-xml.c
.if ( ${OSVERSION} > 600000 && ${OSVERSION} < 600006 ) || \
( ${OSVERSION} < 503101 )
.for po in da.po it.po zh_CN.po zh_TW.po
diff --git a/x11/gnome-panel/distinfo b/x11/gnome-panel/distinfo
index 57f37c4c59d5..d5bc43d7667c 100644
--- a/x11/gnome-panel/distinfo
+++ b/x11/gnome-panel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-panel-2.22.0.tar.bz2) = fe10c920c1f182a2bd5dba98863c786c
-SHA256 (gnome2/gnome-panel-2.22.0.tar.bz2) = 8b2152b35e3d82a640c383b29e99a322595dca23269450ad8d3182bdd94b308a
-SIZE (gnome2/gnome-panel-2.22.0.tar.bz2) = 3267787
+MD5 (gnome2/gnome-panel-2.22.1.tar.bz2) = fb497e544c3873fffe9c12059838231b
+SHA256 (gnome2/gnome-panel-2.22.1.tar.bz2) = 60e1c8c65d069fd9129d681874c9fae9a3390b0b7a7fb484b1a09e683efac0c6
+SIZE (gnome2/gnome-panel-2.22.1.tar.bz2) = 3243201
diff --git a/x11/gnome-panel/files/patch-applets_clock_clock-location.c b/x11/gnome-panel/files/patch-applets_clock_clock-location.c
index 1bb485f32586..405c4b89634e 100644
--- a/x11/gnome-panel/files/patch-applets_clock_clock-location.c
+++ b/x11/gnome-panel/files/patch-applets_clock_clock-location.c
@@ -1,8 +1,8 @@
---- applets/clock/clock-location.c.orig 2008-03-22 21:14:45.000000000 -0400
-+++ applets/clock/clock-location.c 2008-03-23 02:11:34.000000000 -0400
-@@ -28,6 +28,8 @@
+--- applets/clock/clock-location.c.orig 2008-04-07 17:17:51.000000000 -0400
++++ applets/clock/clock-location.c 2008-04-07 22:54:31.000000000 -0400
+@@ -27,6 +27,8 @@
+ #include "clock-marshallers.h"
#include "set-timezone.h"
- #include "gweather-xml.h"
+#define daylight 1
+
@@ -17,15 +17,7 @@
#define PRIVATE(o) (G_TYPE_INSTANCE_GET_PRIVATE ((o), CLOCK_LOCATION_TYPE, ClockLocationPrivate))
-@@ -271,7 +274,6 @@ parse_etc_sysconfig_clock (void)
- }
- }
- }
--
- out:
- if (lines)
- g_strfreev (lines);
-@@ -298,7 +300,11 @@ zone_from_etc_sysconfig_clock (void)
+@@ -299,7 +302,11 @@ zone_from_etc_sysconfig_clock (void)
parse_etc_sysconfig_clock ();
@@ -37,8 +29,8 @@
monitor = g_file_monitor_file (file, G_FILE_MONITOR_NONE,
NULL, NULL);
-@@ -632,10 +638,17 @@ gboolean
- clock_location_is_current (ClockLocation *loc)
+@@ -642,12 +649,18 @@ gboolean
+ clock_location_is_current_timezone (ClockLocation *loc)
{
ClockLocationPrivate *priv = PRIVATE (loc);
- const char *zone;
@@ -47,13 +39,16 @@
- if ((zone = zone_from_etc_sysconfig_clock ()))
+ zones = clock_zonetable_new (SYSTEM_ZONEINFODIR);
-+
+ if ((zone = clock_location_guess_zone (zones))) {
+ g_object_unref (zones);
return strcmp (zone, priv->timezone) == 0;
+- else
+- return clock_location_get_offset (loc) == 0;
+ }
+
+ g_object_unref (zones);
-
- return clock_location_get_offset (loc) == 0;
++
++ return clock_location_get_offset (loc) == 0;
}
+
+ gboolean
diff --git a/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c b/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c
deleted file mode 100644
index 7ae87fdd360f..000000000000
--- a/x11/gnome-panel/files/patch-applets_clock_gweather-xml.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- applets/clock/gweather-xml.c.orig 2008-01-23 00:51:33.000000000 -0500
-+++ applets/clock/gweather-xml.c 2008-01-23 00:52:35.000000000 -0500
-@@ -359,7 +359,7 @@ gweather_xml_load_locations( GtkTreeView
- #ifdef GWEATHER_XML_LOCATION
- xml = xmlNewTextReaderFilename (GWEATHER_XML_LOCATION "Locations.xml");
- #else
-- xml = xmlNewTextReaderFilename ("/usr/share/gnome-applets/gweather/Locations.xml");
-+ xml = xmlNewTextReaderFilename ("/usr/local/share/libgweather/Locations.xml");
- #endif
- if( xml == NULL )
- goto error_out;
diff --git a/x11/gnome-panel/files/patch-applets_clock_set-timezone.c b/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
deleted file mode 100644
index 3a9fb4ae9fa8..000000000000
--- a/x11/gnome-panel/files/patch-applets_clock_set-timezone.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- trunk/applets/clock/set-timezone.c 2008/02/28 20:48:16 10908
-+++ applets/clock/set-timezone.c 2008/04/02 15:08:34 10972
-@@ -139,6 +139,9 @@
- DBusError dbus_error;
- gint res = 0;
-
-+ pk_caller = NULL;
-+ pk_action = NULL;
-+
- system_bus = dbus_g_connection_get_connection (get_system_bus ());
- if (system_bus == NULL)
- goto out;
-@@ -147,9 +150,6 @@
- if (pk_context == NULL)
- goto out;
-
-- pk_caller = NULL;
-- pk_action = NULL;
--
- pk_action = polkit_action_new ();
- polkit_action_set_action_id (pk_action, pk_action_id);
-
diff --git a/x11/gnome-panel/pkg-plist b/x11/gnome-panel/pkg-plist
index 776e004791d3..64030194a50b 100644
--- a/x11/gnome-panel/pkg-plist
+++ b/x11/gnome-panel/pkg-plist
@@ -42,7 +42,6 @@ share/gnome-2.0/ui/GNOME_WorkspaceSwitcherApplet.xml
%%DATADIR%%/glade/panel-properties-dialog.glade
%%DATADIR%%/glade/panel-run-dialog.glade
%%DATADIR%%/glade/panel-test-applets.glade
-%%DATADIR%%/glade/timezone.glade
%%DATADIR%%/glade/window-list.glade
%%DATADIR%%/glade/workspace-switcher.glade
%%DATADIR%%/iso3166.tab
@@ -311,6 +310,7 @@ share/locale/eu/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/fa/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/fi/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/fr/LC_MESSAGES/gnome-panel-2.0.mo
+share/locale/fur/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/ga/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/gl/LC_MESSAGES/gnome-panel-2.0.mo
share/locale/gu/LC_MESSAGES/gnome-panel-2.0.mo
@@ -607,6 +607,8 @@ share/omf/workspace-switcher/workspace-switcher-vi.omf
@dirrmtry share/locale/ku
@dirrmtry share/locale/hy/LC_MESSAGES
@dirrmtry share/locale/hy
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
@dirrmtry share/locale/dz/LC_MESSAGES
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES