aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-swallow/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /x11/gnome-swallow/Makefile
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11/gnome-swallow/Makefile')
-rw-r--r--x11/gnome-swallow/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11/gnome-swallow/Makefile b/x11/gnome-swallow/Makefile
index c48f33cc1a85..9758a54e84be 100644
--- a/x11/gnome-swallow/Makefile
+++ b/x11/gnome-swallow/Makefile
@@ -10,17 +10,17 @@ MASTER_SITES= http://interreality.org/~tetron/technology/swallow/
MAINTAINER= marcus@FreeBSD.org
COMMENT= Applet that swallows any X11 application into the GNOME 2 panel
-USE_XORG= x11
USES= gmake pathfix pkgconfig
USE_GNOME= gnomeprefix gnomepanel libgnomeui
+USE_XORG= x11
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
-LIBS+= -L${LOCALBASE}/lib `pkg-config --libs libgnomeui-2.0`
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
${WRKSRC}/GNOME_Swallow.server
+ @${REINPLACE_CMD} 's/libpanelapplet-2.0/& libgnomeui-2.0 x11/' \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.mk>