aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-terminal/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-08-05 12:04:24 +0800
committermarcus <marcus@FreeBSD.org>2002-08-05 12:04:24 +0800
commit57ca97c17cf8150d9524f1413935ddc013c81135 (patch)
tree22d40c0c528f67662e80f3f044e8808792feabea /x11/gnome-terminal/Makefile
parent984c00fcafc35de3014723afe49bc4a12ebea925 (diff)
downloadfreebsd-ports-gnome-57ca97c17cf8150d9524f1413935ddc013c81135.tar.gz
freebsd-ports-gnome-57ca97c17cf8150d9524f1413935ddc013c81135.tar.zst
freebsd-ports-gnome-57ca97c17cf8150d9524f1413935ddc013c81135.zip
Update to 2.0.1.
This is mainly a bug fix release with a few added translations. A full list of changes can be found in WRKSRC/ChangeLog.
Diffstat (limited to 'x11/gnome-terminal/Makefile')
-rw-r--r--x11/gnome-terminal/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index 9b1a82ae7343..973a5d66ac5e 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnometerminal
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= 2.0.0/releases/gnome-2.0-desktop-final
+MASTER_SITE_SUBDIR= 2.0.0/sources/gnome-terminal
DISTNAME= gnome-terminal-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -23,19 +22,15 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>