aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome-terminal
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
committermarcus <marcus@FreeBSD.org>2009-01-10 13:22:13 +0800
commit6d8ed8f7c7511223163de715a97ffc04bf6fada9 (patch)
tree40dc015efe383243b0880df377f73ee250da7de7 /x11/gnome-terminal
parentc7f342a8d7b82e85b9625c4403600fc20ce41da6 (diff)
downloadfreebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.gz
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.tar.zst
freebsd-ports-gnome-6d8ed8f7c7511223163de715a97ffc04bf6fada9.zip
Presenting GNOME 2.24 for FreeBSD.
See http://library.gnome.org/misc/release-notes/2.24/ for the general release notes. On the FreeBSD front, this release introduces Fuse support in HAL, adds multi-CPU support to libgtop, WebKit updates, and fixes some long-standing seahorse and gnome-keyring bugs. The documentation updates to the website are forthcoming. This release features commits by adamw, ahze, kwm, mezz, and myself. It would not have been possible without are contributors and testers: Alexander Loginov Craig Butler [1] Dmitry Marakasov [6] Eric L. Chen Joseph S. Atkinson Kris Moore Lapo Luchini [7] Nikos Ntarmos Pawel Worach Romain Tartiere TAOKA Fumiyoshi [3] Yasuda Keisuke Zyl aZ [4] bf [2] [5] Florent Thoumie Peter Wemm pluknet PR: 125857 [1] 126993 [2] 130031 [3] 127399 [4] 127661 [5] 124302 [6] 129570 [7] 129936 123790
Diffstat (limited to 'x11/gnome-terminal')
-rw-r--r--x11/gnome-terminal/Makefile4
-rw-r--r--x11/gnome-terminal/distinfo6
-rw-r--r--x11/gnome-terminal/files/patch-src_terminal-screen.c82
-rw-r--r--x11/gnome-terminal/pkg-plist27
4 files changed, 28 insertions, 91 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index adf1411b5cfd..f4a01ce3972c 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -3,11 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome-terminal/Makefile,v 1.101 2008/03/11 02:42:58 mezz Exp $
+# $MCom: ports/x11/gnome-terminal/Makefile,v 1.113 2008/11/25 05:43:25 mezz Exp $
#
PORTNAME= gnome-terminal
-PORTVERSION= 2.22.3
+PORTVERSION= 2.24.2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11/gnome-terminal/distinfo b/x11/gnome-terminal/distinfo
index e0fbe6d40c65..7e3356076669 100644
--- a/x11/gnome-terminal/distinfo
+++ b/x11/gnome-terminal/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-terminal-2.22.3.tar.bz2) = ef61930fbafe81406c934dcf97efec09
-SHA256 (gnome2/gnome-terminal-2.22.3.tar.bz2) = fffe2b352167fa42680cae79be80c5082cd4a04f712564bc4ae5ff0253509cd7
-SIZE (gnome2/gnome-terminal-2.22.3.tar.bz2) = 1803177
+MD5 (gnome2/gnome-terminal-2.24.2.tar.bz2) = c864ee43335db306e344df41e0090d4f
+SHA256 (gnome2/gnome-terminal-2.24.2.tar.bz2) = 849597d79f2dd6eb8d4079bc0b59c0f806a691ac2af360099ef0fa1f6b91e82a
+SIZE (gnome2/gnome-terminal-2.24.2.tar.bz2) = 1854226
diff --git a/x11/gnome-terminal/files/patch-src_terminal-screen.c b/x11/gnome-terminal/files/patch-src_terminal-screen.c
deleted file mode 100644
index ed0df8903943..000000000000
--- a/x11/gnome-terminal/files/patch-src_terminal-screen.c
+++ /dev/null
@@ -1,82 +0,0 @@
---- src/terminal-screen.c.orig Wed Oct 18 15:50:28 2006
-+++ src/terminal-screen.c Wed Oct 18 15:49:42 2006
-@@ -244,6 +244,10 @@
- GtkAllocation *allocation)
- {
- GtkWidget *child;
-+ GtkAllocation old_allocation;
-+
-+ old_allocation.width = widget->allocation.width;
-+ old_allocation.height = widget->allocation.height;
-
- widget->allocation = *allocation;
-
-@@ -251,6 +255,13 @@
- g_assert (child != NULL);
-
- gtk_widget_size_allocate (child, allocation);
-+
-+ if (old_allocation.width != allocation->width ||
-+ old_allocation.height != allocation->height)
-+ {
-+ GtkWidget *term = TERMINAL_SCREEN (widget)->priv->term;
-+ gtk_widget_queue_resize_no_redraw (term);
-+ }
- }
-
- static void
-@@ -278,22 +289,22 @@
- #define URLPATH "/[" PATHCHARS "]*[^]'.}>) \t\r\n,\\\"]"
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
-- "(:[0-9]+)?(" URLPATH ")?\\>/?", FLAVOR_AS_IS);
-+ "[[:<:]]" SCHEME "//(" USER "@)?[" HOSTCHARS ".]+"
-+ "(:[0-9]+)?(" URLPATH ")?[[:>:]]/?", FLAVOR_AS_IS);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
-- "(:[0-9]+)?(" URLPATH ")?\\>/?",
-+ "[[:<:]](www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+"
-+ "(:[0-9]+)?(" URLPATH ")?[[:>:]]/?",
- FLAVOR_DEFAULT_TO_HTTP);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<(mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9]"
-- "[a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>",
-+ "[[:<:]](mailto:)?[a-z0-9][a-z0-9.-]*@[a-z0-9]"
-+ "[a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+[[:>:]]",
- FLAVOR_EMAIL);
-
- terminal_widget_match_add (screen->priv->term,
-- "\\<news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+"
-- "@[" HOSTCHARS ".]+(:[0-9]+)?\\>", FLAVOR_AS_IS);
-+ "[[:<:]]news:[-A-Z\\^_a-z{|}~!\"#$%&'()*+,./0-9;:=?`]+"
-+ "@[" HOSTCHARS ".]+(:[0-9]+)?[[:>:]]", FLAVOR_AS_IS);
-
- terminal_screen_setup_dnd (screen);
-
-@@ -548,7 +559,6 @@
- */
- terminal_screen_update_scrollbar (screen);
- terminal_window_update_icon (screen->priv->window);
-- terminal_window_update_geometry (screen->priv->window);
- }
-
- if (GTK_WIDGET_REALIZED (screen->priv->term))
-@@ -909,7 +919,6 @@
-
- terminal_widget_set_allow_bold (term,
- terminal_profile_get_allow_bold (profile));
-- terminal_window_set_size (screen->priv->window, screen, TRUE);
- }
-
- static void
-@@ -1019,6 +1028,7 @@
- GtkWidget*
- terminal_screen_get_widget (TerminalScreen *screen)
- {
-+ if (screen == NULL) return NULL;
- return screen->priv->term;
- }
-
diff --git a/x11/gnome-terminal/pkg-plist b/x11/gnome-terminal/pkg-plist
index 690ad8893f3d..bef6f9e81cc3 100644
--- a/x11/gnome-terminal/pkg-plist
+++ b/x11/gnome-terminal/pkg-plist
@@ -1,7 +1,13 @@
bin/gnome-terminal
libdata/bonobo/servers/gnome-terminal.server
share/applications/gnome-terminal.desktop
-%%DATADIR%%/glade/gnome-terminal.glade2
+%%DATADIR%%/encodings-dialog.ui
+%%DATADIR%%/keybinding-editor.ui
+%%DATADIR%%/profile-manager.ui
+%%DATADIR%%/profile-new-dialog.ui
+%%DATADIR%%/profile-preferences.ui
+%%DATADIR%%/skey-challenge.ui
+%%DATADIR%%/terminal.xml
share/gnome/help/gnome-terminal/C/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/C/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/C/gnome-terminal.xml
@@ -13,6 +19,9 @@ share/gnome/help/gnome-terminal/bg/legal.xml
share/gnome/help/gnome-terminal/ca/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/ca/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/ca/gnome-terminal.xml
+share/gnome/help/gnome-terminal/cs/figures/gnome-terminal-default.png
+share/gnome/help/gnome-terminal/cs/figures/gnome-terminal-tabbed.png
+share/gnome/help/gnome-terminal/cs/gnome-terminal.xml
share/gnome/help/gnome-terminal/de/figures/gnome-terminal-default.png
share/gnome/help/gnome-terminal/de/figures/gnome-terminal-tabbed.png
share/gnome/help/gnome-terminal/de/gnome-terminal.xml
@@ -97,10 +106,12 @@ share/locale/id/LC_MESSAGES/gnome-terminal.mo
share/locale/it/LC_MESSAGES/gnome-terminal.mo
share/locale/ja/LC_MESSAGES/gnome-terminal.mo
share/locale/ka/LC_MESSAGES/gnome-terminal.mo
+share/locale/kn/LC_MESSAGES/gnome-terminal.mo
share/locale/ko/LC_MESSAGES/gnome-terminal.mo
share/locale/ku/LC_MESSAGES/gnome-terminal.mo
share/locale/lt/LC_MESSAGES/gnome-terminal.mo
share/locale/lv/LC_MESSAGES/gnome-terminal.mo
+share/locale/mai/LC_MESSAGES/gnome-terminal.mo
share/locale/mg/LC_MESSAGES/gnome-terminal.mo
share/locale/mk/LC_MESSAGES/gnome-terminal.mo
share/locale/ml/LC_MESSAGES/gnome-terminal.mo
@@ -115,6 +126,7 @@ share/locale/oc/LC_MESSAGES/gnome-terminal.mo
share/locale/or/LC_MESSAGES/gnome-terminal.mo
share/locale/pa/LC_MESSAGES/gnome-terminal.mo
share/locale/pl/LC_MESSAGES/gnome-terminal.mo
+share/locale/ps/LC_MESSAGES/gnome-terminal.mo
share/locale/pt/LC_MESSAGES/gnome-terminal.mo
share/locale/pt_BR/LC_MESSAGES/gnome-terminal.mo
share/locale/ro/LC_MESSAGES/gnome-terminal.mo
@@ -125,7 +137,7 @@ share/locale/sk/LC_MESSAGES/gnome-terminal.mo
share/locale/sl/LC_MESSAGES/gnome-terminal.mo
share/locale/sq/LC_MESSAGES/gnome-terminal.mo
share/locale/sr/LC_MESSAGES/gnome-terminal.mo
-share/locale/sr@Latn/LC_MESSAGES/gnome-terminal.mo
+share/locale/sr@latin/LC_MESSAGES/gnome-terminal.mo
share/locale/sv/LC_MESSAGES/gnome-terminal.mo
share/locale/ta/LC_MESSAGES/gnome-terminal.mo
share/locale/te/LC_MESSAGES/gnome-terminal.mo
@@ -141,6 +153,7 @@ share/locale/zh_TW/LC_MESSAGES/gnome-terminal.mo
share/omf/gnome-terminal/gnome-terminal-C.omf
share/omf/gnome-terminal/gnome-terminal-bg.omf
share/omf/gnome-terminal/gnome-terminal-ca.omf
+share/omf/gnome-terminal/gnome-terminal-cs.omf
share/omf/gnome-terminal/gnome-terminal-de.omf
share/omf/gnome-terminal/gnome-terminal-es.omf
share/omf/gnome-terminal/gnome-terminal-fr.omf
@@ -155,7 +168,6 @@ share/omf/gnome-terminal/gnome-terminal-sv.omf
share/omf/gnome-terminal/gnome-terminal-uk.omf
share/omf/gnome-terminal/gnome-terminal-zh_CN.omf
share/omf/gnome-terminal/gnome-terminal-zh_TW.omf
-share/pixmaps/gnome-terminal.png
@dirrm share/omf/gnome-terminal
@dirrm share/gnome/help/gnome-terminal/zh_TW/figures
@dirrm share/gnome/help/gnome-terminal/zh_TW
@@ -185,6 +197,8 @@ share/pixmaps/gnome-terminal.png
@dirrm share/gnome/help/gnome-terminal/es
@dirrm share/gnome/help/gnome-terminal/de/figures
@dirrm share/gnome/help/gnome-terminal/de
+@dirrm share/gnome/help/gnome-terminal/cs/figures
+@dirrm share/gnome/help/gnome-terminal/cs
@dirrm share/gnome/help/gnome-terminal/ca/figures
@dirrm share/gnome/help/gnome-terminal/ca
@dirrm share/gnome/help/gnome-terminal/bg/figures
@@ -192,7 +206,6 @@ share/pixmaps/gnome-terminal.png
@dirrm share/gnome/help/gnome-terminal/C/figures
@dirrm share/gnome/help/gnome-terminal/C
@dirrm share/gnome/help/gnome-terminal
-@dirrm %%DATADIR%%/glade
@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@@ -201,16 +214,22 @@ share/pixmaps/gnome-terminal.png
@dirrmtry share/locale/xh
@dirrmtry share/locale/te/LC_MESSAGES
@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ps/LC_MESSAGES
+@dirrmtry share/locale/ps
@dirrmtry share/locale/oc/LC_MESSAGES
@dirrmtry share/locale/oc
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
@dirrmtry share/locale/mg/LC_MESSAGES
@dirrmtry share/locale/mg
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
@dirrmtry share/locale/ku/LC_MESSAGES
@dirrmtry share/locale/ku
@dirrmtry share/locale/hy/LC_MESSAGES