aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome2
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-09-18 14:49:37 +0800
committermarcus <marcus@FreeBSD.org>2003-09-18 14:49:37 +0800
commit5797d600f46f09de6f7e9f89bd9546544d3f93e6 (patch)
treef29aa772e064572f168522a552ce158c9147a8a2 /x11/gnome2
parentf8ccc20f69f18bf5f775fc1a7f7a5098f7173ac1 (diff)
downloadfreebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.tar.gz
freebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.tar.zst
freebsd-ports-gnome-5797d600f46f09de6f7e9f89bd9546544d3f93e6.zip
Update to GNOME 2.4.0. For all the goodies on what's changed, known issues,
future plans, etc., please see http://www.gnome.org/start/2.4/. This commit represents work done by adamw, bland, and myself as well as many other contributers: Koop Mast <einekoai@chello.nl> Akifyev Sergey <asa@gascom.ru> Franz Klammer <klammer@webonaut.com> Øyvind Kolbu <oyvind@kebab.gaffel.nu> Thomas E. Zander <riggs@rrr.de> Jeremy Messenger <mezz7@cox.net> Without these contirbuters, and our faithful users, GNOME 2.4.0 would not be possible. Please check the FreeBSD GNOME site for any FreeBSD gotchas, as well as general FAQs and documentation (GNOME 2.4 updates to be posted soon). The best way to upgrade so that you get all shared library dependencies is: portupgrade -rf -m BATCH=yes atk portupgrade -R -m BATCH=yes gnome2 Approved by: portmgr (kris, will, myself implicitly) Requested by: re as well as many other users
Diffstat (limited to 'x11/gnome2')
-rw-r--r--x11/gnome2/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/x11/gnome2/Makefile b/x11/gnome2/Makefile
index f95aaaf239a3..9f4b03562e1e 100644
--- a/x11/gnome2/Makefile
+++ b/x11/gnome2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome2
-PORTVERSION= 2.2.2
-PORTREVISION= 2
+PORTVERSION= 2.4.0
CATEGORIES= x11 gnome
MASTER_SITES= # empty
DISTFILES= # empty
@@ -18,7 +17,7 @@ COMMENT= The "meta-port" for the GNOME 2 integrated X11 desktop
RUN_DEPENDS= ${X11BASE}/libexec/cdplayer_applet2:${PORTSDIR}/x11/gnomeapplets2 \
gnome-cd:${PORTSDIR}/audio/gnomemedia2 \
- gnome-calculator:${PORTSDIR}/deskutils/gnomeutils2 \
+ gnome-dictionary:${PORTSDIR}/deskutils/gnomeutils2 \
eog:${PORTSDIR}/graphics/eog2 \
gnome-control-center:${PORTSDIR}/sysutils/gnomecontrolcenter2 \
gconf-editor:${PORTSDIR}/sysutils/gconf-editor \
@@ -26,7 +25,6 @@ RUN_DEPENDS= ${X11BASE}/libexec/cdplayer_applet2:${PORTSDIR}/x11/gnomeapplets2 \
gedit:${PORTSDIR}/editors/gedit2 \
gnome-terminal:${PORTSDIR}/x11/gnometerminal \
gnome-session:${PORTSDIR}/x11/gnomesession \
- metacity:${PORTSDIR}/x11-wm/metacity \
bug-buddy:${PORTSDIR}/devel/bugbuddy2 \
gnome-system-monitor:${PORTSDIR}/sysutils/gnomesystemmonitor \
nautilus:${PORTSDIR}/x11-fm/nautilus2 \
@@ -36,21 +34,27 @@ RUN_DEPENDS= ${X11BASE}/libexec/cdplayer_applet2:${PORTSDIR}/x11/gnomeapplets2 \
${X11BASE}/share/gnome/help/user-guide/C/user-guide.xml:${PORTSDIR}/misc/gnomeuserdocs2 \
${X11BASE}/share/gnome/sounds/question.wav:${PORTSDIR}/audio/gnomeaudio2 \
${X11BASE}/libdata/pkgconfig/libgail-gnome.pc:${PORTSDIR}/x11-toolkits/libgail-gnome \
- ${X11BASE}/libdata/pkgconfig/vte.pc:${PORTSDIR}/x11-toolkits/vte \
- ${X11BASE}/libdata/pkgconfig/libzvt-2.0.pc:${PORTSDIR}/x11-toolkits/libzvt \
file-roller:${PORTSDIR}/archivers/fileroller \
${X11BASE}/share/themes/HighContrast/gtk-2.0/gtkrc:${PORTSDIR}/x11-toolkits/gnome-themes \
ggv:${PORTSDIR}/print/ggv2 \
- gnome-pkgview:${PORTSDIR}/sysutils/gnome-pkgview \
acme:${PORTSDIR}/multimedia/acme \
+ gok:${PORTSDIR}/sysutils/gok \
+ gpdf:${PORTSDIR}/graphics/gpdf \
+ nautilus-cd-burner:${PORTSDIR}/sysutils/nautilus-cd-burner \
+ gcalctool:${PORTSDIR}/math/gcalctool \
+ gucharmap:${PORTSDIR}/deskutils/gucharmap \
+ zenity:${PORTSDIR}/x11/zenity \
gst-thumbnail:${PORTSDIR}/multimedia/nautilus-media \
- ${X11BASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera
+ ${X11BASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
+ gnomemeeting:${PORTSDIR}/net/gnomemeeting \
+ epiphany:${PORTSDIR}/www/epiphany \
+ gnopernicus:${PORTSDIR}/x11/gnopernicus
NO_BUILD= yes
USE_PYTHON= yes
-.if !defined(PACKAGE_BUILDING)
+.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-configure:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
.endif