aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnomesession/Makefile
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-05-29 04:17:56 +0800
committermezz <mezz@FreeBSD.org>2006-05-29 04:17:56 +0800
commitacf4de44afd0dc676b490d8a6d8a28fc879b3ffc (patch)
treeffa65bc93b7094f6a0beacd1022b557996628382 /x11/gnomesession/Makefile
parent2372b522f3e9c44b1207467c13d75f3f8041a995 (diff)
downloadfreebsd-ports-gnome-acf4de44afd0dc676b490d8a6d8a28fc879b3ffc.tar.gz
freebsd-ports-gnome-acf4de44afd0dc676b490d8a6d8a28fc879b3ffc.tar.zst
freebsd-ports-gnome-acf4de44afd0dc676b490d8a6d8a28fc879b3ffc.zip
x11/gnomesession -> x11/gnome-session
Rename this ports to use the real vendor package name. The advantage of this is to allow our users' keyword search works and easier for users to file the Bugzilla report when they use our name of ports. Debian, Gentoo, NetBSD and other OSs have the correct package name, but not in our ports tree. My team, FreeBSD GNOME Team, have agreed with it. As for other ports, chase the rename. PR: ports/97985 Repocopy by: marcus
Diffstat (limited to 'x11/gnomesession/Makefile')
-rw-r--r--x11/gnomesession/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/x11/gnomesession/Makefile b/x11/gnomesession/Makefile
deleted file mode 100644
index fcdee9b27fe1..000000000000
--- a/x11/gnomesession/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: gnomesession
-# Date created: 08 May 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
-# $FreeBSD$
-# $MCom: ports/x11/gnomesession/Makefile,v 1.83 2006/04/24 03:18:23 marcus Exp $
-#
-
-PORTNAME= gnomesession
-PORTVERSION= 2.14.1
-PORTREVISION= 2
-CATEGORIES= x11 gnome
-MASTER_SITES= ${MASTER_SITE_GNOME} \
- ${MASTER_SITE_LOCAL:S/$/:local/} \
- http://people.FreeBSD.org/~adamw/images/gnome_splashes/2.12/:local
-MASTER_SITE_SUBDIR= sources/gnome-session/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/} \
- adamw/:local
-DISTNAME= gnome-session-${PORTVERSION}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${SPLASHES}:local
-DIST_SUBDIR= gnome2
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-
-MAINTAINER= gnome@FreeBSD.org
-COMMENT= Session component for the GNOME 2 desktop
-
-USE_GETTEXT= yes
-USE_BZIP2= yes
-USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop
-GNOME_DESKTOP_VERSION=2
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-
-MAN1= gnome-session.1 gnome-wm.1 session-properties.1 \
- gnome-session-save.1
-MAN5= default.session.5
-GCONF_SCHEMAS= gnome-session.schemas
-
-SPLASHES= freebsd-splashes-gnome-2.12.1.tar
-
-post-extract:
- cd ${WRKDIR} && ${TAR} xf ${DISTDIR}/${DIST_SUBDIR}/${SPLASHES}
-
-post-install:
- ${INSTALL_DATA} ${WRKSRC}/gnome-session/gnome-splash.png \
- ${PREFIX}/share/gnome/pixmaps/splash/original-gnome-splash.png
-# ${INSTALL_DATA} ${WRKDIR}/freebsd-splashes-gnome-2.12/domix-splash-2.12.png \
-# ${PREFIX}/share/gnome/pixmaps/splash/gnome-splash.png
-.for splash in MaMBaNgGaoX-2.12.png adamw-piggy-2.12.png adamw-trophy-2.12.png andreas-slogan-2.12.png andreas-splash-2.12.png domix-splash-2.12.png domix-splash2-2.12.png mumija-2.12.png mumija2-2.12.png mumija3-2.12.png tremulant-2.12.png tremulant-blood-2.12.png tremulant-brushed-metal-2.12.png
- ${INSTALL_DATA} ${WRKDIR}/freebsd-splashes-gnome-2.12/${splash} \
- ${PREFIX}/share/gnome/pixmaps/splash
-.endfor
-
-.include <bsd.port.mk>