aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnustep-app
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2006-11-02 03:23:52 +0800
committerdinoex <dinoex@FreeBSD.org>2006-11-02 03:23:52 +0800
commit735f092847d6d364a47559f1fc98dc61adee03ed (patch)
treea27a9450e564a3eeb4c5d6778ec0631803f024b7 /x11/gnustep-app
parent18f4e5aef67216e1d8424b6431cb13aa3f5d6b47 (diff)
downloadfreebsd-ports-gnome-735f092847d6d364a47559f1fc98dc61adee03ed.tar.gz
freebsd-ports-gnome-735f092847d6d364a47559f1fc98dc61adee03ed.tar.zst
freebsd-ports-gnome-735f092847d6d364a47559f1fc98dc61adee03ed.zip
Collection of GNUstep software
System libs: Gorm, ScriptKit, gnustep-db2, Renaissance, PreferencePanes System apps: GShisen, ProjectCenter, Preferences, GWorkspace, guile-gui, gui, TextEdit, TimeMon, Terminal, Emacs, GSPdf, SystemPreferences Local libs: Pantomime, GToolKit, rigs, Addresses, SlideShow, netclasses, WizardKit, HighlighterKit, Performance, SQLClient, WebServer, StepTalk, MathArray Local apps: Gomoku, GNUMail, EasyDiff, Calculator, CurrencyConverter, Finger, GFractal, GSTest, HostAddress, Ink, NSBrowserTest, NSImageTest, NSPanelTest, NSScreenTest, md5Digest, GSCommander, ImageViewer, SlideShow, Preview, oolite, Cenon, Gridlock, PRICE, EdenMath, Stepulator, VolumeControl, Cynthiune, TalkSoup, Grouch, Zipper, Camera, Ladder, StepBill, Charmap, GTAMSAnalyzer, Paje, AClock, PhotoClip, LapisPuzzle, Waiho, Affiche, ProjectManager, GMastermind2, GPuzzle2, Ticker, NoteBook, HelpViewer, Duncan, Jishyo
Diffstat (limited to 'x11/gnustep-app')
-rw-r--r--x11/gnustep-app/Makefile99
-rw-r--r--x11/gnustep-app/pkg-descr21
2 files changed, 120 insertions, 0 deletions
diff --git a/x11/gnustep-app/Makefile b/x11/gnustep-app/Makefile
new file mode 100644
index 000000000000..fb3531ffcc24
--- /dev/null
+++ b/x11/gnustep-app/Makefile
@@ -0,0 +1,99 @@
+# New ports collection makefile for: gnustep-app
+# Date created: 28 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnustep-app
+PORTVERSION= 1.13.0
+CATEGORIES= x11
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Metaport for GNUstep applications
+
+NO_BUILD= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_GUI= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_XLIB= yes
+USE_GNUSTEP_LIBART= yes
+
+USE_GNUSTEP_SYSTEM_LIBS+= Gorm:devel/gorm
+USE_GNUSTEP_SYSTEM_LIBS+= ScriptKit:lang/gnustep-guile
+USE_GNUSTEP_SYSTEM_LIBS+= gnustep-db2:databases/gdl2
+USE_GNUSTEP_SYSTEM_LIBS+= Renaissance:x11-toolkits/renaissance
+USE_GNUSTEP_SYSTEM_LIBS+= PreferencePanes:deskutils/preferencepanes
+
+USE_GNUSTEP_SYSTEM_APPS+= GShisen:games/gshisen
+USE_GNUSTEP_SYSTEM_APPS+= ProjectCenter:devel/projectcenter.app
+USE_GNUSTEP_SYSTEM_APPS+= Preferences:deskutils/preferences.app
+USE_GNUSTEP_SYSTEM_APPS+= GWorkspace:deskutils/gworkspace
+USE_GNUSTEP_SYSTEM_APPS+= TextEdit:editors/textedit.app
+USE_GNUSTEP_SYSTEM_APPS+= TimeMon:sysutils/timemon
+USE_GNUSTEP_SYSTEM_APPS+= Terminal:x11/terminal.app
+USE_GNUSTEP_SYSTEM_APPS+= Emacs:editors/emacs.app
+USE_GNUSTEP_SYSTEM_APPS+= GSPdf:print/gspdf
+USE_GNUSTEP_SYSTEM_APPS+= SystemPreferences:deskutils/systempreferences
+
+USE_GNUSTEP_LOCAL_LIBS+= Pantomime:mail/pantomime
+USE_GNUSTEP_LOCAL_LIBS+= GToolKit:x11-toolkits/gtoolkit
+USE_GNUSTEP_LOCAL_LIBS+= rigs:devel/ruby-gnustep
+USE_GNUSTEP_LOCAL_LIBS+= Addresses:mail/addresses
+USE_GNUSTEP_LOCAL_LIBS+= SlideShow:graphics/gnustep-slideshowkit
+USE_GNUSTEP_LOCAL_LIBS+= netclasses:net/netclasses
+USE_GNUSTEP_LOCAL_LIBS+= WizardKit:devel/wizardkit
+USE_GNUSTEP_LOCAL_LIBS+= HighlighterKit:devel/highlighterkit
+USE_GNUSTEP_LOCAL_LIBS+= Performance:devel/performance
+USE_GNUSTEP_LOCAL_LIBS+= SQLClient:databases/sqlclient
+USE_GNUSTEP_LOCAL_LIBS+= WebServer:www/webserver
+USE_GNUSTEP_LOCAL_LIBS+= StepTalk:lang/steptalk
+USE_GNUSTEP_LOCAL_LIBS+= MathArray:math/matharray
+
+USE_GNUSTEP_LOCAL_APPS+= Gomoku:games/gomoku.app
+USE_GNUSTEP_LOCAL_APPS+= GNUMail:mail/gnumail
+USE_GNUSTEP_LOCAL_APPS+= EasyDiff:textproc/easydiff
+USE_GNUSTEP_LOCAL_APPS+= Ink:misc/gnustep-examples
+USE_GNUSTEP_LOCAL_APPS+= GSCommander:shells/gscommander
+USE_GNUSTEP_LOCAL_APPS+= ImageViewer:graphics/imageviewer
+USE_GNUSTEP_LOCAL_APPS+= SlideShow:graphics/gnustep-slideshow
+USE_GNUSTEP_LOCAL_APPS+= Preview:graphics/preview
+USE_GNUSTEP_LOCAL_APPS+= oolite:games/oolite
+USE_GNUSTEP_LOCAL_APPS+= Cenon:graphics/cenon
+USE_GNUSTEP_LOCAL_APPS+= Gridlock:games/gridlock
+USE_GNUSTEP_LOCAL_APPS+= PRICE:graphics/price
+USE_GNUSTEP_LOCAL_APPS+= EdenMath:math/edenmath
+USE_GNUSTEP_LOCAL_APPS+= Stepulator:math/stepulator
+USE_GNUSTEP_LOCAL_APPS+= VolumeControl:audio/volumecontrol.app
+USE_GNUSTEP_LOCAL_APPS+= Cynthiune:audio/cynthiune
+USE_GNUSTEP_LOCAL_APPS+= TalkSoup:irc/talksoup
+USE_GNUSTEP_LOCAL_APPS+= Grouch:net-im/grouch
+USE_GNUSTEP_LOCAL_APPS+= Zipper:archivers/zipper
+USE_GNUSTEP_LOCAL_APPS+= Camera:graphics/camera
+USE_GNUSTEP_LOCAL_APPS+= Ladder:games/gnustep-ladder
+USE_GNUSTEP_LOCAL_APPS+= StepBill:games/stepbill
+USE_GNUSTEP_LOCAL_APPS+= Charmap:deskutils/charmap
+USE_GNUSTEP_LOCAL_APPS+= GTAMSAnalyzer:science/gtamsanalyzer
+USE_GNUSTEP_LOCAL_APPS+= Paje:science/paje
+USE_GNUSTEP_LOCAL_APPS+= AClock:x11-clocks/aclock
+USE_GNUSTEP_LOCAL_APPS+= PhotoClip:graphics/photoclip
+USE_GNUSTEP_LOCAL_APPS+= LapisPuzzle:games/lapispuzzle
+USE_GNUSTEP_LOCAL_APPS+= Waiho:ftp/waiho
+USE_GNUSTEP_LOCAL_APPS+= Affiche:deskutils/affiche
+USE_GNUSTEP_LOCAL_APPS+= ProjectManager:devel/projectmanager
+USE_GNUSTEP_LOCAL_APPS+= GMastermind2:games/gmastermind
+USE_GNUSTEP_LOCAL_APPS+= GPuzzle2:games/gpuzzle
+USE_GNUSTEP_LOCAL_APPS+= Ticker:www/gnustep-ticker
+USE_GNUSTEP_LOCAL_APPS+= NoteBook:deskutils/gnustep-notebook
+USE_GNUSTEP_LOCAL_APPS+= HelpViewer:deskutils/helpviewer
+#USE_GNUSTEP_LOCAL_APPS+= Duncan:textproc/duncan
+#USE_GNUSTEP_LOCAL_APPS+= Jishyo:japanese/jishyo
+
+do-install: # empty
+
+.include <bsd.port.mk>
diff --git a/x11/gnustep-app/pkg-descr b/x11/gnustep-app/pkg-descr
new file mode 100644
index 000000000000..77367cadbc05
--- /dev/null
+++ b/x11/gnustep-app/pkg-descr
@@ -0,0 +1,21 @@
+Collection of GNUstep software
+
+System libs: Gorm, ScriptKit, gnustep-db2, Renaissance, PreferencePanes
+
+System apps: GShisen, ProjectCenter, Preferences, GWorkspace, guile-gui,
+ gui, TextEdit, TimeMon, Terminal, Emacs, GSPdf,
+ SystemPreferences
+
+Local libs: Pantomime, GToolKit, rigs, Addresses, SlideShow, netclasses,
+ WizardKit, HighlighterKit, Performance, SQLClient, WebServer,
+ StepTalk, MathArray
+
+Local apps: Gomoku, GNUMail, EasyDiff, Calculator, CurrencyConverter,
+ Finger, GFractal, GSTest, HostAddress, Ink, NSBrowserTest,
+ NSImageTest, NSPanelTest, NSScreenTest, md5Digest,
+ GSCommander, ImageViewer, SlideShow, Preview, oolite, Cenon,
+ Gridlock, PRICE, EdenMath, Stepulator, VolumeControl,
+ Cynthiune, TalkSoup, Grouch, Zipper, Camera, Ladder, StepBill,
+ Charmap, GTAMSAnalyzer, Paje, AClock, PhotoClip, LapisPuzzle,
+ Waiho, Affiche, ProjectManager, GMastermind2, GPuzzle2,
+ Ticker, NoteBook, HelpViewer, Duncan, Jishyo