aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gyroscope
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
commit72ce7050d03c812e37966786e11996a90713afea (patch)
tree9ec01d647da1c4e80223e31fc766740c2a43ebff /x11/gyroscope
parent97830337b8c0333a12d15a49ea1f9c9cdc3dfddf (diff)
downloadfreebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.gz
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.zst
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.zip
Implement USE_GTK, part 2.
Diffstat (limited to 'x11/gyroscope')
-rw-r--r--x11/gyroscope/Makefile7
-rw-r--r--x11/gyroscope/files/patch-aa2
2 files changed, 3 insertions, 6 deletions
diff --git a/x11/gyroscope/Makefile b/x11/gyroscope/Makefile
index e7326500c1e7..9c9a3d849a6b 100644
--- a/x11/gyroscope/Makefile
+++ b/x11/gyroscope/Makefile
@@ -12,14 +12,11 @@ MASTER_SITES= http://soupnazi.org/FreeBSD/ports/distfiles/
MAINTAINER= jim@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_X_PREFIX= yes
-MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
+USE_GTK= yes
+
ALL_TARGET= # empty
.include <bsd.port.mk>
diff --git a/x11/gyroscope/files/patch-aa b/x11/gyroscope/files/patch-aa
index 82cb04fefa7c..c012ee216243 100644
--- a/x11/gyroscope/files/patch-aa
+++ b/x11/gyroscope/files/patch-aa
@@ -28,4 +28,4 @@
install:
- cp ./$(BINARYNAME) $(BIN_DIR)$(BINARYNAME)
-+ @/usr/bin/install -c -o 0 -g 0 -s -m 1755 ${BINARYNAME} ${BIN_DIR}/${BINARYNAME}
++ ${BSD_INSTALL_PROGRAM} ${BINARYNAME} ${BIN_DIR}/${BINARYNAME}