aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-baseapps/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-04-22 07:47:50 +0800
committerwill <will@FreeBSD.org>2002-04-22 07:47:50 +0800
commit9a055e87611beb41b98be5a2fe9e0206e33101e8 (patch)
treec06250f8a52c1d8b199e541cd41068fe11b11219 /x11/kde4-baseapps/Makefile
parentb471bb2de2ef8435ad3f5071b5ba82d535385f85 (diff)
downloadfreebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.tar.gz
freebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.tar.zst
freebsd-ports-gnome-9a055e87611beb41b98be5a2fe9e0206e33101e8.zip
Please welcome Qt3/KDE3 to our ports tree. This includes work since the
original versions of these ports, so some PORTREVISIONs were bumped. See http://freebsd.kde.org/ and mailing lists linked to from there for info on the packages generated to test these ports. bsd.kde.mk has already been updated a few days ago to work with these. Some patches applied to fix a few bugs were: deskutils/kdepim3: [1] Remove kpilot from build because it wasn't ready at release. editors/koffice-kde3: [2] Fix compile time bugs for FreeBSD. misc/kdeedu3: [3] Fix compile problem with kvoctrain. x11/kdebase3: [4] Fix KDM CPU usage and login bug. Some caveats: * All PLISTs are broken for deinstall due to script bug that I didn't notice until very recently. This will be fixed when I commit an update tomorrow. These ports should still install perfectly fine though. They should also deinstall without giving errors, but will leave directories behind. * You can't install this with any other version of QT or KDE already installed. I am not sure the checks are 100% working, but fixes for these will be forthcoming. This is mainly due to a policy decision made by kde@ to make QT/KDE ports install the way the rest of the world expects it to while also still conforming to FreeBSD's hier(7). For reference on this decision, please consult the KDE/FreeBSD mailing list archives. This decision fixes 2-year-old bug reports relating to how we handled this for KDE2 vs KDE1. Submitted by: [1] Adrian de Groot <adridg@cs.kun.nl>, [2] David Faure <faure@kde.org>, Andy Fawcett <andy@athame.co.uk> Lauri Watts <lauri@kde.org> [3] Lauri Watts <lauri@kde.org> [4] Alan Eldridge <alane@geeksrus.net> Oswald Buddenhagen <ossi@kde.org> Reviewed by: kde
Diffstat (limited to 'x11/kde4-baseapps/Makefile')
-rw-r--r--x11/kde4-baseapps/Makefile58
1 files changed, 15 insertions, 43 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 3c5876f985f2..8f5f5bac75df 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= kdebase
-PORTVERSION= 2.2.2
-PORTREVISION= 4
+PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES?= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -15,31 +15,28 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
LIB_DEPENDS= intl.2:${PORTSDIR}/devel/gettext
-USE_KDELIBS_VER=2
-SOMAJOR= 4
-SOMINOR= 0
+USE_KDELIBS_VER=3
USE_XPM= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= RUN_KAPPFINDER=no
CONFIGURE_ARGS+=--with-xdmdir=${X11BASE}/lib/X11/xdm \
- --with-qt-dir=${X11BASE} \
--without-ldap --disable-closure
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
+CONFIGURE_ARGS+=--enable-final
+.endif
+.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
+CONFIGURE_ARGS+=--disable-debug
+.endif
USE_GMAKE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500029
-_NO_KDE_OBJPRELINK=yes
-.endif
-
-.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
-
.if exists(${X11BASE}/include/Xm/Xm.h)
WITH_MOTIF= yes
.endif
@@ -59,40 +56,15 @@ pre-everything::
.endif
post-extract:
- @${ECHO_CMD} "#!/bin/sh" > ${WRKSRC}/mkpamserv
- @${ECHO_CMD} "exit 0" >> ${WRKSRC}/mkpamserv
-
-post-patch:
-.if !defined(WITH_MOTIF)
- @${PERL} -pi -e 's/nsplugin//' \
- ${WRKSRC}/konqueror/konqueror_config.desktop
-.endif
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/auto-bin
-.for AC in autoconf autoheader
- ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
-.endfor
-.for AM in automake aclocal
- ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
-.endfor
- cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
- ${GMAKE} -f Makefile.cvs
- ${PERL} -pi -e "s@version-info 3:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/libkonq/Makefile.in
- ${PERL} -pi -e "s@version-info 1:0:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/khelpcenter/Makefile.in
- ${PERL} -pi -e "s@version-info 1:1:0@version-info ${SOMAJOR}:${SOMINOR}@g" ${WRKSRC}/nsplugins/Makefile.in
- ${PERL} -pi -e "s@TIME_WITH_SYS_TIME@INVALID_FOO@g" ${WRKSRC}/kioslave/ldap/kldap.h
+ @${ECHO} "#!/bin/sh" > ${WRKSRC}/mkpamserv
+ @${ECHO} "exit 0" >> ${WRKSRC}/mkpamserv
post-configure:
${PERL} -pi -e "s@444@644@g" ${WRKSRC}/kdesktop/init/Templates/Makefile
post-install:
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
-.for file in kdmrc
-.if !exists(${PREFIX}/share/config/kdm/${file})
- @${CP} ${PREFIX}/share/config/kdm/${file}.dist \
- ${PREFIX}/share/config/kdm/${file}
-.endif
-.endfor
+ ${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
+ ${CHMOD} g+s ${PREFIX}/bin/ksysguardd
.include <bsd.port.post.mk>