aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-03-26 04:30:55 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-03-26 04:30:55 +0800
commit8a8b253fcaea793c9fc91f1dee06afa63625a9ff (patch)
tree7112df67da2abf499c710cd65a1f30c3b9ac284f /x11/kde4-workspace
parent6c60bf2bf30aa23b89e15d16c566749c276fcbbd (diff)
downloadfreebsd-ports-gnome-8a8b253fcaea793c9fc91f1dee06afa63625a9ff.tar.gz
freebsd-ports-gnome-8a8b253fcaea793c9fc91f1dee06afa63625a9ff.tar.zst
freebsd-ports-gnome-8a8b253fcaea793c9fc91f1dee06afa63625a9ff.zip
- Chase astro/gpsd shlib version bump
- Add patches required for compatibility with new version of libgps Submitted by: glebius Tested by: glebius
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile3
-rw-r--r--x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.cpp54
-rw-r--r--x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.h20
3 files changed, 76 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index e9515702d715..bf2fd70afff7 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase-workspace
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE_kde} \
${MASTER_SITE_LOCAL} \
@@ -26,7 +27,7 @@ LIB_DEPENDS= qimageblitz.4:${PORTSDIR}/x11/qimageblitz\
pci.3:${PORTSDIR}/devel/libpci \
hal.1:${PORTSDIR}/sysutils/hal \
xklavier.12:${PORTSDIR}/x11/libxklavier \
- gps.19:${PORTSDIR}/astro/gpsd \
+ gps.20:${PORTSDIR}/astro/gpsd \
qalculate.5:${PORTSDIR}/math/libqalculate \
dmtx.0:${PORTSDIR}/graphics/libdmtx
RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
diff --git a/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.cpp b/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.cpp
new file mode 100644
index 000000000000..7bdf60248966
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.cpp
@@ -0,0 +1,54 @@
+--- plasma/generic/dataengines/geolocation/location_gps.cpp.orig 2011-03-23 00:33:55.000000000 +0300
++++ plasma/generic/dataengines/geolocation/location_gps.cpp 2011-03-23 00:48:57.000000000 +0300
+@@ -17,7 +17,7 @@
+
+ #include "location_gps.h"
+
+-Gpsd::Gpsd(gps_data_t* gpsdata)
++Gpsd::Gpsd(gps_data_t gpsdata)
+ : m_gpsdata(gpsdata)
+ , m_abort(false)
+ {
+@@ -41,24 +41,20 @@
+
+ void Gpsd::run()
+ {
+-#if defined( GPSD_API_MAJOR_VERSION ) && ( GPSD_API_MAJOR_VERSION >= 3 ) && defined( WATCH_ENABLE )
+- gps_stream(m_gpsdata, WATCH_ENABLE, NULL);
+-#else
+- gps_query(m_gpsdata, "w+x\n");
+-#endif
++ gps_stream(&m_gpsdata, WATCH_ENABLE, NULL);
+
+ while (!m_abort) {
+ Plasma::DataEngine::Data d;
+
+- if (gps_poll(m_gpsdata) != -1) {
++ if (gps_read(&m_gpsdata) > 0) {
+ //kDebug() << "poll ok";
+- if (m_gpsdata->online) {
++ if (m_gpsdata.online) {
+ //kDebug() << "online";
+- if (m_gpsdata->status != STATUS_NO_FIX) {
++ if (m_gpsdata.status != STATUS_NO_FIX) {
+ //kDebug() << "fix";
+ d["accuracy"] = 30;
+- d["latitude"] = QString::number(m_gpsdata->fix.latitude);
+- d["longitude"] = QString::number(m_gpsdata->fix.longitude);
++ d["latitude"] = QString::number(m_gpsdata.fix.latitude);
++ d["longitude"] = QString::number(m_gpsdata.fix.longitude);
+ }
+ }
+ }
+@@ -73,8 +69,9 @@
+ : GeolocationProvider(parent, args),
+ m_gpsd(0)
+ {
+- gps_data_t* gpsdata = gps_open("localhost", DEFAULT_GPSD_PORT);
+- if (gpsdata) {
++ gps_data_t gpsdata;
++
++ if (gps_open("localhost", DEFAULT_GPSD_PORT, &gpsdata) == 0) {
+ kDebug() << "gpsd found.";
+ m_gpsd = new Gpsd(gpsdata);
+ connect(m_gpsd, SIGNAL(dataReady(const Plasma::DataEngine::Data&)),
diff --git a/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.h b/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.h
new file mode 100644
index 000000000000..f160691c8840
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-plasma-generic-dataengines-geolocation-location_gps.h
@@ -0,0 +1,20 @@
+--- plasma/generic/dataengines/geolocation/location_gps.h.orig 2011-03-23 00:37:50.000000000 +0300
++++ plasma/generic/dataengines/geolocation/location_gps.h 2011-03-23 00:41:05.000000000 +0300
+@@ -29,7 +29,7 @@
+ {
+ Q_OBJECT
+ public:
+- Gpsd(gps_data_t* gpsdata);
++ Gpsd(gps_data_t gpsdata);
+ virtual ~Gpsd();
+
+ void update();
+@@ -41,7 +41,7 @@
+ virtual void run();
+
+ private:
+- gps_data_t* m_gpsdata;
++ gps_data_t m_gpsdata;
+ QMutex m_mutex;
+ QWaitCondition m_condition;
+ bool m_abort;