aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-09-29 13:07:27 +0800
committerdbn <dbn@FreeBSD.org>2016-09-29 13:07:27 +0800
commit6f515fdd5ecb1fc2609379bdd526dfa40bd15452 (patch)
tree48e615a2e439ee7bbf60e14e73260fa4b894a25d /x11/kde4-workspace
parent4dbd934ace8d6f61febc1ff08610dd72f767204e (diff)
downloadfreebsd-ports-gnome-6f515fdd5ecb1fc2609379bdd526dfa40bd15452.tar.gz
freebsd-ports-gnome-6f515fdd5ecb1fc2609379bdd526dfa40bd15452.tar.zst
freebsd-ports-gnome-6f515fdd5ecb1fc2609379bdd526dfa40bd15452.zip
x11/kde4-workspace: fix OpenGL test for nvidia-driver.
Restore patch introduced in r408463 and accidentially removed in r417328. MFH: 2016Q3
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt15
2 files changed, 16 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 02bc1687e5b0..9fb432fa7d59 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -2,7 +2,7 @@
PORTNAME= kde-workspace
PORTVERSION= ${KDE4_WORKSPACE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= KDE/${KDE4_APPLICATIONS_BRANCH}/applications/${KDE4_APPLICATIONS_VERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
diff --git a/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
new file mode 100644
index 000000000000..be76904999e2
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kwin_opengltest_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- kwin/opengltest/CMakeLists.txt.orig 2014-11-06 22:36:58 UTC
++++ kwin/opengltest/CMakeLists.txt
+@@ -2,9 +2,11 @@
+
+ set(kwin_opengl_test_SRCS opengltest.cpp )
+
++find_package(Threads)
++
+ kde4_add_executable(kwin_opengl_test ${kwin_opengl_test_SRCS})
+
+-target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY})
++target_link_libraries(kwin_opengl_test ${X11_LIBRARIES} ${OPENGL_gl_LIBRARY} ${CMAKE_THREAD_LIBS_INIT})
+
+ install(TARGETS kwin_opengl_test DESTINATION ${LIBEXEC_INSTALL_DIR} )
+