aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2009-08-23 22:39:34 +0800
committermarkus <markus@FreeBSD.org>2009-08-23 22:39:34 +0800
commit78168a11e4e842df73f6960395e0a1e6d32ddfac (patch)
treee4b82e059bc41fabaf596c968686ce8c1d6f3bf7 /x11/kde4-workspace
parent8d7bd60906751275748d7a592bbeb13dc9bd0bdc (diff)
downloadfreebsd-ports-gnome-78168a11e4e842df73f6960395e0a1e6d32ddfac.tar.gz
freebsd-ports-gnome-78168a11e4e842df73f6960395e0a1e6d32ddfac.tar.zst
freebsd-ports-gnome-78168a11e4e842df73f6960395e0a1e6d32ddfac.zip
- Add patch from upstream that fixes the HDD system monitor applet if
localization is being used. - Bump PORTREVISION Obtained from: KDE SVN (rev. 1011262) Noticed by: cloudsv of The FreeBSD Forums
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp13
2 files changed, 14 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 3218cd5fcba2..85cb15d63e7a 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase-workspace
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp b/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
new file mode 100644
index 000000000000..a4685dcdfb1b
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-plasma-applets-system-monitor-hdd.cpp
@@ -0,0 +1,13 @@
+--- plasma/applets/system-monitor/hdd.cpp.orig 2009-07-21 17:19:25.000000000 +0200
++++ plasma/applets/system-monitor/hdd.cpp 2009-08-23 16:07:02.000000000 +0200
+@@ -265,8 +265,8 @@
+ data->value("File System Type").toString() <<
+ data->value("Size").toString();
+ */
+- if ((data->value("Usage").toString() != "File System" &&
+- data->value("Usage").toString() != "Raid") ||
++ if ((data->value("Usage").toString() != i18n("File System") &&
++ data->value("Usage").toString() != i18n("Raid")) ||
+ data->value("File System Type").toString() == "swap") {
+ QStringList list = items();
+ list.removeAll(uuid);