aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-08-10 19:47:36 +0800
committermakc <makc@FreeBSD.org>2009-08-10 19:47:36 +0800
commit535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a (patch)
treeacc82b024802c87837dd90521b3991bd7c3b2ce5 /x11/kde4-workspace
parent0f3e4afecbce328fa8a996731b691e68dbaef539 (diff)
downloadfreebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.tar.gz
freebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.tar.zst
freebsd-ports-gnome-535fdd55d1e1a1c33b3cf476095fc0ca55a2fa2a.zip
Mk/bsd.kde4.mk:
- rework KDE4_BUILDENV All ports: - remove needless post-extract target - make patches relative to ${PATCH_WRKSRC} - clean up - bump PORTREVISION when required databases/akonadi: - replace dependency on boost-python-libs with boost-libs (finally, boost-pyhton does not conflict with boost \o/) deskutils/kdepim*: - replace boost-python-libs with boost-libs - reduce dependencies - respect PREFIX - fix build with qt3 installed misc/kdeedu4: - add dependency on astro/xplanet (for KStars) misc/kdeutils4: - add dependency on devel/qca (for okteta) - make dependency on kdebase non-optional multimedia/kdemultimedia4: - add optional support for PulseAudio x11/kdebase4: - remove needless dependency on kdebase4-runtime x11/kdebase4-runtime, x11/kdebase4-workspace - remove extra CMAKE_ARGS to fix build for qt3/kde3 users x11/kdelibs4 - remove needless dependencies - remove extra CMAKE_ARGS to fix build for qt3/kde3 users
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile25
-rw-r--r--x11/kde4-workspace/files/patch-CMakeLists.txt4
-rw-r--r--x11/kde4-workspace/files/patch-kcontrol-keyboard-kcmmisc.cpp4
-rw-r--r--x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt4
-rw-r--r--x11/kde4-workspace/files/patch-ksmserver_fadeeffect.cpp4
-rw-r--r--x11/kde4-workspace/files/patch-ksysguard-gui-SystemLoad.sgrd4
-rw-r--r--x11/kde4-workspace/files/patch-ksysguard-gui-ksgrd-SensorManager.cc4
-rw-r--r--x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.c4
-rw-r--r--x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.h4
-rw-r--r--x11/kde4-workspace/files/patch-kwin-kcmkwin-kwinrules_ruleswidget.cpp4
-rw-r--r--x11/kde4-workspace/files/patch-libs-ksysguard-processui_CMakeLists.txt4
-rw-r--r--x11/kde4-workspace/files/patch-libs-ksysguard_CMakeLists.txt4
12 files changed, 32 insertions, 37 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 0f2e48931d26..337edf9ce630 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -46,12 +46,10 @@ QT_COMPONENTS= assistant corelib dbus designer gui network opengl \
USE_GETTEXT= yes
USE_ICONV= yes
MAKE_JOBS_SAFE= yes
-MAN1= plasmaengineexplorer.1
+
+MAN1= plasmaengineexplorer.1
CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
- -DCMAKE_INCLUDE_PATH:STRING="${LOCALBASE}/include" \
- -DCMAKE_EXE_LINKER_FLAGS:STRING="-L${LOCALBASE}/lib" \
- -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
-DWITH_BlueZ:BOOL=OFF \
-DWITH_Sensors:BOOL=OFF \
-DWITH_NetworkManager:BOOL=OFF \
@@ -68,28 +66,25 @@ CMAKE_ARGS+= -DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib" \
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
-post-extract:
- ${MKDIR} ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
- ${WRKSRC}/../startkde.cmake \
- ${WRKSRC}/../kcontrol/kfontinst/lib/KfiConstants.h \
- ${WRKSRC}/../kcontrol/kfontinst/kio/KioFonts.cpp \
- ${WRKSRC}/../kcontrol/kxkb/x11helper.cpp \
- ${WRKSRC}/../kdm/kfrontend/genkdmconf.c
+ ${PATCH_WRKSRC}/startkde.cmake \
+ ${PATCH_WRKSRC}/kcontrol/kfontinst/lib/KfiConstants.h \
+ ${PATCH_WRKSRC}/kcontrol/kfontinst/kio/KioFonts.cpp \
+ ${PATCH_WRKSRC}/kcontrol/kxkb/x11helper.cpp \
+ ${PATCH_WRKSRC}/kdm/kfrontend/genkdmconf.c
pre-configure:
${REINPLACE_CMD} -e 's|<qhash.h>|<QHash>|'\
- ${WRKSRC}/../kwin/effects/thumbnailaside/thumbnailaside.h
+ ${PATCH_WRKSRC}/kwin/effects/thumbnailaside/thumbnailaside.h
.for item in b2/b2client.cpp kwmtheme/kwmthemeclient.cpp\
laptop/laptopclient.cpp modernsystem/modernsys.cpp\
redmond/redmond.cpp
${REINPLACE_CMD} -e 's|<qdrawutil.h>|<QtGui/qdrawutil.h>|'\
- ${WRKSRC}/../kwin/clients/${item}
+ ${PATCH_WRKSRC}/kwin/clients/${item}
${REINPLACE_CMD} -e 's|addToUtmp ""|addToUtmp "${LOCALBASE}/lib"|' \
-e 's|(utempter.h|(${LOCALBASE}/include/utempter.h|' \
- ${WRKSRC}/../kwrited/CMakeLists.txt
+ ${PATCH_WRKSRC}/kwrited/CMakeLists.txt
.endfor
post-install:
diff --git a/x11/kde4-workspace/files/patch-CMakeLists.txt b/x11/kde4-workspace/files/patch-CMakeLists.txt
index 25851f037692..b0a9a4744f7e 100644
--- a/x11/kde4-workspace/files/patch-CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../CMakeLists.txt.orig 2009-01-01 19:26:09.000000000 +0300
-+++ ../CMakeLists.txt 2009-03-07 10:02:36.000000000 +0300
+--- ./CMakeLists.txt.orig 2009-01-01 19:26:09.000000000 +0300
++++ ./CMakeLists.txt 2009-03-07 10:02:36.000000000 +0300
@@ -220,7 +220,7 @@
macro_write_basic_cmake_version_file(${CMAKE_CURRENT_BINARY_DIR}/KDE4WorkspaceConfigVersion.cmake
${KDE4WORKSPACE_VERSION_MAJOR} ${KDE4WORKSPACE_VERSION_MINOR} ${KDE4WORKSPACE_VERSION_PATCH})
diff --git a/x11/kde4-workspace/files/patch-kcontrol-keyboard-kcmmisc.cpp b/x11/kde4-workspace/files/patch-kcontrol-keyboard-kcmmisc.cpp
index 78ebf36725c6..15eec2aa583d 100644
--- a/x11/kde4-workspace/files/patch-kcontrol-keyboard-kcmmisc.cpp
+++ b/x11/kde4-workspace/files/patch-kcontrol-keyboard-kcmmisc.cpp
@@ -1,5 +1,5 @@
---- ../kcontrol/keyboard/kcmmisc.cpp.orig 2008-04-02 08:18:22.000000000 -0400
-+++ ../kcontrol/keyboard/kcmmisc.cpp 2008-07-07 14:02:16.000000000 -0400
+--- ./kcontrol/keyboard/kcmmisc.cpp.orig 2008-04-02 08:18:22.000000000 -0400
++++ ./kcontrol/keyboard/kcmmisc.cpp 2008-07-07 14:02:16.000000000 -0400
@@ -505,8 +505,10 @@
diff --git a/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt b/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt
index d7654a8cbd5c..45f403dd292c 100644
--- a/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-kdm-kfrontend-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../kdm/kfrontend/CMakeLists.txt.orig 2008-07-30 17:02:54.000000000 +0300
-+++ ../kdm/kfrontend/CMakeLists.txt 2008-07-30 17:03:26.000000000 +0300
+--- ./kdm/kfrontend/CMakeLists.txt.orig 2008-07-30 17:02:54.000000000 +0300
++++ ./kdm/kfrontend/CMakeLists.txt 2008-07-30 17:03:26.000000000 +0300
@@ -108,6 +108,6 @@
build_confci()
diff --git a/x11/kde4-workspace/files/patch-ksmserver_fadeeffect.cpp b/x11/kde4-workspace/files/patch-ksmserver_fadeeffect.cpp
index a6bdc04d66b8..b08046ff9014 100644
--- a/x11/kde4-workspace/files/patch-ksmserver_fadeeffect.cpp
+++ b/x11/kde4-workspace/files/patch-ksmserver_fadeeffect.cpp
@@ -1,5 +1,5 @@
---- ../ksmserver/fadeeffect.cpp.ori 2008-07-22 00:15:47.000000000 +0200
-+++ ../ksmserver/fadeeffect.cpp 2008-07-22 00:16:13.000000000 +0200
+--- ./ksmserver/fadeeffect.cpp.ori 2008-07-22 00:15:47.000000000 +0200
++++ ./ksmserver/fadeeffect.cpp 2008-07-22 00:16:13.000000000 +0200
@@ -58,7 +58,7 @@
#include "fadeeffect.moc"
diff --git a/x11/kde4-workspace/files/patch-ksysguard-gui-SystemLoad.sgrd b/x11/kde4-workspace/files/patch-ksysguard-gui-SystemLoad.sgrd
index efe4fd885e93..1b7b451570db 100644
--- a/x11/kde4-workspace/files/patch-ksysguard-gui-SystemLoad.sgrd
+++ b/x11/kde4-workspace/files/patch-ksysguard-gui-SystemLoad.sgrd
@@ -1,5 +1,5 @@
---- ../ksysguard/gui/SystemLoad2.sgrd.orig 2009-06-09 18:07:55.000000000 +0200
-+++ ../ksysguard/gui/SystemLoad2.sgrd 2009-07-03 09:35:29.000000000 +0200
+--- ./ksysguard/gui/SystemLoad2.sgrd.orig 2009-06-09 18:07:55.000000000 +0200
++++ ./ksysguard/gui/SystemLoad2.sgrd 2009-07-03 09:35:29.000000000 +0200
@@ -3,7 +3,7 @@
<WorkSheet title="System Load" interval="0.5" locked="1" rows="3" columns="1" >
<host port="-1" command="ksysguardd" shell="" name="localhost" />
diff --git a/x11/kde4-workspace/files/patch-ksysguard-gui-ksgrd-SensorManager.cc b/x11/kde4-workspace/files/patch-ksysguard-gui-ksgrd-SensorManager.cc
index a112710f60ff..951988f978b5 100644
--- a/x11/kde4-workspace/files/patch-ksysguard-gui-ksgrd-SensorManager.cc
+++ b/x11/kde4-workspace/files/patch-ksysguard-gui-ksgrd-SensorManager.cc
@@ -1,5 +1,5 @@
---- ../ksysguard/gui/ksgrd/SensorManager.cc.orgi 2009-01-22 23:54:35.000000000 +0100
-+++ ../ksysguard/gui/ksgrd/SensorManager.cc 2009-01-22 23:54:52.000000000 +0100
+--- ./ksysguard/gui/ksgrd/SensorManager.cc.orgi 2009-01-22 23:54:35.000000000 +0100
++++ ./ksysguard/gui/ksgrd/SensorManager.cc 2009-01-22 23:54:52.000000000 +0100
@@ -61,6 +61,7 @@
mDict.insert( QLatin1String( "nice" ), i18n( "Nice Load" ) );
mDict.insert( QLatin1String( "user" ), i18n( "User Load" ) );
diff --git a/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.c b/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.c
index 978857c88f17..e2aa9fc7591d 100644
--- a/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.c
+++ b/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.c
@@ -1,5 +1,5 @@
---- ../ksysguard/ksysguardd/FreeBSD/CPU.c.orig 2008-01-05 00:55:46.000000000 +0100
-+++ ../ksysguard/ksysguardd/FreeBSD/CPU.c 2009-02-03 20:54:08.000000000 +0100
+--- ./ksysguard/ksysguardd/FreeBSD/CPU.c.orig 2008-01-05 00:55:46.000000000 +0100
++++ ./ksysguard/ksysguardd/FreeBSD/CPU.c 2009-02-03 20:54:08.000000000 +0100
@@ -49,11 +49,12 @@
struct kinfo_cputime *);
static struct kinfo_cputime cp_time, cp_old;
diff --git a/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.h b/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.h
index df52f95fab38..87896f1d25eb 100644
--- a/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.h
+++ b/x11/kde4-workspace/files/patch-ksysguard-ksysguardd-FreeBSD-CPU.h
@@ -1,5 +1,5 @@
---- ../ksysguard/ksysguardd/FreeBSD/CPU.h.orig 2008-01-05 00:55:46.000000000 +0100
-+++ ../ksysguard/ksysguardd/FreeBSD/CPU.h 2009-02-03 16:26:12.000000000 +0100
+--- ./ksysguard/ksysguardd/FreeBSD/CPU.h.orig 2008-01-05 00:55:46.000000000 +0100
++++ ./ksysguard/ksysguardd/FreeBSD/CPU.h 2009-02-03 16:26:12.000000000 +0100
@@ -35,6 +35,10 @@
void printCPUNiceInfo(const char* cmd);
void printCPUSys(const char* cmd);
diff --git a/x11/kde4-workspace/files/patch-kwin-kcmkwin-kwinrules_ruleswidget.cpp b/x11/kde4-workspace/files/patch-kwin-kcmkwin-kwinrules_ruleswidget.cpp
index cbcfad414d0e..946eb9395aae 100644
--- a/x11/kde4-workspace/files/patch-kwin-kcmkwin-kwinrules_ruleswidget.cpp
+++ b/x11/kde4-workspace/files/patch-kwin-kcmkwin-kwinrules_ruleswidget.cpp
@@ -1,5 +1,5 @@
---- ../kwin/kcmkwin/kwinrules/ruleswidget.cpp.orgi 2008-01-30 00:38:06.000000000 +0100
-+++ ../kwin/kcmkwin/kwinrules/ruleswidget.cpp 2008-01-30 00:38:38.000000000 +0100
+--- ./kwin/kcmkwin/kwinrules/ruleswidget.cpp.orgi 2008-01-30 00:38:06.000000000 +0100
++++ ./kwin/kcmkwin/kwinrules/ruleswidget.cpp 2008-01-30 00:38:38.000000000 +0100
@@ -30,6 +30,7 @@
#include <assert.h>
diff --git a/x11/kde4-workspace/files/patch-libs-ksysguard-processui_CMakeLists.txt b/x11/kde4-workspace/files/patch-libs-ksysguard-processui_CMakeLists.txt
index 1de4d0ae85d0..d9b0efedd656 100644
--- a/x11/kde4-workspace/files/patch-libs-ksysguard-processui_CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-libs-ksysguard-processui_CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../libs/ksysguard/processui/CMakeLists.txt.orig 2008-06-18 16:41:37.000000000 +0400
-+++ ../libs/ksysguard/processui/CMakeLists.txt 2008-06-28 13:56:54.000000000 +0400
+--- ./libs/ksysguard/processui/CMakeLists.txt.orig 2008-06-18 16:41:37.000000000 +0400
++++ ./libs/ksysguard/processui/CMakeLists.txt 2008-06-28 13:56:54.000000000 +0400
@@ -1,7 +1,7 @@
include_directories( ${CMAKE_CURRENT_SOURCE_DIR}/../ ../processcore/)
diff --git a/x11/kde4-workspace/files/patch-libs-ksysguard_CMakeLists.txt b/x11/kde4-workspace/files/patch-libs-ksysguard_CMakeLists.txt
index 770d2cf432ce..de32b4591cdf 100644
--- a/x11/kde4-workspace/files/patch-libs-ksysguard_CMakeLists.txt
+++ b/x11/kde4-workspace/files/patch-libs-ksysguard_CMakeLists.txt
@@ -1,5 +1,5 @@
---- ../libs/ksysguard/CMakeLists.txt.orig 2008-04-10 13:30:14.000000000 +0400
-+++ ../libs/ksysguard/CMakeLists.txt 2008-06-28 14:04:29.000000000 +0400
+--- ./libs/ksysguard/CMakeLists.txt.orig 2008-04-10 13:30:14.000000000 +0400
++++ ./libs/ksysguard/CMakeLists.txt 2008-06-28 14:04:29.000000000 +0400
@@ -5,7 +5,7 @@
add_subdirectory( processui )
add_subdirectory( tests )
eebsd-ports-gnome/commit/x11-servers?h=gnome-3.24&id=f2ddf0faa8abb2e4cb86f0d5db7a84d83d10f6c2'>If port belongs to X11 distribution different than ${X_WINDOW_SYSTEM} one,lesi2005-11-1224-12/+64 | | | | | | point to The X Window System and Virtual Consoles chapter of FAQ. Add SHA256. * Update to the 6.8.99.16 snapshot, and add in a fix for a memory leak in cursoranholt2005-10-168-69/+318 | | | | | change handling as well as a merge of some important nv changes to avoid hangs and reduce corruption in some cases. * Install rc sript with ".sample" postfix so it does not get executed bylesi2005-09-213-3/+3 | | | | | | | default. Noticed by: Rostislav Krasny (rosti.bsd at gmail.com) Pointy hat to: lesi * Fix the fix for CAN-2005-2495.lesi2005-09-212-128/+271 | | | | Obtained from: XFree86 CVS * Fix the fix for CAN-2005-2495.lesi2005-09-192-30/+44 | | | | Obtained from: Xorg CVS * Fix the fix for CAN-2005-2495.lesi2005-09-192-30/+44 | | | | | | | Among other, this shoud fix problems with wine - thanks to Robert Backhaus (robbak at gmail.com) for testing. Obtained from: Xorg CVS * Fix rc script extension.lesi2005-09-173-1/+13 | | | | Spotted by: Rong-En Fan (rafan at infor.org) * Fix integer overflow when allocating large pixmaps.lesi2005-09-126-2/+510 | | | | | | | (Freedesktop.org bug #594) Obtained from: Red Hat via simon Security: CAN-2005-2495 * Fix a use-after-free in the cursor code that's easily triggered with -AJ mallocanholt2005-08-272-1/+43 | | | | | | | opts and running current gdm. Approved by: portmgr (marcus) Obtained from: X.Org CVS * Fixup plist and man lists for alpha and sparc64.lesi2005-08-012-23/+42 | | | | Noticed by: pointyhat * Grab a patch for keyboard on sparc64 from Xorg CVS. This makes 'kbd' driverlesi2005-08-014-31/+36 | | | | | | | | | work properly this time on FreeBSD/sparc64 so stop using workaround that defaults to old 'keyboard' one and remove erroneous patch by me. Pointed out by: Matthias Muthmann (mmuthmann at gmx.net) Tested by: Matthias Muthmann (Ultra10/type5c), me (Ultra5/type5) Obtained from: Xorg CVS * Update to 6.8.99.12, and incorporate the PCI ID fix for a Radeon X600. Add aanholt2005-06-234-3/+56 | | | | | | soon-to-be-committed-upstream patch to fix the build after the removal of xf86drmCompat.c. Also includes the fix for ports/32121, which had been committed. * [1] Fix the Chipset lines written by xorgcfg for 3dfx cards.anholt2005-06-233-1/+31 | | | | | | | | [2] Add the PCI ID for Radeon X600, 0x5B62 to a place that was missed. PR: [1] ports/32121 Submitted by: [1] alane [2] Vladimir Kushnir <vkushnir@i.kiev.ua> * - Install X server setuid root by default, and provide a switchlesi2005-06-216-14/+144 | | | | | | | | | | | | | | | | | | | | NO_SUID_XSERVER to disable this. The end result is same as it was before with x11/wrapper installed as the code from there is included in X server. It is also the same as xorg-server port does (from which this changes were taken). This should conclude removal of dependency on x11/wrapper from meta port for above reasons. [1] - (patch-bsdResource.c) Correct the ranges of the bus resource windows on sparc64. This makes PCI video cards work that hang off directly from the Host-to-PCI bridge in machines like the Blade 100. [2] - (patch-HALlib_bindings.c patch-mga_driver.c) Revert the MGA HALlib MGASetDisplayStart interface back to HALSetDisplayStart (taken from upstream CVS) [3] Noticed by: (bugsgrief at bugsgrief.net) [1] Submitted by: marius [2] Reported and tested by: Steven Friedrich (FreeBSD at InsightBB.com) [3] * Fix up plist after modifications to mtree (BSD.x11-4.dist rev. 1.27).lesi2005-06-151-1/+3 | * Upgrade to XFree86 4.5.0.lesi2005-06-1549-1120/+412 | | | | | | | | | | | | | | | | | | Ports changes: - Drop dependency on x11/wrapper. X server already contains this code (programs/Xserver/os/utils.c rev. 3.58). - Install default SecurityPolicy with XFree86-4-libraries, thus avoiding plists and who-owns-what complications between different fooServer ports. Copy default file to real one if that doesn't exist and remove both upon uninstall if they are the same. - Revert change to Imake.rules rev. 3.132 in devel/imake-4 port, since couple of ports break with this change (devel/imake-4/files/patch-Imake.rules) - Add grehans patches for PPC [1] - Several of directories that were previously in /etc/mtree/BSD.x11-4.dist were moved to respective ports pkg-plists PR: [1] 78345, 78346, 78348, 78352, 78353, 78354, 78355, 78356 * During build, munge PATH so that imake's makedepend will get picked up insteadanholt2005-06-131-0/+3 | | | | | | | | of devel/makedepend, which crashes. PR: ports/81706 Submitted by: Koji Yokota <yokota@res.otaru-uc.ac.jp> Patch by: lesi * Update to the 6.8.99.10 snapshot. Merges in many local patches, miscellaneousanholt2005-06-1114-180/+12 | | | | | bugfixes, and includes Zack Rusin's great improvements to Render extension performance. Should also fix packaging on amd64. * Use appropriate autoconf version (2.53), >= 2.50 is requiredvs2005-05-231-1/+1 | | | | Noticed by: cluster * - Correct the ranges of the bus resource windows on sparc64.lesi2005-05-183-1/+78 | | | | | | | | | | | This makes PCI video cards work that hang off directly from the Host-to-PCI bridge in machines like the Blade 100. [1] - Default to old 'keyboard' driver for sparc64. Patches for 'kbd' one were not enough so until new driver is fixed, this change makes Xorg work with sparc64 keyboards. Knob WITH_SPARC_KBD is provided to ease efforts of fixing 'kbd'. Submitted by: marius [1] * Bump max number of buttons supported by mouse driver to 16 so Logitechlesi2005-05-092-0/+12 | | | | | | | | MediaPlay mouse works. (Xorg Bugzilla #2389) PR: ports/80744 Submitted by: cy * Add two missing i386-only drivers to the packing list.anholt2005-05-072-0/+4 | | | | Reported by: krismail * Bring xorg-server-snap port to 6.8.99.5 after repocopy from xorg-server. Thisanholt2005-05-0412-294/+151 | | | | | | is a port of the server pieces of the periodic snapshot of X.Org, with the development DRI drivers enabled. The purpose of this port is to bring bleeding-edge graphics support to FreeBSD. * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 | | | | after 5.4-RELEASE. * Assist getting more ports working on AMD64 by obeying theobrien2005-04-11