aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kde4-workspace
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-07-06 07:22:17 +0800
committerlofi <lofi@FreeBSD.org>2006-07-06 07:22:17 +0800
commita7a8a298d104b186d4c831ce25da2abc1e1ed23a (patch)
tree02990b98fdecf4f704815133abdfc631a19aa88a /x11/kde4-workspace
parent58c8d113c42aac8d0e1f667145748413d74b1c67 (diff)
downloadfreebsd-ports-gnome-a7a8a298d104b186d4c831ce25da2abc1e1ed23a.tar.gz
freebsd-ports-gnome-a7a8a298d104b186d4c831ce25da2abc1e1ed23a.tar.zst
freebsd-ports-gnome-a7a8a298d104b186d4c831ce25da2abc1e1ed23a.zip
Fix KDE Bug 128610 (kscreensaver does not launch screensaver after x minutes).
Diffstat (limited to 'x11/kde4-workspace')
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-post-3.5.3-screensavers97
2 files changed, 98 insertions, 1 deletions
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 5b2275ad48eb..365e19c65795 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-workspace/files/patch-post-3.5.3-screensavers b/x11/kde4-workspace/files/patch-post-3.5.3-screensavers
new file mode 100644
index 000000000000..1182c861986c
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-post-3.5.3-screensavers
@@ -0,0 +1,97 @@
+--- kdesktop/xautolock.cc 2006/05/18 13:18:28 542149
++++ kdesktop/xautolock.cc 2006/06/04 12:42:03 548008
+@@ -192,6 +192,7 @@
+
+ bool activate = false;
+
++ kdDebug() << now << " " << mTrigger << endl;
+ if (now >= mTrigger)
+ {
+ resetTrigger();
+@@ -202,6 +203,8 @@
+ BOOL on;
+ CARD16 state;
+ DPMSInfo( qt_xdisplay(), &state, &on );
++
++ kdDebug() << "DPMSInfo " << state << " " << on << endl;
+ // If DPMS is active, it makes XScreenSaverQueryInfo() report idle time
+ // that is always smaller than DPMS timeout (X bug I guess). So if DPMS
+ // saving is active, simply always activate our saving too, otherwise
+@@ -217,9 +220,11 @@
+ #ifdef HAVE_XSCREENSAVER
+ static XScreenSaverInfo* mitInfo = 0;
+ if (!mitInfo) mitInfo = XScreenSaverAllocInfo ();
+- XScreenSaverQueryInfo (qt_xdisplay(), DefaultRootWindow (qt_xdisplay()), mitInfo);
+- if (mitInfo->state == ScreenSaverDisabled)
+- activate = false;
++ if (XScreenSaverQueryInfo (qt_xdisplay(), DefaultRootWindow (qt_xdisplay()), mitInfo)) {
++ kdDebug() << "XScreenSaverQueryInfo " << mitInfo->state << " " << ScreenSaverDisabled << endl;
++ if (mitInfo->state == ScreenSaverDisabled)
++ activate = false;
++ }
+ #endif
+
+ if(mActive && activate)
+--- kdesktop/lockeng.cc 2006/02/06 13:25:11 506297
++++ kdesktop/lockeng.cc 2006/06/04 12:42:03 548008
+@@ -42,9 +42,6 @@
+ XGetScreenSaver(qt_xdisplay(), &mXTimeout, &mXInterval,
+ &mXBlanking, &mXExposures);
+
+- // We'll handle blanking
+- XSetScreenSaver(qt_xdisplay(), 0, mXInterval, mXBlanking, mXExposures);
+-
+ mState = Waiting;
+ mXAutoLock = 0;
+ mEnabled = false;
+@@ -158,6 +155,9 @@
+ mXAutoLock->setDPMS(mDPMS);
+ //mXAutoLock->changeCornerLockStatus( mLockCornerTopLeft, mLockCornerTopRight, mLockCornerBottomLeft, mLockCornerBottomRight);
+
++ // We'll handle blanking
++ XSetScreenSaver(qt_xdisplay(), mTimeout + 10, mXInterval, mXBlanking, mXExposures);
++
+ mXAutoLock->start();
+
+ kdDebug(1204) << "Saver Engine started, timeout: " << mTimeout << endl;
+@@ -170,6 +170,7 @@
+ mXAutoLock = 0;
+ }
+
++ XSetScreenSaver(qt_xdisplay(), 0, mXInterval, mXBlanking, mXExposures);
+ kdDebug(1204) << "Saver Engine disabled" << endl;
+ }
+
+@@ -291,7 +292,6 @@
+ kdDebug(1204) << "SaverEngine: stopping lock" << endl;
+ emitDCOPSignal("KDE_stop_screensaver()", QByteArray());
+
+-
+ mLockProcess.kill();
+
+ if (mXAutoLock)
+@@ -300,6 +300,7 @@
+ }
+ processLockTransactions();
+ mState = Waiting;
++ XSetScreenSaver(qt_xdisplay(), mTimeout + 10, mXInterval, mXBlanking, mXExposures);
+ }
+
+ void SaverEngine::lockProcessExited()
+@@ -314,6 +315,7 @@
+ }
+ processLockTransactions();
+ mState = Waiting;
++ XSetScreenSaver(qt_xdisplay(), mTimeout + 10, mXInterval, mXBlanking, mXExposures);
+ }
+
+ //---------------------------------------------------------------------------
+@@ -322,6 +324,8 @@
+ //
+ void SaverEngine::idleTimeout()
+ {
++ // disable X screensaver
++ XSetScreenSaver(qt_xdisplay(), 0, mXInterval, mXBlanking, mXExposures);
+ startLockProcess( DefaultLock );
+ }
+
lantw44/cgit/cgit.cgi/freebsd-ports-gnome/commit/mail?h=gnome-3.24&id=1fd7600b6f6fbb790b8bbb70dc4e4b34d9c2ad5a'>update to 0.74leeym2003-04-153-61/+3 * remove pkg-comment, add COMMENT.edwin2003-04-152-1/+1 * De-pkg-commentlioux2003-04-152-1/+1 * - Use MASTER_SITE_DEBIANleeym2003-04-142-58/+16 * update of mail/ssmtp to 2.50.9edwin2003-04-1411-132/+145 * Upgrade to 0.11.2.obraun2003-04-146-28/+4 * By default, bmf should use the system's db library and not bdb3. Not bumpingseanc2003-04-141-1/+1 * * Upgrade to 0.11.1.9.obraun2003-04-146-96/+24 * Update to exmh-2.6.3.bmah2003-04-144-38/+7 * * Upgrade to 1.00RC7clive2003-04-137-58/+67 * TMDA port is out of date.edwin2003-04-132-2/+2 * Conditionalize dependencies for moudules included in perl 5.8edwin2003-04-131-4/+10 * mail/turba & mail/imp3: better support of Apache2.edwin2003-04-134-4/+20 * - use WITH_OPENSSL_BASEdinoex2003-04-132-2/+2 * - Use libobjc.sodinoex2003-04-133-66/+21 * * Fix a problem where the help file could not be found [1]marcus2003-04-132-10/+15 * Chase the location of the NSS header files.marcus2003-04-132-2/+2 * explicit depends on autoconfig/automake -> USE_xxx variablesedwin2003-04-122-6/+8 * Fix build on sparc64.nork2003-04-122-0/+96 * - use bsd.openssl.mkdinoex2003-04-121-1/+1 * Update distinfo. FAQ changed.adamw2003-04-111-1/+1 * Bump PORTREVISION by previous commitnork2003-04-111-1/+1 * o Fix a segmentation fault.nork2003-04-112-4/+13 * Update to 0.7.8.anders2003-04-102-2/+4 * 1) Fix reproducible plaintext authentication crash.sheldonh2003-04-103-0/+21 * Fix python path. Bump PORTREVISION.arved2003-04-101-0/+6 * Finally add a port of qmail-conf that I have been using forroam2003-04-086-0/+59 * fix build on alpha by fixing prototype conflict.ume2003-04-083-0/+54 * Update to 1.4.7kevlo2003-04-082-2/+2 * Upgrade to 0.11.1.8.obraun2003-04-084-6/+6 * - Fix more linebreaksdinoex2003-04-082-14/+13 * This is a simple sendmail milter which adds an X-RBL-Warning header todinoex2003-04-088-0/+125 * update to vm-7.14leeym2003-04-072-9/+3 * add spamstats-0.4bleeym2003-04-075-0/+48 * Upgrade to version 2.53, which contains numerous bug fixes. See thedougb2003-04-072-4/+6 * The SA developers incorporated something very similar to this patch, sodougb2003-04-071-27/+0 * Project home has moved to sourceforge.petef2003-04-076-8/+8 * update to version 0.8.7leeym2003-04-072-2/+2 * use cpio(1) instead of tar(1), avoid owner's problem when the port is builtleeym2003-04-071-5/+3 * Specify /usr/sbin/sendmail (mailwrapper) as the default sendmail binarypetef2003-04-061-0/+6 * There is a problem with the interaction between MessageWall and Microsoftnork2003-04-063-0/+69 * unbreak openwebmail when it's installed in fresh-built environment.leeym2003-04-062-5556/+10 * cyrus port should add periodic file to prune deliverdbedwin2003-04-063-1/+28 * Mark port NO_PACKAGE because it requires IMAP/IMAP_SSL which isn'tedwin2003-04-061-0/+1 * Don't remove the etc/pam.d system directorykris2003-04-061-1/+0 * BROKEN: Changes ownership/permission of manpages, broken pkg-plistkris2003-04-061-0/+2 * Update port: mail/mimedefang to 2.31edwin2003-04-052-6/+8 * Convert to new GNOME infrastructure.marcus2003-04-051-1/+1 * * Update to 1.2.4marcus2003-04-056-8/+8 * Upgrade to 1.4.0.vanilla2003-04-053-122/+194 * Fix bmf to work correctly with db3, db4, and db41.seanc2003-04-052-0/+21 * 'chown user:group' constructs are preferred over 'chown user.group'lioux2003-04-051-1/+1 * - make portlint happierdinoex2003-04-051-2/+5 * Update to latest release (0.5.1)leeym2003-04-042-2/+2 * new port mail/silkymail, a slick looking webmail programedwin2003-04-046-0/+1290 * Upgrade to 0.11.1.6.obraun2003-04-044-4/+4 * Update to 2.0.10.marcus2003-04-044-22/+25 * * Update to 1.2.3marcus2003-04-0410-190/+58 * Update to 2.0.3 and add my autoconfiguration patch which uses DJB'sroam2003-04-043-31/+10 * update to 0.9.6bleeym2003-04-042-2/+2 * [Maintainer Update]: mail/gubbyedwin2003-04-043-6/+26 * - use bsd.openssl.mkdinoex2003-04-044-6/+6 * Update to 1.4.3.marcus2003-04-035-88/+72 * Fix plist and the list of manpages.tobez2003-04-032-2/+4 * Update port:mail/gotmail to version 0.7.9 to work with changes in Hotmailedwin2003-04-022-2/+2 * New port: mail/smtprcedwin2003-04-025-0/+59 * Update to 0.9.2kevlo2003-04-023-29/+41 * remove mail/wmbiff/pkg-message since it is no longer neededleeym2003-04-011-4/+0 * Add p5-Sendmail-Milter 0.18, a module to write mail filters in Perlsobomax2003-04-016-0/+99 * Update of mail/wmbiff to 0.4.15 and add support for gnutls (SSL).leeym2003-04-013-5/+11 * New port: mail/crashechoedwin2003-04-015-0/+47 * New ports: mail/jamlibedwin2003-04-015-0/+65 * * Update exim-4.12 -> exim-4.14:sheldonh2003-03-315-67/+44 * mail/dovecot 0.99.8-test5 -> 0.99.8.1edwin2003-03-316-10/+20 * accidentially commted files.edwin2003-03-313-59/+0 * mail/mailfront: Mail server network protocol front-endsedwin2003-03-318-0/+135 * TMDA port is out of date to version 0.71edwin2003-03-312-3/+2 * Update to upstream bugfix release 0.11.1.5:leeym2003-03-314-4/+4 * TMDA port is missing the contributed cgi interface.edwin2003-03-312-3/+61 * Make pre-requisites for mail/imp3 regarding PHP4 available foredwin2003-03-311-3/+7 * - Update to 8.11.7dinoex2003-03-318-1224/+4 * add trailing slash in path to help the users who forget to remove previouslyleeym2003-03-311-2/+2 * Enable LMTP modeache2003-03-312-49/+38 * Port mail/imapfilter update to version 0.8.6.edwin2003-03-302-2/+2 * mail/gtkgrepmail run-depends on gnome-help-browser.edwin2003-03-301-1/+2 * mail/imp3: install error if defined(WITHOUT_TURBA)edwin2003-03-302-3/+8 * mail/imp3: upgrading to IMP 3.2.edwin2003-03-304-14/+51 * mail/turba: upgrading to 1.2.edwin2003-03-3015-66/+294 * - Security Updatedinoex2003-03-304-4/+4 * - add security fix:dinoex2003-03-304-2/+252 * update to openwebmail-2.00, and add some optional supports.leeym2003-03-303-63/+882 * activate cyrus-imapd22.ume2003-03-291-0/+1 * Add Cyrus IMAPd 2.2.0-ALPHA after repo copy.ume2003-03-2960-504/+1704 * Update to 3.07, grab the port.tobez2003-03-293-14/+13 * Update to 1.01a.petef2003-03-282-2/+2 * New Port: mail/dcc-dccdedwin2003-03-286-0/+92 * Fix PLIST.tobez2003-03-281-1/+0 * Fix PATCH_SITES for the package building case (e.g. bento).roam2003-03-281-16/+7 * Mairix is a program for indexing and searching email messages stored in Maildirobraun2003-03-285-0/+37 * PR: 45711foxfair2003-03-283-67/+3 * Upgrade to 0.11.1.4.obraun2003-03-274-4/+4 * - update to 1.5.2petef2003-03-273-26/+60 * - Install the configuration examples into ${PREFIX}/share/examples/mutt.obraun2003-03-272-33/+136 * - Integrate the new "initials"-patch.obraun2003-03-278-66/+180 * Upgrade to 2.15.obraun2003-03-262-3/+4 * Update to 0.5.4, pass Maintainership to submitter.arved2003-03-263-12/+12 * o Update to 1.12[1].nork2003-03-265-27/+42 * - Don't strip the mutt binary again, it's done by install -s.naddy2003-03-252-42/+38 * Fix type-o in pkg-messageseanc2003-03-251-1/+1 * Upgrade to version 1.7.1.nbm2003-03-243-6/+35 * Update 2.2.2 -> 2.2.2a:sheldonh2003-03-242-2/+2 * Add bmf: a fast (fastest filter I know of) Bayesian Mail Filter (adaptiveseanc2003-03-247-0/+137 * Update to 1.04adamw2003-03-245-135/+3 * Add maildirsync 0.3, online synchronizer for Maildir-format mailboxes.obraun2003-03-245-0/+40 * - Add new knob WITH_MUTT_SMIME_OUTLOOK_COMPAT.ru2003-03-244-36/+58 * Add some @unexec rmdir linesarved2003-03-241-0/+17 * Use REINPLACE_CMD.ume2003-03-245-39/+27 * Update to 0.8.11.nork2003-03-2312-20/+24 * Fix build: replace BUILD_DEPENDS with EXTRACT_DEPENDS where appropriatelioux2003-03-231-2/+2 * - Update to 0.6.2dinoex2003-03-233-3/+4 * - use include more consistentdinoex2003-03-234-4/+4 * Update mutt-devel to Mutt 1.5.4, which fixes the IMAP vulnerability.roam2003-03-227-192/+89 * ``compressed'' patch now available for 1.4.1.obrien2003-03-216-412/+6 * Update to version 1.4.1 which among other things, fixes a buffer overflowobrien2003-03-216-8/+414 * Upgrade to 0.11.1.3 (critical bugs fixed)obraun2003-03-174-4/+4 * Update to 4.0.5lioux2003-03-153-7/+17 * update postfix to 2.0.6leeym2003-03-1133-44/+33 * * Fix the problem of uninstall wiping out the local.cf filedougb2003-03-102-67/+75 * Fix the DB_LIB_VERSION=4 case.sheldonh2003-03-072-5/+10 * Clear moonlight beckons.ade2003-03-07