aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase4-runtime/Makefile
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
committerlofi <lofi@FreeBSD.org>2004-08-11 09:27:37 +0800
commit864e9b668c7ed19626e92e91ce653b0426e8a652 (patch)
tree790eb38840233721a33b0ae2dcaaebb416020301 /x11/kdebase4-runtime/Makefile
parent73eb1b5f64621d1b69dbde88fc44e81f1bd5f32d (diff)
downloadfreebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.gz
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.tar.zst
freebsd-ports-gnome-864e9b668c7ed19626e92e91ce653b0426e8a652.zip
Factor out all but one of the build switches of the KDE main module ports
into separate ports. The OPTIONS will remain as of yet and trigger dependencies now, for easy transition. Update KOffice to version 1.3.2. Add patches to fix a number of issues, including: - fix kxkb on Xorg - fix kdemultimedia WITH_MPEGLIB (now mpeglib_artsplug) compilation on gcc 3.4.2 with optimizations greater than -O Add security related patches and entries to portaudit.txt.
Diffstat (limited to 'x11/kdebase4-runtime/Makefile')
-rw-r--r--x11/kdebase4-runtime/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index db61c6ebeb34..7fa93289891c 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -21,7 +22,6 @@ LIB_DEPENDS= smbclient:${PORTSDIR}/net/samba-libsmbclient
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
-KDE_BUILD_PLIST=yes
USE_OPENLDAP= yes
USE_BZIP2= yes
@@ -29,6 +29,7 @@ USE_GMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
PKGMESSAGE= ${WRKDIR}/MESSAGE
+PKGINSTALL= ${WRKDIR}/INSTALL
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
@@ -50,8 +51,7 @@ RUN_DEPENDS+= artswrapper:${PORTSDIR}/audio/artswrapper
.endif
.if !defined(WITHOUT_MOTIF)
-USE_MOTIF= yes
-PLIST_APPEND+= plist.motif
+RUN_DEPENDS= nspluginviewer:${PORTSDIR}/www/konqueror-nsplugins
.elseif defined(WITHOUT_MOTIF)
CONFIGURE_ARGS+= --without-motif
.endif
@@ -69,14 +69,20 @@ post-configure:
post-build:
@${CAT} ${PKGDIR}/pkg-message | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
| ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGMESSAGE}
+ @${CAT} ${PKGDIR}/pkg-install | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${PKGINSTALL}
+ @${CAT} ${FILESDIR}/kdm.sh | ${SED} -e 's,%%PREFIX%%,${PREFIX},g' \
+ | ${SED} -e 's,%%X11BASE%%,${X11BASE},g' > ${WRKDIR}/kdm.sh
post-install:
- ${LOCALBASE}/bin/genkdmconf --no-old --in ${PREFIX}/share/config/kdm/default
- ${LOCALBASE}/bin/genkdmconf --no-backup --no-old-scripts --in ${PREFIX}/share/config/kdm
${RM} -f ${PREFIX}/share/apps/konsole/linux.desktop
${CHMOD} u+s ${PREFIX}/bin/kcheckpass
${CHGRP} kmem ${PREFIX}/bin/ksysguardd && \
${CHMOD} g+s ${PREFIX}/bin/ksysguardd
- ${CAT} ${PKGMESSAGE}
+ ${INSTALL_SCRIPT} ${WRKDIR}/kdm.sh ${PREFIX}/etc/rc.d
+.if !defined(PACKAGE_BUILDING)
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
>bapt2013-01-311-2/+2 * Decommissioning java 1.5 (EOLed since October 2009):bapt2012-12-101-7/+2 * - Fix the code instead of suppressing the compiler errorgahr2012-11-302-1/+12 * Fix build with clangbapt2012-11-301-7/+2 * 2012-11-28 editors/glimmer: Depends on the expired gtkglarea through py-gtkbapt2012-11-284-29/+0 * Deprecate a bunch of ports that are either abandonware and/or for which no morebapt2012-10-261-5/+4 * 2012-10-20 security/sscep: No more public distfilesbapt2012-10-2610-359/+0 * Force numerous ports that fail to build with clang over to instead alwayslinimon2012-10-101-0/+1 * use USE_PKGCONFIG= buildbapt2012-10-061-2/+2 * Convert to new options frameworkbapt2012-10-041-10/+10 * - Reassign to the heap at maintainer's requesttabthorpe2012-09-221-6/+2 * Deprecate a bunch a ports with no more public distfiles (thanks ehaupt's dist...bapt2012-09-211-0/+3 * - Register conflicts in my portspav2012-06-041-0/+2 * - update png to 1.5.10dinoex2012-06-019-8/+9 * Remove expired ports:ak2012-05-1913-348/+0 * Mark as deprecated and set expiration to 2012-05-10 for ports that are mark a...bapt2012-04-101-0/+3 * At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450eadler2012-01-221-1/+1 * - fix small typos in COMMENTeadler2011-11-151-1/+1 * Mark as broken on powerpc: does not compile.linimon2011-11-111-0/+4 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-091-1/+0 * Standardize WWW: tags a bit more:dougb2011-11-071-1/+2 * - Fix build on FreeBSD 10miwi2011-10-301-0/+1 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-3/+0 * Remove more tags from pkg-descr files fo the form:dougb2011-10-243-11/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-248-13/+8 * 2012-09-20 www/ruby-http-access: Deprecated upstream, please use www/rubygem-...bapt2011-09-2221-2607/+0 * - Track dependencies after databases/gdbm updategabor2011-09-121-2/+2 * Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where ...kwm2011-08-242-2/+13 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-126-6/+5 * - Adjust WWW line with link to new author's sitefluffy2011-08-041-1/+1 * Deprecate some ports where I can't find distfiles and upstreambapt2011-08-032-0/+6 * Now that the Java 1.3 and Java 1.4 ports are deprecated and will expire soon,linimon2011-07-212-2/+2 * - kick MD5miwi2011-07-021-1/+0 * - Update to 1.8.1pav2011-06-234-15/+16 * Remove unmaintain expired ports from palmbapt2011-05-0222-1047/+0 * Remove most expired ports:rene2011-04-196-60/+0 * - Mark BROKEN: does not compilepav2011-03-271-0/+2 * - Get Rid MD5 supportmiwi2011-03-1938-42/+0 * - Mark ports that have been broken for six month or more, or never compiled onpav2011-03-171-11/+5 * Deprecate unmaintained ports from palm where upstream disapear and/orbapt2011-03-144-0/+12 * Add -I${LOCALBASE}/include to CFLAGS. [1] Sort pkg-plist.gerald2011-01-263-12/+11 * Reset ijliao@FreeBSD.org due to maintainer-timeouts and long absence.linimon2010-12-285-7/+4 * Use the $SRC_BASE Makevar instead of hard-coding.linimon2010-12-171-2/+2 * Sync to new bsd.autotools.mkade2010-12-044-4/+4 * Convert LDCONFIG_DIRS to USE_LDCONFIG.makc2010-06-091-3/+1 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-316-6/+6 * Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for thiskwm2010-05-111-2/+2 * - fix option WITH_PNGdinoex2010-03-301-0/+6 * - update to 1.4.1dinoex2010-03-2812-11/+12 * - Chase x11-toolkits/fltk updategahr2010-03-241-1/+1 * Plugin for JPilot (jpilot.org) to download pictures, photos and videos fromamdmi32010-03-194-0/+50 * - Add backup mirror (looks like project site is down)miwi2010-03-101-1/+1 * - Update to 0.12.5miwi2010-03-102-4/+4 * - update to jpeg-8dinoex2010-02-0510-7/+10 * - Convert to DOCSDIRmiwi2010-02-032-4/+4 * - Remove unneeded dependencies which is in perl-5.8.9 distkuriyama2010-01-261-2/+1 * - Fix sorting and minor cleanups in category Makefilesamdmi32010-01-201-1/+1 * - remove broken/expired ports@ portspgollucci2010-01-1818-919/+0 * - Convert NOMANCOMPRESS to NO_MANCOMPRESS to sync with srcmiwi2009-12-291-1/+1 * For ports maintained by ports@FreeBSD.org, remove names and/ordougb2009-12-215-9/+1 * This port has been broken for 3+ months, thuspav2009-12-081-0/+2