aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdebase4
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-04-08 02:59:07 +0800
committerlofi <lofi@FreeBSD.org>2006-04-08 02:59:07 +0800
commit862c29a971b9242761e1fce7d2883136011096ee (patch)
tree8a40a123f0edfe74330b665637ac7e22ad0991f5 /x11/kdebase4
parentec0d9edb4753d78624cc699fafd85862c58eb12f (diff)
downloadfreebsd-ports-gnome-862c29a971b9242761e1fce7d2883136011096ee.tar.gz
freebsd-ports-gnome-862c29a971b9242761e1fce7d2883136011096ee.tar.zst
freebsd-ports-gnome-862c29a971b9242761e1fce7d2883136011096ee.zip
Fix KDE bug 124826.
Obtained from: KDE SVN, Aron Stansvik <elvstone@gmail.com>
Diffstat (limited to 'x11/kdebase4')
-rw-r--r--x11/kdebase4/Makefile1
-rw-r--r--x11/kdebase4/files/patch-kwin-tabbox.cpp20
2 files changed, 21 insertions, 0 deletions
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index d5066a5cc0a3..bd713a88e9b6 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4/files/patch-kwin-tabbox.cpp b/x11/kdebase4/files/patch-kwin-tabbox.cpp
new file mode 100644
index 000000000000..1254fc501ed8
--- /dev/null
+++ b/x11/kdebase4/files/patch-kwin-tabbox.cpp
@@ -0,0 +1,20 @@
+--- kwin/tabbox.cpp 2006/03/17 21:38:24 519807
++++ kwin/tabbox.cpp 2006/04/03 13:05:18 525954
+@@ -1152,7 +1152,7 @@
+ */
+ Client* Workspace::nextFocusChainClient( Client* c ) const
+ {
+- int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
++ int desktop = !c || c->isOnAllDesktops() ? currentDesktop() : c->desktop();
+ if ( focus_chain[desktop].isEmpty() )
+ return 0;
+ ClientList::ConstIterator it = focus_chain[desktop].find( c );
+@@ -1170,7 +1170,7 @@
+ */
+ Client* Workspace::previousFocusChainClient( Client* c ) const
+ {
+- int desktop = c->isOnAllDesktops() ? currentDesktop() : c->desktop();
++ int desktop = !c || c->isOnAllDesktops() ? currentDesktop() : c->desktop();
+ if ( focus_chain[desktop].isEmpty() )
+ return 0;
+ ClientList::ConstIterator it = focus_chain[desktop].find( c );