aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs3/files
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-08-29 09:53:47 +0800
committerwill <will@FreeBSD.org>2001-08-29 09:53:47 +0800
commitbe53290ac86e3858743d47949e21514781b78810 (patch)
tree29a1f6dd0261a4fd7bafa4c742b76a5e09c08f27 /x11/kdelibs3/files
parentca7019f4eca8ff4e40fbc747e48d9a13aa8c9071 (diff)
downloadfreebsd-ports-gnome-be53290ac86e3858743d47949e21514781b78810.tar.gz
freebsd-ports-gnome-be53290ac86e3858743d47949e21514781b78810.tar.zst
freebsd-ports-gnome-be53290ac86e3858743d47949e21514781b78810.zip
Fix problem with meinproc coredumping on -CURRENT. Basically what the
problem is is that there are a few sloppy pieces of code in xslt.cpp. Bump PORTREVISION to account for recent changes (I had intended to do this much earlier, but wanted to include these patches first, and there was a problem getting them together correctly). Submitted by: mi Tested by: dwcjr, petef
Diffstat (limited to 'x11/kdelibs3/files')
-rw-r--r--x11/kdelibs3/files/patch-kdoctools::Makefile.in14
-rw-r--r--x11/kdelibs3/files/patch-kdoctools::xslt.cpp13
2 files changed, 27 insertions, 0 deletions
diff --git a/x11/kdelibs3/files/patch-kdoctools::Makefile.in b/x11/kdelibs3/files/patch-kdoctools::Makefile.in
new file mode 100644
index 000000000000..42e4165ac2a7
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdoctools::Makefile.in
@@ -0,0 +1,14 @@
+--- kdoctools/Makefile.in Sun Aug 5 20:27:17 2001
++++ kdoctools/Makefile.in.new Tue Aug 28 20:08:34 2001
+@@ -757,10 +757,7 @@
+
+
+ xslt_pure.o: xslt.cpp
+- -rm -f xslt_pure.cpp
+- $(LN_S) $(srcdir)/xslt.cpp xslt_pure.cpp
+- $(CXXCOMPILE) -DSIMPLE_XSLT -c xslt_pure.cpp
+- -rm -f xslt_pure.cpp
++ $(CXXCOMPILE) -DSIMPLE_XSLT -c xslt.cpp -o xslt_pure.o
+
+ messages:
+ $(XGETTEXT) *.cpp -o $(podir)/kdebase/kio_help.pot
diff --git a/x11/kdelibs3/files/patch-kdoctools::xslt.cpp b/x11/kdelibs3/files/patch-kdoctools::xslt.cpp
new file mode 100644
index 000000000000..aa384e393527
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdoctools::xslt.cpp
@@ -0,0 +1,13 @@
+--- kdoctools/xslt.cpp Mon Jul 30 17:11:20 2001
++++ kdoctools/xslt.cpp.new Tue Aug 28 20:09:34 2001
+@@ -86,9 +86,7 @@
+ INFO(i18n("Reading document"));
+ QFile xmlFile( pat );
+ xmlFile.open(IO_ReadOnly);
+- QCString contents;
+- contents.assign(xmlFile.readAll());
+- contents.truncate(xmlFile.size());
++ QCString contents(xmlFile.readAll(), xmlFile.size() + 1);
+ xmlFile.close();
+ /* if (contents.left(5) != "<?xml") {
+ fprintf(stderr, "xmlizer\n");