aboutsummaryrefslogtreecommitdiffstats
path: root/x11/kdelibs3
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-04-02 05:49:50 +0800
committerlofi <lofi@FreeBSD.org>2005-04-02 05:49:50 +0800
commit996b17a5a4790420c267fc8b9fd75a25981a0618 (patch)
tree904d9b8e46e1dbfc1ea50bfe7d84ba0a950dfe9c /x11/kdelibs3
parentdfbd22895c3af4e2838f5208e76cee8eca0edf7f (diff)
downloadfreebsd-ports-gnome-996b17a5a4790420c267fc8b9fd75a25981a0618.tar.gz
freebsd-ports-gnome-996b17a5a4790420c267fc8b9fd75a25981a0618.tar.zst
freebsd-ports-gnome-996b17a5a4790420c267fc8b9fd75a25981a0618.zip
Fix double deletion bug in kio_kzip, which causes nasty crashes in
apps like koffice. Reported by, patch obtained from: Raphael Langerhorst <raphael-langerhorst@gmx.at> Approved by: portmgr (marcus)
Diffstat (limited to 'x11/kdelibs3')
-rw-r--r--x11/kdelibs3/Makefile1
-rw-r--r--x11/kdelibs3/files/patch-kio_kio_kzip.cpp7
2 files changed, 8 insertions, 0 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 36e2fb9ceb5a..bb24110f77c1 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs3/files/patch-kio_kio_kzip.cpp b/x11/kdelibs3/files/patch-kio_kio_kzip.cpp
new file mode 100644
index 000000000000..0163f80b2a20
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kio_kio_kzip.cpp
@@ -0,0 +1,7 @@
+--- kio/kio/kzip.cpp #1.56:1.57
+@@ -382,4 +382,5 @@ bool KZip::openArchive( int mode )
+ kdWarning(7040) << "KSaveFile creation for " << m_filename << " failed, " << strerror( d->m_saveFile->status() ) << endl;
+ delete d->m_saveFile;
++ d->m_saveFile = 0;
+ return false;
+ }