aboutsummaryrefslogtreecommitdiffstats
path: root/x11/keybinder
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2014-01-29 03:38:45 +0800
committerolivierd <olivierd@FreeBSD.org>2014-01-29 03:38:45 +0800
commit9d50c7354cf9119c46caa8b5227b7fd8042d9ca2 (patch)
tree740b88dc8e4b25be67c904a093d1bab9d77eb530 /x11/keybinder
parent6be639f5074ad57bc10e8fd666123987c8d73f78 (diff)
downloadfreebsd-ports-gnome-9d50c7354cf9119c46caa8b5227b7fd8042d9ca2.tar.gz
freebsd-ports-gnome-9d50c7354cf9119c46caa8b5227b7fd8042d9ca2.tar.zst
freebsd-ports-gnome-9d50c7354cf9119c46caa8b5227b7fd8042d9ca2.zip
- Fix Python and Lua versions
- Disable g-ir-scanner cache [1] PR: 185910 Submitted by: amdmi3@ [1]
Diffstat (limited to 'x11/keybinder')
-rw-r--r--x11/keybinder/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/x11/keybinder/Makefile b/x11/keybinder/Makefile
index 306966eb683c..71ebe4c3547b 100644
--- a/x11/keybinder/Makefile
+++ b/x11/keybinder/Makefile
@@ -9,15 +9,14 @@ MASTER_SITES= GENTOO/distfiles
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Library for registering keyboard shortcuts
-BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USE_GNOME= gtk20
+USE_GNOME= gtk20 introspection
USE_XORG= x11 xext xrender
USES= gmake pkgconfig pathfix
USE_LDCONFIG= yes
+MAKE_ENV= GI_SCANNER_DISABLE_CACHE=yes
OPTIONS_DEFINE= DOCS EXAMPLES PYTHON LUA
OPTIONS_DEFAULT= PYTHON
@@ -28,7 +27,7 @@ LUA_DESC= Lua bindings
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USE_PYTHON= 2
USE_GNOME+= pygtk2
PLIST_SUB+= PYTHON=""
.else
@@ -37,7 +36,7 @@ PLIST_SUB+= PYTHON="@comment "
.endif
.if ${PORT_OPTIONS:MLUA}
-USE_LUA= 5.1+
+USE_LUA= 5.1
CONFIGURE_ARGS+= --with-lua-includes=${LUA_INCDIR}
PLIST_SUB+= LUA=""
.else
@@ -58,7 +57,7 @@ PLIST_SUB+= DOCS="@comment "
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
- @${REINPLACE_CMD} -i '' -e 's|lua5.1|lua-5.1|g' ${WRKSRC}/examples/Makefile
+ @${REINPLACE_CMD} -i '' -e 's|lua5.1|lua-${LUA_VER}|g' ${WRKSRC}/examples/Makefile
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.endif