aboutsummaryrefslogtreecommitdiffstats
path: root/x11/keylaunch
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /x11/keylaunch
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'x11/keylaunch')
-rw-r--r--x11/keylaunch/Makefile4
-rw-r--r--x11/keylaunch/files/patch-Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/x11/keylaunch/Makefile b/x11/keylaunch/Makefile
index 55cfa13164ac..4d4008098153 100644
--- a/x11/keylaunch/Makefile
+++ b/x11/keylaunch/Makefile
@@ -22,7 +22,7 @@ USE_XORG= x11
PKGMESSAGE= ${WRKSRC}/pkg-message
post-patch:
- @${PERL} -pi -e 's,%%X11BASE%%,${X11BASE},g' ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/keylaunch ${PREFIX}/bin
@@ -30,7 +30,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/example_rc ${EXAMPLESDIR}/keylaunch.rc
post-install:
- @${SED} -e 's;/usr/X11R6;${PREFIX};g' < ${FILESDIR}/pkg-message.in > \
+ @${SED} -e 's;/usr/X11R6;${LOCALBASE};g' < ${FILESDIR}/pkg-message.in > \
${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
diff --git a/x11/keylaunch/files/patch-Makefile b/x11/keylaunch/files/patch-Makefile
index adbf494bb8dd..eafcf1b6863e 100644
--- a/x11/keylaunch/files/patch-Makefile
+++ b/x11/keylaunch/files/patch-Makefile
@@ -4,7 +4,7 @@
-CC = gcc
-CFLAGS = -g -O2 -Wall
-XROOT = /usr/X11
-+XROOT = %%X11BASE%%
++XROOT = %%LOCALBASE%%
INCLUDES = -I$(XROOT)/include
LIBS = -lX11
LDPATH = -L$(XROOT)/lib