aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libGL
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2004-07-08 06:05:09 +0800
committeranholt <anholt@FreeBSD.org>2004-07-08 06:05:09 +0800
commit491a2868d7aefc491d2c5b35482b769211bd1fd0 (patch)
tree856ed5560a2c6ee70162229127ec1c183c0b298a /x11/libGL
parente201e8187f7e299df1752fdcde99d3667f2a7835 (diff)
downloadfreebsd-ports-gnome-491a2868d7aefc491d2c5b35482b769211bd1fd0.tar.gz
freebsd-ports-gnome-491a2868d7aefc491d2c5b35482b769211bd1fd0.tar.zst
freebsd-ports-gnome-491a2868d7aefc491d2c5b35482b769211bd1fd0.zip
Fix PREFIX setting to match other xlibs ports and unmark BROKEN on -current.
Still requires libXThrStub on 4.x, which libX11 isn't providing (yet). PR: ports/67759 Submitted by: Jonathan Fosburgh <syjef@mdanderson.org>
Diffstat (limited to 'x11/libGL')
-rw-r--r--x11/libGL/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/x11/libGL/Makefile b/x11/libGL/Makefile
index 3d94cbb4f88a..b0fa28c7381e 100644
--- a/x11/libGL/Makefile
+++ b/x11/libGL/Makefile
@@ -18,18 +18,22 @@ COMMENT= OpenGL library that renders using GLX or DRI
LIB_DEPENDS= Xxf86vm.1:${PORTSDIR}/x11/libXxf86
-BROKEN= Build fails
-
CONFLICTS= XFree86-libraries-*
EXTRA_PATCHES= ${CF_PATCHES}
+PREFIX?= ${X11BASE}
XBUILD_DIRS= lib/GL
GLHEADERS= gl.h glext.h glx.h glxext.h glxint.h glxmd.h glxproto.h \
glxtokens.h
INSTALLS_SHLIB= yes
USE_GNOME= pkgconfig
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500043
+BROKEN= Requires libXThrStub, which should be part of libX11
+.endif
+
post-extract:
(cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
${DISTDIR}/${DIST_SUBDIR}/X11R6.7.0-src3.tar.gz | \
@@ -42,4 +46,4 @@ post-install:
.endfor
.include "${.CURDIR}/../../x11-servers/xorg-server/Makefile.inc"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>