aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libX11
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 03:49:54 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 03:49:54 +0800
commit19277bf9f9001d90852676fc37971acbcf8a517a (patch)
tree74eef508888f2b7cab72b76594224f6c91f0eb37 /x11/libX11
parent1c9604519cd7ae5096f26888a4a8b3986de33346 (diff)
downloadfreebsd-ports-gnome-19277bf9f9001d90852676fc37971acbcf8a517a.tar.gz
freebsd-ports-gnome-19277bf9f9001d90852676fc37971acbcf8a517a.tar.zst
freebsd-ports-gnome-19277bf9f9001d90852676fc37971acbcf8a517a.zip
New port: Prerelease version of libX11 from freedesktop.org.
Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libX11')
-rw-r--r--x11/libX11/Makefile34
-rw-r--r--x11/libX11/distinfo1
-rw-r--r--x11/libX11/files/patch-Makefile.in11
-rw-r--r--x11/libX11/pkg-descr6
-rw-r--r--x11/libX11/pkg-plist18
5 files changed, 70 insertions, 0 deletions
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
new file mode 100644
index 000000000000..cd9222164476
--- /dev/null
+++ b/x11/libX11/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libX11
+# Date Created: 28 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libX11
+PORTVERSION= 6.2.1.p2
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X11 library
+
+BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
+ ${X11BASE}/libdata/pkgconfig/xtrans.pc:${PORTSDIR}/x11/libXtrans \
+ ${X11BASE}/libdata/pkgconfig/xau.pc:${PORTSDIR}/x11/libXau
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --enable-xdmauth
+CFLAGS+= -DMALLOC_0_RETURNS_NULL -DXLOCALEDIR="\"${X11BASE}/locale\""
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.2.1
+
+INSTALLS_SHLIB= yes
+
+# This is a hack until we get locale files included with libX11.
+post-install:
+ ${LN} -shf ${PREFIX}/lib/X11/locale ${PREFIX}/share/X11/locale
+
+.include <bsd.port.mk>
diff --git a/x11/libX11/distinfo b/x11/libX11/distinfo
new file mode 100644
index 000000000000..62bf7fc949ba
--- /dev/null
+++ b/x11/libX11/distinfo
@@ -0,0 +1 @@
+MD5 (libX11-6.2.1.p2.tar.bz2) = fe3afd486d204a5e98cb8e155e98e4db
diff --git a/x11/libX11/files/patch-Makefile.in b/x11/libX11/files/patch-Makefile.in
new file mode 100644
index 000000000000..00f31a36775b
--- /dev/null
+++ b/x11/libX11/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Nov 9 23:02:21 2003
++++ Makefile.in Sun Nov 9 23:02:34 2003
+@@ -159,7 +159,7 @@
+ target_alias = @target_alias@
+ SUBDIRS = include src
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = x11.pc
+
+ EXTRA_DIST = x11.pc.in
diff --git a/x11/libX11/pkg-descr b/x11/libX11/pkg-descr
new file mode 100644
index 000000000000..b79c61eb5c33
--- /dev/null
+++ b/x11/libX11/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X11 library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libX11/pkg-plist b/x11/libX11/pkg-plist
new file mode 100644
index 000000000000..e35e7bd7012b
--- /dev/null
+++ b/x11/libX11/pkg-plist
@@ -0,0 +1,18 @@
+include/X11/ImUtil.h
+include/X11/XKBlib.h
+include/X11/Xcms.h
+include/X11/Xlib.h
+include/X11/Xlibint.h
+include/X11/Xlocale.h
+include/X11/Xresource.h
+include/X11/Xutil.h
+include/X11/cursorfont.h
+include/X11/region.h
+lib/libX11.a
+lib/libX11.la
+lib/libX11.so
+lib/libX11.so.6
+libdata/pkgconfig/x11.pc
+share/X11/XErrorDB
+share/X11/XKeysymDB
+share/X11/locale