aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libX11
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2008-03-13 18:33:56 +0800
committerflz <flz@FreeBSD.org>2008-03-13 18:33:56 +0800
commit0168f07d84c75869f83514e0ec3b0292b66a99ea (patch)
tree4bd27adb95880e52c0aea75078e283f0ae218c9a /x11/libX11
parentb2adedb7b99ad39c6e1b3329104bfb688a6f28b1 (diff)
downloadfreebsd-ports-gnome-0168f07d84c75869f83514e0ec3b0292b66a99ea.tar.gz
freebsd-ports-gnome-0168f07d84c75869f83514e0ec3b0292b66a99ea.tar.zst
freebsd-ports-gnome-0168f07d84c75869f83514e0ec3b0292b66a99ea.zip
- Mark xtrans as a BUILD_DEPENDS only (unless specified otherwise with :both)
- Bump PORTREVISION on ports having xtrans in USE_XORG. - Add some missing dependencies in various xorg libraries.
Diffstat (limited to 'x11/libX11')
-rw-r--r--x11/libX11/Makefile28
1 files changed, 17 insertions, 11 deletions
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
index 715e1d2203ff..bb5baf630641 100644
--- a/x11/libX11/Makefile
+++ b/x11/libX11/Makefile
@@ -7,27 +7,33 @@
PORTNAME= libX11
PORTVERSION= 1.1.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11
MAINTAINER= x11@FreeBSD.org
COMMENT= X11 library
+OPTIONS= XCB "use XCB for low-level protocol implementation" off
+
+XORG_CAT= lib
+USE_XORG= bigreqsproto xau xcmiscproto xdmcp xextproto xtrans \
+ kbproto:both inputproto xf86bigfontproto xproto:both
+USE_XORG+=
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ARGS+= --enable-xdmauth --datadir=${PREFIX}/lib
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_XCB)
-BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/xcb-xlib.pc:${PORTSDIR}/x11/libxcb
-RUN_DEPENDS= ${BUILD_DEPENDS}
-CONFIGURE_ARGS= --with-xcb=yes
+BUILD_DEPENDS+= ${X11BASE}/libdata/pkgconfig/xcb-xlib.pc:${PORTSDIR}/x11/libxcb
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+CONFIGURE_ARGS+= --with-xcb=yes
PLIST_SUB+= XCB=""
.else
-CONFIGURE_ARGS= --with-xcb=no
+CONFIGURE_ARGS+= --with-xcb=no
PLIST_SUB+= XCB="@comment "
.endif
-XORG_CAT= lib
-USE_XORG= bigreqsproto xau xdmcp xextproto xtrans xcmiscproto kbproto:both \
- inputproto:both xf86bigfontproto xproto:both
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS+= --enable-xdmauth --datadir=${PREFIX}/lib
-
.include "${.CURDIR}/manpages"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>