aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXcursor
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 09:41:43 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 09:41:43 +0800
commit04a4915d4cf6a748bf36003b3d7ebe12b9ac7a06 (patch)
tree2722e0007832611159e2b82a021811a3d7eb20eb /x11/libXcursor
parent96041ab67c1012166ddeb34dd90f8535763df857 (diff)
downloadfreebsd-ports-gnome-04a4915d4cf6a748bf36003b3d7ebe12b9ac7a06.tar.gz
freebsd-ports-gnome-04a4915d4cf6a748bf36003b3d7ebe12b9ac7a06.tar.zst
freebsd-ports-gnome-04a4915d4cf6a748bf36003b3d7ebe12b9ac7a06.zip
New port: Prerelease version of libXcursor from freedesktop.org:
X client-side cursor loading library Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libXcursor')
-rw-r--r--x11/libXcursor/Makefile34
-rw-r--r--x11/libXcursor/distinfo1
-rw-r--r--x11/libXcursor/files/patch-Makefile.in11
-rw-r--r--x11/libXcursor/pkg-descr6
-rw-r--r--x11/libXcursor/pkg-plist6
5 files changed, 58 insertions, 0 deletions
diff --git a/x11/libXcursor/Makefile b/x11/libXcursor/Makefile
new file mode 100644
index 000000000000..4c5eabd7f018
--- /dev/null
+++ b/x11/libXcursor/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libXcursor
+# Date Created: 22 Nov, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXcursor
+PORTVERSION= 1.1.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X client-side cursor loading library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+MAN3= Xcursor.3
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.1.1
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/x11/libXcursor/distinfo b/x11/libXcursor/distinfo
new file mode 100644
index 000000000000..9aaa1cddc713
--- /dev/null
+++ b/x11/libXcursor/distinfo
@@ -0,0 +1 @@
+MD5 (libXcursor-1.1.1.p1.tar.bz2) = 5bc778904371f1fb5fb21f27cd4f227c
diff --git a/x11/libXcursor/files/patch-Makefile.in b/x11/libXcursor/files/patch-Makefile.in
new file mode 100644
index 000000000000..d774877de4a9
--- /dev/null
+++ b/x11/libXcursor/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Nov 22 17:27:48 2003
++++ Makefile.in Sat Nov 22 17:32:03 2003
+@@ -187,7 +187,7 @@
+ libXcursorincludedir = $(includedir)/X11/Xcursor
+ libXcursorinclude_HEADERS = Xcursor.h
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = xcursor.pc
+
+ EXTRA_DIST = $(man_MANS) xcursor.pc.in autogen.sh
diff --git a/x11/libXcursor/pkg-descr b/x11/libXcursor/pkg-descr
new file mode 100644
index 000000000000..b8a320199cc3
--- /dev/null
+++ b/x11/libXcursor/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the X client-side cursor loading library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Eric Anholt
+anholt@FreeBSD.org
diff --git a/x11/libXcursor/pkg-plist b/x11/libXcursor/pkg-plist
new file mode 100644
index 000000000000..2207738f94d4
--- /dev/null
+++ b/x11/libXcursor/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/Xcursor/Xcursor.h
+lib/libXcursor.a
+lib/libXcursor.la
+lib/libXcursor.so
+lib/libXcursor.so.1
+libdata/pkgconfig/xcursor.pc \ No newline at end of file