aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXext/Makefile
diff options
context:
space:
mode:
authoranholt <anholt@FreeBSD.org>2003-12-22 09:02:26 +0800
committeranholt <anholt@FreeBSD.org>2003-12-22 09:02:26 +0800
commitd58d63133695a2226010f4971fd4b075136141b4 (patch)
tree2b88556d2231584878563b92c8b080fc4eca2d36 /x11/libXext/Makefile
parenta4f5e579bb5b477aa22354328f561ab4bddbc3cc (diff)
downloadfreebsd-ports-gnome-d58d63133695a2226010f4971fd4b075136141b4.tar.gz
freebsd-ports-gnome-d58d63133695a2226010f4971fd4b075136141b4.tar.zst
freebsd-ports-gnome-d58d63133695a2226010f4971fd4b075136141b4.zip
New port: Prerelease version of libXext from freedesktop.org:
X Extension library. Testing is encouraged, but please do not use these ports as dependencies until they are updated to release tarballs and the XFree86 ports have been updated to depend on them.
Diffstat (limited to 'x11/libXext/Makefile')
-rw-r--r--x11/libXext/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/libXext/Makefile b/x11/libXext/Makefile
new file mode 100644
index 000000000000..0e4f1745dceb
--- /dev/null
+++ b/x11/libXext/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libXext
+# Date Created: 29 Oct, 2003
+# Whom: Eric Anholt <anholt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libXext
+PORTVERSION= 6.4.1.p1
+CATEGORIES= x11
+MASTER_SITES= http://pdx.freedesktop.org/~anholt/dist/
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X11 Extension library
+
+LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/x11.pc:${PORTSDIR}/x11/libX11
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig \
+ ${X11BASE}/libdata/pkgconfig/xproto.pc:${PORTSDIR}/x11/xproto \
+ ${X11BASE}/libdata/pkgconfig/xextensions.pc:${PORTSDIR}/x11/xextensions \
+ ${LIB_PC_DEPENDS}
+RUN_DEPENDS= ${LIB_PC_DEPENDS}
+
+USE_BZIP2= yes
+PREFIX?= ${X11BASE}
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CFLAGS+= -DMALLOC_0_RETURNS_NULL
+WRKSRC= ${WRKDIR}/${PORTNAME}-6.4.1
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>