aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libXp/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2007-05-20 04:36:56 +0800
committerflz <flz@FreeBSD.org>2007-05-20 04:36:56 +0800
commit87f4d471fb27b9547c1a0de221b51f4c31684157 (patch)
treedfc4d7ae0fdd043d231bab6f4e98fccbbad14665 /x11/libXp/Makefile
parent5ae66b41b712e5f34c78308a97f7511fc0b1539e (diff)
downloadfreebsd-ports-gnome-87f4d471fb27b9547c1a0de221b51f4c31684157.tar.gz
freebsd-ports-gnome-87f4d471fb27b9547c1a0de221b51f4c31684157.tar.zst
freebsd-ports-gnome-87f4d471fb27b9547c1a0de221b51f4c31684157.zip
- Welcome X.org 7.2 \o/.
- Set X11BASE to ${LOCALBASE} for recent ${OSVERSION}. - Bump PORTREVISION for ports intalling files in ${X11BASE}.
Diffstat (limited to 'x11/libXp/Makefile')
-rw-r--r--x11/libXp/Makefile57
1 files changed, 40 insertions, 17 deletions
diff --git a/x11/libXp/Makefile b/x11/libXp/Makefile
index a8a57807f0ed..7fe491916ed8 100644
--- a/x11/libXp/Makefile
+++ b/x11/libXp/Makefile
@@ -6,29 +6,52 @@
#
PORTNAME= libXp
-PORTVERSION= 6.0
+PORTVERSION= 1.0.0
+PORTEPOCH= 1
CATEGORIES= x11
-MASTER_SITES= http://xorg.freedesktop.org/X11R6.7.0/src/ \
- ${MASTER_SITE_XORG}
-MASTER_SITE_SUBDIR= X11R6.7/tars
-DISTNAME= X11R6.7.0-src1
MAINTAINER= x11@FreeBSD.org
COMMENT= X print library
-LIB_PC_DEPENDS= ${X11BASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext \
- ${X11BASE}/include/X11/extensions/Print.h:${PORTSDIR}/x11/printext
-BUILD_DEPENDS= ${LIB_PC_DEPENDS}
-RUN_DEPENDS= ${LIB_PC_DEPENDS}
+XORG_CAT= lib
+USE_XORG= x11 xext xextproto xau printproto:both
+USE_AUTOTOOLS= libtool:15
-CONFLICTS= XFree86-libraries-* xorg-libraries-*
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-USE_IMAKE= YES
-USE_X_PREFIX= no
-PREFIX?= ${X11BASE}
-DIST_SUBDIR= xorg
-INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/xc/lib/Xp
-EXTRACT_AFTER_ARGS= | ${TAR} -xf - xc/lib/Xp
+MAN3= XpCancelDoc.3 \
+ XpCancelJob.3 \
+ XpCancelPage.3 \
+ XpCreateContext.3 \
+ XpDestroyContext.3 \
+ XpEndDoc.3 \
+ XpEndJob.3 \
+ XpEndPage.3 \
+ XpFreePrinterList.3 \
+ XpGetAttributes.3 \
+ XpGetContext.3 \
+ XpGetDocumentData.3 \
+ XpGetImageResolution.3 \
+ XpGetLocaleHinter.3 \
+ XpGetOneAttribute.3 \
+ XpGetPageDimensions.3 \
+ XpGetPdmStartParams.3 \
+ XpGetPrinterList.3 \
+ XpGetScreenOfContext.3 \
+ XpInputSelected.3 \
+ XpPutDocumentData.3 \
+ XpQueryExtension.3 \
+ XpQueryScreens.3 \
+ XpQueryVersion.3 \
+ XpRehashPrinterList.3 \
+ XpSelectInput.3 \
+ XpSetAttributes.3 \
+ XpSetContext.3 \
+ XpSetImageResolution.3 \
+ XpSetLocaleHinter.3 \
+ XpStartDoc.3 \
+ XpStartJob.3 \
+ XpStartPage.3 \
+ libXp.3
.include <bsd.port.mk>