aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libdnd/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-08-11 16:54:43 +0800
committertg <tg@FreeBSD.org>1997-08-11 16:54:43 +0800
commit335aff27b139e0d0b18d1850c99e4da8a7327c49 (patch)
tree6e614a8c19717cdafaa875255247197a9b8591b0 /x11/libdnd/Makefile
parentbcab824ae51ce74e7eb1f27d2f0370cdc2040b4c (diff)
downloadfreebsd-ports-gnome-335aff27b139e0d0b18d1850c99e4da8a7327c49.tar.gz
freebsd-ports-gnome-335aff27b139e0d0b18d1850c99e4da8a7327c49.tar.zst
freebsd-ports-gnome-335aff27b139e0d0b18d1850c99e4da8a7327c49.zip
Import of libdnd port. libdnd is an X11-lib for drag-and-drop operations
used by some office applications. PR: 4250 Submitted by: Kostya Lukin <lukin@ns.okbmei.msk.su>
Diffstat (limited to 'x11/libdnd/Makefile')
-rw-r--r--x11/libdnd/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11/libdnd/Makefile b/x11/libdnd/Makefile
new file mode 100644
index 000000000000..b6aa87eaebba
--- /dev/null
+++ b/x11/libdnd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libDnd
+# Version required: 1.1
+# Date created: 8 August 1997
+# Whom: lukin@okbmei.msk.su
+#
+# $Id$
+#
+
+DISTNAME= dnd.1.1
+PKGNAME= libdnd-1.1
+CATEGORIES= x11
+MASTER_SITES= http://leb.net/OffiX/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= lukin@okbmei.msk.su
+
+WRKSRC= ${WRKDIR}/DND/DNDlib
+GNU_CONFIGURE= yes
+ALL_TARGET= libC libCpp
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/libdnd
+ ${INSTALL_MAN} ${WRKDIR}/DND/DNDdoc/* ${PREFIX}/share/doc/libdnd
+.endif
+
+.include <bsd.port.mk>