aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-20 01:31:43 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-20 01:31:43 +0800
commitf267f484a39f56123518e320a81eed6370327aaa (patch)
treeafa6006dc2cd708e6274ae78c007e5bee66e1f9a /x11/libgnome/Makefile
parent2ecfd69a74178661dcd9f5cd8300e67d183dd6f5 (diff)
downloadfreebsd-ports-gnome-f267f484a39f56123518e320a81eed6370327aaa.tar.gz
freebsd-ports-gnome-f267f484a39f56123518e320a81eed6370327aaa.tar.zst
freebsd-ports-gnome-f267f484a39f56123518e320a81eed6370327aaa.zip
Update to 1.112.1 after a repo-copy from gnomelibs.
Diffstat (limited to 'x11/libgnome/Makefile')
-rw-r--r--x11/libgnome/Makefile48
1 files changed, 16 insertions, 32 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 87e6c925d847..21ff74bb8292 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -1,59 +1,43 @@
-# New ports collection makefile for: gnomelibs
+# New ports collection makefile for: libgnome
# Date created: 17 June 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $FreeBSD$
#
-PORTNAME= gnomelibs
-PORTVERSION= 1.4.1.4
-PORTREVISION= 1
+PORTNAME= libgnome
+PORTVERSION= 1.112.1
CATEGORIES?= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= stable/sources/gnome-libs
-DISTNAME= gnome-libs-${PORTVERSION}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta2
+DIST_SUBDIR= gnome2
MAINTAINER?= gnome@FreeBSD.org
-BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-LIB_DEPENDS+= xml.5:${PORTSDIR}/textproc/libxml \
- ORBit.2:${PORTSDIR}/devel/ORBit
-RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+LIB_DEPENDS+= xslt.1:${PORTSDIR}/textproc/libxslt \
+ gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_XPM= yes
-USE_PERL5= yes
USE_GMAKE= yes
-USE_IMLIB= yes
USE_ESOUND= yes
+USE_BISON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --disable-test-gnome
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome2 \
+ --datadir=${PREFIX}/share/gnome2 \
+ --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-
-MAN1= dns-helper.1 gconfigger.1 gnome-bug.1 gnome-config.1 \
- gnome-doc.1 gnome-dump-metadata.1 gnome-gen-mimedb.1 \
- gnome-mkstub.1 gnome-moz-remote.1 gnome-name-service.1 \
- gnome-pty-helper.1 gnome.1 gnome_segv.1 goad-browser.1 \
- libart-config.1 loadshlib.1 new-object.1
-MAN5= gnome-mime.5
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
-
-post-patch:
- @${PERL} -pi -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/gnome-config.in ${WRKSRC}/libgnome/gnome-util.c
-
-# need to make launched gnome-terminals appear in utmp/wtmp
-post-install:
- @${CHMOD} u+s ${PREFIX}/bin/gnome-pty-helper
+ 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
.include <bsd.port.mk>