aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2005-01-30 04:21:04 +0800
committermezz <mezz@FreeBSD.org>2005-01-30 04:21:04 +0800
commit577add6b6109b07287b844f81160629bacd060a7 (patch)
tree0c4c9cce0682ec238270e554edd2aa9c35a30cfc /x11/libgnome
parentfebc1080d7da9f632819f9e1ad4e04af95aaec4d (diff)
downloadfreebsd-ports-gnome-577add6b6109b07287b844f81160629bacd060a7.tar.gz
freebsd-ports-gnome-577add6b6109b07287b844f81160629bacd060a7.tar.zst
freebsd-ports-gnome-577add6b6109b07287b844f81160629bacd060a7.zip
devel/gconf2
Remove the post-install/pkg-install, since gnomehier is taking care of it. devel/gnomevfs2 Add pkg-install and pkg-deinstall to restore libgnome's gconf key if libgnome's .schemas exists. This fix the plist complained by pointyhat. Why restore libgnome's gconf key during the installtion if it exists? Because, libgnome always depend on gnomevfs2 so make sure the libgnome is still in the top when we either reinstall or upgrade gnomevfs2. misc/gnomehier Remove the etc/gconf/gconf.xml.defaults/*, since the gconftool is taking care of it. ie: GCONF_SCHEMAS x11/libgnome Add pkg-deinstall to restore gnomevfs2's gconf key if gnomevfs2's schemas exists. This fix the plist complained by pointyhat. Also, this is a real fix for the weird keyboard problem when you uninstall libgnome without reinstall it. Bump the PORTREVISION in all of four ports above to fix everything with gconf keys stuff for plist. Those have been tested in the MarcusCom CVS, GNOME tinderbox, and my tinderbox.
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile8
-rw-r--r--x11/libgnome/pkg-deinstall.in19
2 files changed, 25 insertions, 2 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 93ca85a26992..50f44aff4cea 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgnome
PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
@@ -32,6 +32,8 @@ USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+
GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
desktop_gnome_accessibility_startup.schemas \
desktop_gnome_applications_browser.schemas \
@@ -52,8 +54,10 @@ GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-libgnome_gnome-program.c
.endif
-.if defined(NOPORTDOCS)
post-patch:
+ @${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
+ < ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
+.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|gnome-data po doc|gnome-data po|g' \
${WRKSRC}/Makefile.in
.endif
diff --git a/x11/libgnome/pkg-deinstall.in b/x11/libgnome/pkg-deinstall.in
new file mode 100644
index 000000000000..0ac463865c7f
--- /dev/null
+++ b/x11/libgnome/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Restore gconf keys of gnomevfs2.
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+SCHEMAS=%%X11BASE%%/etc/gconf/schemas/desktop_default_applications.schemas
+
+if [ -f ${SCHEMAS} ]; then
+ env GCONF_CONFIG_SOURCE=xml::%%X11BASE%%/etc/gconf/gconf.xml.defaults \
+ %%X11BASE%%/bin/gconftool-2 --makefile-install-rule ${SCHEMAS} \
+ > /dev/null || /usr/bin/true
+fi
+
+exit 0