aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-08-04 09:19:21 +0800
committerade <ade@FreeBSD.org>2000-08-04 09:19:21 +0800
commitf710791a75a1a897078bc67c9d8d237aa98f6e36 (patch)
tree9678346bea3d4ebce203fa7ff52257077ed4ac10 /x11/libgnome
parentcb57a6c30e8edc7db27081f1e42de38911b80a8c (diff)
downloadfreebsd-ports-gnome-f710791a75a1a897078bc67c9d8d237aa98f6e36.tar.gz
freebsd-ports-gnome-f710791a75a1a897078bc67c9d8d237aa98f6e36.tar.zst
freebsd-ports-gnome-f710791a75a1a897078bc67c9d8d237aa98f6e36.zip
Extensive patchfile cleanups using sobomax's wonderful
post-extract rule
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile7
-rw-r--r--x11/libgnome/files/patch-aa38
-rw-r--r--x11/libgnome/files/patch-ac12
-rw-r--r--x11/libgnome/files/patch-ag2
4 files changed, 28 insertions, 31 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 5eca7664198c..90b311d64e31 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -39,4 +39,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gnome.1 gnome-config.1
MAN5= gnome-mime.5
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>
diff --git a/x11/libgnome/files/patch-aa b/x11/libgnome/files/patch-aa
index 4b1108a7aa4a..604dc409f06d 100644
--- a/x11/libgnome/files/patch-aa
+++ b/x11/libgnome/files/patch-aa
@@ -1,33 +1,15 @@
---- configure.orig Tue Apr 27 14:24:19 1999
-+++ configure Mon Jun 7 20:27:21 1999
-@@ -2521,7 +2521,7 @@
- fi
- if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
- echo "$ac_t""yes" 1>&6
-- PTHREAD_LIB="-lc_r"
-+ PTHREAD_LIB=""
- else
- echo "$ac_t""no" 1>&6
- echo $ac_n "checking for pthread_create""... $ac_c" 1>&6
-@@ -5215,7 +5215,7 @@
- cat conftest.$ac_ext >&5
- rm -rf conftest*
- CATOBJEXT=.mo
-- DATADIRNAME=lib
-+ DATADIRNAME=share
- fi
- rm -f conftest*
- INSTOBJEXT=.mo
-@@ -7372,7 +7372,7 @@
+--- configure.orig Tue Aug 1 21:58:10 2000
++++ configure Tue Aug 1 21:59:03 2000
+@@ -7214,7 +7214,7 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-ltiff -lm $LIBS"
+LIBS="-ltiff -ljpeg -lz -lm $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 7378 "configure"
+ #line 7220 "configure"
#include "confdefs.h"
-@@ -10853,13 +10853,13 @@
+@@ -10208,13 +10208,13 @@
SUPPORTINCS='-DNEED_GNOMESUPPORT_H -I$(top_builddir)/support -I$(top_srcdir)/support'
ART_LIBS="-lart_lgpl"
@@ -43,7 +25,15 @@
GNOME_IDLDIR='-I${datadir}/idl'
-@@ -11724,10 +11724,6 @@
+@@ -10609,6 +10609,7 @@
+ s%@MAINTAINER_MODE_FALSE@%$MAINTAINER_MODE_FALSE%g
+ s%@MAINT@%$MAINT%g
+ s%@cflags_set@%$cflags_set%g
++s%@GLIB_CONFIG@%$GLIB_CONFIG%g
+ s%@GTK_CONFIG@%$GTK_CONFIG%g
+ s%@GTK_CFLAGS@%$GTK_CFLAGS%g
+ s%@GTK_LIBS@%$GTK_LIBS%g
+@@ -11079,10 +11080,6 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
diff --git a/x11/libgnome/files/patch-ac b/x11/libgnome/files/patch-ac
index 6b3a11c2a084..f73a45521ae8 100644
--- a/x11/libgnome/files/patch-ac
+++ b/x11/libgnome/files/patch-ac
@@ -14,13 +14,13 @@
Known values for LIBRARY are:
- glib (calls glib-config)
-+ glib (calls glib12-config)
++ glib (calls @GLIB_CONFIG@)
idl (to be used with orbit-idl)
gnome
gnomeui
gnorba
- gtk (calls gtk-config)
-+ gtk (calls gtk12-config)
++ gtk (calls @GTK_CONFIG@)
gtkxmhtml (only --libs)
zvt (only --libs)
@@ -41,14 +41,14 @@
glib)
- the_libs="$the_libs `glib-config --libs`"
- the_flags="$the_flags `glib-config --cflags`"
-+ the_libs="$the_libs `glib12-config --libs`"
-+ the_flags="$the_flags `glib12-config --cflags`"
++ the_libs="$the_libs `@GLIB_CONFIG@ --libs`"
++ the_flags="$the_flags `@GLIB_CONFIG@ --cflags`"
;;
gtk)
- the_libs="$the_libs `gtk-config --libs`"
- the_flags="$the_flags `gtk-config --cflags`"
-+ the_libs="$the_libs `gtk12-config --libs`"
-+ the_flags="$the_flags `gtk12-config --cflags`"
++ the_libs="$the_libs `@GTK_CONFIG@ --libs`"
++ the_flags="$the_flags `@GTK_CONFIG@ --cflags`"
;;
gnome)
the_libs="$the_libs @GNOME_LIBDIR@ @GNOME_LIBS@"
diff --git a/x11/libgnome/files/patch-ag b/x11/libgnome/files/patch-ag
index 8778bc26ffc9..6b5481c4e7b9 100644
--- a/x11/libgnome/files/patch-ag
+++ b/x11/libgnome/files/patch-ag
@@ -6,7 +6,7 @@
static char *shells [] = {
- "/bin/bash", "/bin/zsh", "/bin/tcsh", "/bin/ksh",
- "/bin/csh", "/bin/sh", 0
-+ "/bin/csh", "/bin/sh", "/usr/local/bin/tcsh",
++ "/bin/csh", "/bin/sh", "/bin/tcsh", "/usr/local/bin/tcsh",
+ "/usr/local/bin/bash", "/usr/local/bin/ksh",
+ "/usr/local/bin/zsh", "/usr/local/sbin/scsh", 0
};
gi/freebsd-ports-gnome/commit/hebrew?h=gnome-3.24&id=e045754db1a7bae70c28383e59db225b8ffb9984'>Update to KDE 3.5.3lofi2006-06-064-22/+20 * Update to KOffice 1.5.1lofi2006-05-272-4/+4 * Update to KOffice 1.5.0lofi2006-04-293-22/+8 * Update to KDE 3.5.2lofi2006-03-314-128/+22 * Conversion to a single libtool environment.ade2006-02-231-1/+1 * Update to KDE 3.5.1.lofi2006-02-014-8/+18 * SHA256ifyedwin2006-01-224-0/+4 * Update to KDE 3.5.0lofi2006-01-094-74/+82 * - Add SHA256pav2005-11-251-0/+1 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * Update to 0.101mnag2005-11-072-3/+3 * Update to KDE 3.4.3 / KOffice 1.4.2lofi2005-11-054-6/+34 * Remove all the secondary port of editors/ooodict-allmaho2005-11-012-20/+0 * Fix index build by moving openoffice.org-1.1 ports.maho2005-08-291-1/+1 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-012-4/+4 * Update to KDE 3.4.1lofi2005-06-264-22/+30 * - Fix categoriespav2005-06-061-0/+1 * - Unbreak and general updatepav2005-06-062-0/+19 * change the libtool version to use from 1.3 to 1.5oliver2005-06-031-1/+1 * Update to KDE 3.4lofi2005-03-214-78/+34 * Add i18nized doc subdirs to kdehier and adjust i18n port plists accordingly.lofi2004-12-232-2/+0 * Fix kde3-i18n ports.lofi2004-12-162-4/+4 * Update to KDE 3.3.2lofi2004-12-148-12/+12 * Update to 0.8arved2004-12-025-30/+12 * - Update maintainer's email addresspav2004-11-152-4/+4 * Update to KDE 3.3.1lofi2004-11-086-7/+35 * As previously announced, remove hebrew/pine due to security problems.linimon2004-10-23