aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
committermarcus <marcus@FreeBSD.org>2005-03-12 18:39:38 +0800
commit0b42143dea1a55d0f1f6d09704bbc131e1b633ed (patch)
treebc54902eb18f738e45a91362b2b0faf1ec6d04fa /x11/libgnome
parent773c9ca4ac44ac67652d01f1e985e4df8dab5301 (diff)
downloadfreebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.gz
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.tar.zst
freebsd-ports-gnome-0b42143dea1a55d0f1f6d09704bbc131e1b633ed.zip
Presenting GNOME 2.10 for FreeBSD!
The release notes can be found at http://www.gnome.org/start/2.10/notes/rnwhatsnew.html, and will give you a good idea of what has gone into this release overall. However, a lot of FreeBSD specific additions and fixes have been made. For example, this release offers fixed ACPI support as well as new CPU freqeuncy monitoring support. See the FreeBSD GNOME 2.10 upgrade page at http://www.FreeBSD.org/gnome/docs/faq210.html for the entire list as well as a list of known issues and upgrade instructions. GNOME 2.10, as well as all of our releases, would not be possible without the great team that goes into porting and testign each and every component. Thanks definitely goes out to ahze, adamw, bland, kwm, mezz, and pav for all their work. We would also like to thank our adventurous users that chose to ride the walrus. We'd especially like to thank the following users that provided patches for GNOME 2.10: ade Yasuda Keisuke Franz Klammer Khairil Yusof Radek Kozlowsk And anyone else I may have accidentally omitted. As with GNOME 2.8, 2.10 comes with a brand-spankin' new splashscreen courtesy of Franz Klammer. However, unlike GNOME 2.8, we've included all of the FreeBSD GNOME splashscreen entries with gnomesession. You can use the deskutils/splashsetter port to choose the one you like best. As always, GNOME users should _not_ use portupgrade alone to upgrade to 2.10. Instead, get the gnome_upgrade.sh script from http://www.FreeBSD.org/gnome/gnome_upgrade.sh. Enjoy!
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile10
-rw-r--r--x11/libgnome/distinfo4
-rw-r--r--x11/libgnome/files/patch-libgnome_gnome-program.c13
-rw-r--r--x11/libgnome/pkg-plist56
4 files changed, 37 insertions, 46 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index e3ffc9118ca1..64e07c6fa498 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libgnome
-PORTVERSION= 2.8.1
+PORTVERSION= 2.10.0
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.8
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_XPM= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier intlhack esound \
+USE_GNOME= gnomeprefix gnomehack intlhack esound \
gnomevfs2 libxslt
USE_BISON= yes
INSTALLS_SHLIB= yes
@@ -47,8 +47,6 @@ GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
desktop_gnome_sound.schemas desktop_gnome_thumbnailers.schemas \
desktop_gnome_typing_break.schemas
-.include <bsd.port.pre.mk>
-
post-patch:
@${SED} -e 's|%%X11BASE%%|${X11BASE}|g' \
< ${MASTERDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
@@ -57,4 +55,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11/libgnome/distinfo b/x11/libgnome/distinfo
index f102c8bb2600..c21b936b02c0 100644
--- a/x11/libgnome/distinfo
+++ b/x11/libgnome/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/libgnome-2.8.1.tar.bz2) = 17577198f5086c48f69c361be2f4806c
-SIZE (gnome2/libgnome-2.8.1.tar.bz2) = 1178438
+MD5 (gnome2/libgnome-2.10.0.tar.bz2) = f8e1225d96126f5139232821a6723d15
+SIZE (gnome2/libgnome-2.10.0.tar.bz2) = 871282
diff --git a/x11/libgnome/files/patch-libgnome_gnome-program.c b/x11/libgnome/files/patch-libgnome_gnome-program.c
index 8485c2aa7660..9dd33f9c2838 100644
--- a/x11/libgnome/files/patch-libgnome_gnome-program.c
+++ b/x11/libgnome/files/patch-libgnome_gnome-program.c
@@ -1,5 +1,5 @@
---- libgnome/gnome-program.c.orig Mon Feb 21 07:39:01 2005
-+++ libgnome/gnome-program.c Mon Feb 21 23:35:17 2005
+--- libgnome/gnome-program.c.orig Mon May 31 16:37:02 2004
++++ libgnome/gnome-program.c Mon May 31 16:37:05 2004
@@ -895,17 +895,17 @@
attr_rel = "";
break;
@@ -68,12 +68,3 @@
search_path = FALSE;
break;
-@@ -1928,7 +1928,7 @@
- int argc, char **argv,
- guint nparams, GParameter *params)
- {
-- va_list args = 0;
-+ va_list args;
-
- return gnome_program_init_common (type, app_id, app_version, module_info,
- argc, argv, NULL, args, nparams, params);
diff --git a/x11/libgnome/pkg-plist b/x11/libgnome/pkg-plist
index a79ee22d3ec2..6a186eaadcac 100644
--- a/x11/libgnome/pkg-plist
+++ b/x11/libgnome/pkg-plist
@@ -19,34 +19,35 @@ include/libgnome-2.0/libgnome/libgnometypebuiltins.h
lib/bonobo/monikers/libmoniker_extra_2.so
lib/libgnome-2.a
lib/libgnome-2.so
-lib/libgnome-2.so.800
+lib/libgnome-2.so.1000
libdata/bonobo/servers/GNOME_Moniker_std.server
libdata/pkgconfig/libgnome-2.0.pc
-share/doc/libgnome/ch01s02.html
-share/doc/libgnome/ch01s03.html
-share/doc/libgnome/ch01s04.html
-share/doc/libgnome/ch01s05.html
-share/doc/libgnome/home.png
-share/doc/libgnome/index.html
-share/doc/libgnome/index.sgml
-share/doc/libgnome/left.png
-share/doc/libgnome/libgnome-gnome-config.html
-share/doc/libgnome/libgnome-gnome-exec.html
-share/doc/libgnome/libgnome-gnome-gconf.html
-share/doc/libgnome/libgnome-gnome-help.html
-share/doc/libgnome/libgnome-gnome-i18n.html
-share/doc/libgnome/libgnome-gnome-init.html
-share/doc/libgnome/libgnome-gnome-program.html
-share/doc/libgnome/libgnome-gnome-score.html
-share/doc/libgnome/libgnome-gnome-sound.html
-share/doc/libgnome/libgnome-gnome-triggers.html
-share/doc/libgnome/libgnome-gnome-url.html
-share/doc/libgnome/libgnome-gnome-util.html
-share/doc/libgnome/libgnome-libgnometypebuiltins.html
-share/doc/libgnome/libgnome.devhelp
-share/doc/libgnome/libgnome.html
-share/doc/libgnome/right.png
-share/doc/libgnome/up.png
+%%DOCSDIR%%/ch01s02.html
+%%DOCSDIR%%/ch01s03.html
+%%DOCSDIR%%/ch01s04.html
+%%DOCSDIR%%/ch01s05.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/libgnome-gnome-config.html
+%%DOCSDIR%%/libgnome-gnome-exec.html
+%%DOCSDIR%%/libgnome-gnome-gconf.html
+%%DOCSDIR%%/libgnome-gnome-help.html
+%%DOCSDIR%%/libgnome-gnome-i18n.html
+%%DOCSDIR%%/libgnome-gnome-init.html
+%%DOCSDIR%%/libgnome-gnome-program.html
+%%DOCSDIR%%/libgnome-gnome-score.html
+%%DOCSDIR%%/libgnome-gnome-sound.html
+%%DOCSDIR%%/libgnome-gnome-triggers.html
+%%DOCSDIR%%/libgnome-gnome-url.html
+%%DOCSDIR%%/libgnome-gnome-util.html
+%%DOCSDIR%%/libgnome-libgnometypebuiltins.html
+%%DOCSDIR%%/libgnome.devhelp
+%%DOCSDIR%%/libgnome.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
share/locale/am/LC_MESSAGES/libgnome-2.0.mo
share/locale/ar/LC_MESSAGES/libgnome-2.0.mo
share/locale/az/LC_MESSAGES/libgnome-2.0.mo
@@ -110,9 +111,10 @@ share/locale/tr/LC_MESSAGES/libgnome-2.0.mo
share/locale/uk/LC_MESSAGES/libgnome-2.0.mo
share/locale/vi/LC_MESSAGES/libgnome-2.0.mo
share/locale/wa/LC_MESSAGES/libgnome-2.0.mo
+share/locale/xh/LC_MESSAGES/libgnome-2.0.mo
share/locale/yi/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo
-@dirrm share/doc/libgnome
@dirrm include/libgnome-2.0/libgnome
@dirrm include/libgnome-2.0
+@dirrm %%DOCSDIR%%