aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-17 17:29:33 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-17 17:29:33 +0800
commit12fb4eeddfa077f957698882958f01673c573cce (patch)
tree6ebb751dd2f671ce39cea1d40e5c9a4ecd3d460a /x11/libgnome
parente8487c352a125ab2a361989ce5a26ba240806639 (diff)
downloadfreebsd-ports-gnome-12fb4eeddfa077f957698882958f01673c573cce.tar.gz
freebsd-ports-gnome-12fb4eeddfa077f957698882958f01673c573cce.tar.zst
freebsd-ports-gnome-12fb4eeddfa077f957698882958f01673c573cce.zip
Use USE_REINPLACE.
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 7e8c63675348..42951f527e5c 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -26,6 +26,7 @@ USE_XPM= yes
USE_GMAKE= yes
USE_ESOUND= yes
USE_BISON= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
@@ -37,11 +38,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
+ s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>