aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libxfce4menu/Makefile
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-05-08 23:46:07 +0800
committerolivierd <olivierd@FreeBSD.org>2013-05-08 23:46:07 +0800
commit125e22d506099a3b0b145fa738c3fe124c8662b6 (patch)
tree81813e0d247025b8be720c3a0b8f33d2157a2414 /x11/libxfce4menu/Makefile
parentaacc930fbefca98cd16c0d8611f2b3545449a267 (diff)
downloadfreebsd-ports-gnome-125e22d506099a3b0b145fa738c3fe124c8662b6.tar.gz
freebsd-ports-gnome-125e22d506099a3b0b145fa738c3fe124c8662b6.tar.zst
freebsd-ports-gnome-125e22d506099a3b0b145fa738c3fe124c8662b6.zip
- Replace post-patch target by patch (configure script)
- Remove ABI version in LIB_DEPENDS - Finish to convert USES - Remove desktopfileutils, because MimeType entry is not present in desktop file
Diffstat (limited to 'x11/libxfce4menu/Makefile')
-rw-r--r--x11/libxfce4menu/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 8ac2246679ce..832543525cfe 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libxfce4menu
PORTVERSION= 4.10.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11 xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
DISTNAME= libxfce4ui-${PORTVERSION}
@@ -15,14 +15,13 @@ COMMENT= Widgets library for the Xfce desktop environment
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= glib20 gnomehack gtk20 intltool intlhack desktopfileutils
+USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv libutil xfconf
INSTALLS_ICONS= yes
-USES= pkgconfig
+USES= pathfix pkgconfig
-CONFIGURE_ARGS= --disable-gtk-doc-html \
- --with-vendor-info=FreeBSD
+CONFIGURE_ARGS= --with-vendor-info=FreeBSD
OPTIONS_DEFINE= DOCS NLS NOTIFY GLADE
OPTIONS_DEFAULT= NOTIFY
@@ -47,23 +46,17 @@ PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MNOTIFY}
-LIB_DEPENDS+= startup-notification-1.0:${PORTSDIR}/x11/startup-notification
+LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
CONFIGURE_ARGS+=--enable-startup-notification
.else
CONFIGURE_ARGS+=--disable-startup-notification
.endif
.if ${PORT_OPTIONS:MGLADE}
-LIB_DEPENDS+= gladeui-1.10:${PORTSDIR}/devel/glade3
+LIB_DEPENDS+= gladeui-1:${PORTSDIR}/devel/glade3
CONFIGURE_ARGS+=--enable-gladeui
.else
CONFIGURE_ARGS+=--disable-gladeui
.endif
-post-patch:
-.if empty(PORT_OPTIONS:MNLS)
- @${REINPLACE_CMD} -e 's|docs \\|docs|' \
- -e 's|po||' ${WRKSRC}/Makefile.in
-.endif
-
.include <bsd.port.mk>