aboutsummaryrefslogtreecommitdiffstats
path: root/x11/metisse
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-07-23 19:28:40 +0800
committerdanfe <danfe@FreeBSD.org>2014-07-23 19:28:40 +0800
commitbfa6f86aa492888deef37d619f5d48d49bd4b69a (patch)
tree53addcd10504147797b070ed7fcc3df2901175b2 /x11/metisse
parentd8c8455fbae088d206533c0142eba1ee5f3c87d4 (diff)
downloadfreebsd-ports-gnome-bfa6f86aa492888deef37d619f5d48d49bd4b69a.tar.gz
freebsd-ports-gnome-bfa6f86aa492888deef37d619f5d48d49bd4b69a.tar.zst
freebsd-ports-gnome-bfa6f86aa492888deef37d619f5d48d49bd4b69a.zip
- Fix the build across the gang; stagify and undeprecate
- Update CONFLICTS, remove vestiges of Gnome 1.x support
Diffstat (limited to 'x11/metisse')
-rw-r--r--x11/metisse/Makefile37
-rw-r--r--x11/metisse/pkg-plist44
2 files changed, 54 insertions, 27 deletions
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index 4ac1526ae83e..e122fbbf85d3 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -12,31 +12,26 @@ COMMENT= Innovative X-based window system
LICENSE= GPLv3
-CONFLICTS= fvwm-1.* fvwm-2.5.*
-
-BROKEN= does not configure
-
-EXPIRATION_DATE= 2014-08-30
-DEPRECATED= Broken and not staged
+CONFLICTS= fvwm-1.* fvwm-2.*
LIB_DEPENDS= libNucleo.so:${PORTSDIR}/x11-toolkits/nucleo \
libpng15.so:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/libdata/xorg/fonts:${PORTSDIR}/x11-fonts/xorg-fonts
-USE_BZIP2= yes
+USES= gettext pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
-LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-fontdir=${LOCALBASE}/lib/X11/fonts
-MAKE_ARGS= METISSE_DOC_DIR="${DOCSDIR}"
-USES= pathfix gettext
-WANT_GNOME= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
USE_XORG= xcursor xft xinerama xpm xrender xt xtst
+WANT_GNOME= yes
+MAKE_ARGS= METISSE_DOC_DIR="${DOCSDIR}"
+
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= MMX GLX ATSPI STROKE RPLAY FRIBIDI GLIB GTK2 GCONF \
- GTK1 IMLIB GNOME
+ GTK1 IMLIB
OPTIONS_DEFINE_i386= GLX_X86
GLX_X86_DESC= GLX with x86 optimizations
@@ -46,12 +41,10 @@ GLIB_DESC= Use GLib 2.x for module integration
GTK2_DESC= Use GDK-PixBuf-2.0 for image loading
GTK1_DESC= Legacy GTK+ 1.2.x support
IMLIB_DESC= Imlib support in FvwmGtk
-GNOME_DESC= Legacy GNOME 1.4 support
OPTIONS_DEFAULT= MMX GLX
OPTIONS_DEFAULT_i386= GLX_X86
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${MACHINE_CPU:Mmmx} && ${PORT_OPTIONS:MMMX}
@@ -106,20 +99,8 @@ USE_GNOME+= gtk12
USE_GNOME+= imlib
.endif
-MAN1= FvwmAnimate.1 FvwmAuto.1 FvwmBacker.1 FvwmBanner.1 FvwmButtons.1 \
- FvwmCommand.1 FvwmConsole.1 FvwmConsoleC.pl.1 FvwmCpp.1 FvwmDebug.1 \
- FvwmDragWell.1 FvwmEvent.1 FvwmForm.1 FvwmGtkDebug.1 FvwmIconBox.1 \
- FvwmIconMan.1 FvwmIdent.1 FvwmM4.1 FvwmPager.1 FvwmPerl.1 \
- FvwmProxy.1 FvwmRearrange.1 FvwmSave.1 FvwmSaveDesk.1 FvwmScript.1 \
- FvwmScroll.1 FvwmTabs.1 FvwmTaskBar.1 FvwmTheme.1 FvwmWharf.1 \
- FvwmWinList.1 FvwmWindowMenu.1 fvwm-bug.1 fvwm-config.1 \
- fvwm-convert-2.4.1 fvwm-convert-2.6.1 fvwm-menu-desktop.1 \
- fvwm-menu-directory.1 fvwm-menu-headlines.1 fvwm-menu-xlock.1 \
- fvwm-perllib.1 fvwm-root.1 fvwm.1
-
_GTK= ${USE_GNOME:Mgtk12} ${USE_GNOME:Mimlib}
.if !empty(_GTK)
-MAN1+= FvwmGtk.1
PLIST_SUB+= GTK=""
.else
PLIST_SUB+= GTK="@comment "
@@ -136,5 +117,7 @@ post-patch: .SILENT
${REINPLACE_CMD} -e 's, install-gladeDATA,,' \
${WRKSRC}/fvwm-insitu/modules/FvwmConfig/Makefile.in
.endif
+ ${REINPLACE_CMD} -e 's,return;,return 0;,' \
+ ${WRKSRC}/fvwm-insitu/configure
.include <bsd.port.post.mk>
diff --git a/x11/metisse/pkg-plist b/x11/metisse/pkg-plist
index c3493d9708ec..26c44955b0d6 100644
--- a/x11/metisse/pkg-plist
+++ b/x11/metisse/pkg-plist
@@ -75,6 +75,50 @@ libexec/fvwm-insitu/2.5.20/FvwmWinList
libexec/fvwm-insitu/2.5.20/FvwmWindowMenu
@dirrm libexec/fvwm-insitu/2.5.20
@dirrm libexec/fvwm-insitu
+man/man1/FvwmAnimate.1.gz
+man/man1/FvwmAuto.1.gz
+man/man1/FvwmBacker.1.gz
+man/man1/FvwmBanner.1.gz
+man/man1/FvwmButtons.1.gz
+man/man1/FvwmCommand.1.gz
+man/man1/FvwmConsole.1.gz
+man/man1/FvwmConsoleC.pl.1.gz
+man/man1/FvwmCpp.1.gz
+man/man1/FvwmDebug.1.gz
+man/man1/FvwmDragWell.1.gz
+man/man1/FvwmEvent.1.gz
+man/man1/FvwmForm.1.gz
+%%GTK%%man/man1/FvwmGtk.1.gz
+man/man1/FvwmGtkDebug.1.gz
+man/man1/FvwmIconBox.1.gz
+man/man1/FvwmIconMan.1.gz
+man/man1/FvwmIdent.1.gz
+man/man1/FvwmM4.1.gz
+man/man1/FvwmPager.1.gz
+man/man1/FvwmPerl.1.gz
+man/man1/FvwmProxy.1.gz
+man/man1/FvwmRearrange.1.gz
+man/man1/FvwmSave.1.gz
+man/man1/FvwmSaveDesk.1.gz
+man/man1/FvwmScript.1.gz
+man/man1/FvwmScroll.1.gz
+man/man1/FvwmTabs.1.gz
+man/man1/FvwmTaskBar.1.gz
+man/man1/FvwmTheme.1.gz
+man/man1/FvwmWharf.1.gz
+man/man1/FvwmWinList.1.gz
+man/man1/FvwmWindowMenu.1.gz
+man/man1/fvwm-bug.1.gz
+man/man1/fvwm-config.1.gz
+man/man1/fvwm-convert-2.4.1.gz
+man/man1/fvwm-convert-2.6.1.gz
+man/man1/fvwm-menu-desktop.1.gz
+man/man1/fvwm-menu-directory.1.gz
+man/man1/fvwm-menu-headlines.1.gz
+man/man1/fvwm-menu-xlock.1.gz
+man/man1/fvwm-perllib.1.gz
+man/man1/fvwm-root.1.gz
+man/man1/fvwm.1.gz
share/applications/fvwmi.desktop
share/applications/mini-fvwmi.desktop
share/applications/opale.desktop